aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-03-01 07:24:59 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-03-01 07:24:59 +0800
commit0282d1525716be347b881ec0b2f6e2f10e232220 (patch)
tree2fa91a5e63320707a19186aa90158bb4e6387320 /devel
parentf333afab88ae100e4d15689616abfadd1144f14e (diff)
downloadfreebsd-ports-gnome-0282d1525716be347b881ec0b2f6e2f10e232220.tar.gz
freebsd-ports-gnome-0282d1525716be347b881ec0b2f6e2f10e232220.tar.zst
freebsd-ports-gnome-0282d1525716be347b881ec0b2f6e2f10e232220.zip
- Fix build with clang
Diffstat (limited to 'devel')
-rw-r--r--devel/dotconf++/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/dotconf++/Makefile b/devel/dotconf++/Makefile
index 04527b55c362..2682ec94f118 100644
--- a/devel/dotconf++/Makefile
+++ b/devel/dotconf++/Makefile
@@ -7,16 +7,22 @@ CATEGORIES= devel
MASTER_SITES= SF \
http://voodoo.com.ua/dotconfpp/
-
MAINTAINER= ports@FreeBSD.org
COMMENT= Configuration file parser written in C++
+USES= compiler:env
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
${WRKSRC}/src/dotconfpp.h ${WRKSRC}/src/mempool.h
+.if ${COMPILER_TYPE} == "clang"
+ @${REINPLACE_CMD} -e 's|-fexpensive-optimizations||' \
+ ${WRKSRC}/src/example?/Makefile.in
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>