aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-03 21:40:53 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-03 21:40:53 +0800
commit034795c50ccb5cbb9076f0ba374ef4e0b6ae16c9 (patch)
treed6e95229bcf1bbc41fd51124a351511bcf2c80f3 /devel
parenta2be5bda6ddca099881ce1bc905200ad8ad87315 (diff)
downloadfreebsd-ports-gnome-034795c50ccb5cbb9076f0ba374ef4e0b6ae16c9.tar.gz
freebsd-ports-gnome-034795c50ccb5cbb9076f0ba374ef4e0b6ae16c9.tar.zst
freebsd-ports-gnome-034795c50ccb5cbb9076f0ba374ef4e0b6ae16c9.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'devel')
-rw-r--r--devel/gtgt/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/devel/gtgt/Makefile b/devel/gtgt/Makefile
index 5a7cc4111db3..ba7f4166cd53 100644
--- a/devel/gtgt/Makefile
+++ b/devel/gtgt/Makefile
@@ -11,6 +11,7 @@ COMMENT= General (or GNU) template generation tools
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+USES= shebangfix
NO_BUILD= yes
PORTDOCS= autoconf.html automake.html \
@@ -19,24 +20,17 @@ PORTDOCS= autoconf.html automake.html \
index.html libtool.html
PLIST_FILES= ${SCRIPTS:S/^/bin\//}
-SCRIPTS= gcng gptg gscg
+SHEBANG_FILES= scripts/gcng scripts/gptg scripts/gscg
-NO_STAGE= yes
-post-patch:
-.for file in ${SCRIPTS}
- @${REINPLACE_CMD} -e \
- 's|^#!.*|#!${LOCALBASE}/bin/bash|g' ${WRKSRC}/scripts/${file}
-.endfor
+OPTIONS_DEFINE= DOCS
do-install:
-.for file in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/${file} ${PREFIX}/bin
+.for f in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>