aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-27 21:58:49 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-27 21:58:49 +0800
commit0a600cf59bd54ff45047ced202a80f8ebffc82d3 (patch)
tree14fc67956a989bda911c310a84f9ce76e60412ed /devel
parent2e36211a4e3887de36c29a5372e1389216746923 (diff)
downloadfreebsd-ports-gnome-0a600cf59bd54ff45047ced202a80f8ebffc82d3.tar.gz
freebsd-ports-gnome-0a600cf59bd54ff45047ced202a80f8ebffc82d3.tar.zst
freebsd-ports-gnome-0a600cf59bd54ff45047ced202a80f8ebffc82d3.zip
Support staging
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-gdb/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/avr-gdb/Makefile b/devel/avr-gdb/Makefile
index b9b76bfc1f22..63f083d7990f 100644
--- a/devel/avr-gdb/Makefile
+++ b/devel/avr-gdb/Makefile
@@ -5,7 +5,7 @@ PORTNAME= gdb
PORTVERSION= 7.3.1
PORTREVISION= 3
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITES= GNU
MASTER_SITE_SUBDIR= gdb
PKGNAMEPREFIX= avr-
DISTNAME= gdb-${PORTVERSION}
@@ -13,17 +13,17 @@ DISTNAME= gdb-${PORTVERSION}
MAINTAINER= joerg@FreeBSD.org
COMMENT= GNU GDB for the AVR target
-USE_GMAKE= yes
+USES= gmake
USE_BZIP2= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr --program-prefix=avr --disable-nls
-NO_STAGE= yes
pre-configure:
cd ${WRKSRC} ; ${RM} -rf dejagnu expect tcl texinfo
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb \
- ${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
+ ${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
.include <bsd.port.mk>