aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-03-11 10:20:10 +0800
committervanilla <vanilla@FreeBSD.org>2015-03-11 10:20:10 +0800
commit0c5f2237a3684d3f0518f706731af9a77f0768b3 (patch)
tree79c3206b7ef0c6431db1f3c406a68473a33737f1 /devel
parent257cf003a14b470653026ba3b76bdea13b16405f (diff)
downloadfreebsd-ports-gnome-0c5f2237a3684d3f0518f706731af9a77f0768b3.tar.gz
freebsd-ports-gnome-0c5f2237a3684d3f0518f706731af9a77f0768b3.tar.zst
freebsd-ports-gnome-0c5f2237a3684d3f0518f706731af9a77f0768b3.zip
Add libCello 1.1.7, higher level programming in C.
PR: 198495 Submitted by: matthew.closson@gmail.com
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libCello/Makefile20
-rw-r--r--devel/libCello/distinfo2
-rw-r--r--devel/libCello/files/patch-Makefile13
-rw-r--r--devel/libCello/pkg-descr10
-rw-r--r--devel/libCello/pkg-plist27
6 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f124cd119057..505fd80f4b5e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -964,6 +964,7 @@
SUBDIR += lemon
SUBDIR += lfcbase
SUBDIR += lfcxml
+ SUBDIR += libCello
SUBDIR += libIDL
SUBDIR += libPropList
SUBDIR += libafterbase
diff --git a/devel/libCello/Makefile b/devel/libCello/Makefile
new file mode 100644
index 000000000000..ad0bed8ad2c1
--- /dev/null
+++ b/devel/libCello/Makefile
@@ -0,0 +1,20 @@
+# Created by: matthew.closson@gmail.com
+# $FreeBSD$
+
+PORTNAME= libCello
+PORTVERSION= 1.1.7
+CATEGORIES= devel
+MASTER_SITES= http://libcello.org/static/
+
+MAINTAINER= matthew.closson@gmail.com
+COMMENT= Higher level programming in C
+
+LICENSE= BSD2CLAUSE
+
+USES= dos2unix gmake
+DOS2UNIX_FILES= Makefile
+
+post-patch:
+ ${REINPLACE_CMD} -E 's| abs\(| labs\(|' ${WRKSRC}/src/*.c
+
+.include <bsd.port.mk>
diff --git a/devel/libCello/distinfo b/devel/libCello/distinfo
new file mode 100644
index 000000000000..f46b605f73b9
--- /dev/null
+++ b/devel/libCello/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libCello-1.1.7.tar.gz) = 2273fe8257109c2dd19054beecd83ddcc780ec565a1ad02721e24efa74082908
+SIZE (libCello-1.1.7.tar.gz) = 52793
diff --git a/devel/libCello/files/patch-Makefile b/devel/libCello/files/patch-Makefile
new file mode 100644
index 000000000000..213298e179cc
--- /dev/null
+++ b/devel/libCello/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2015-03-10 20:42:37 UTC
++++ Makefile
+@@ -42,8 +42,8 @@ else
+
+ CFLAGS += -fPIC
+
+- INSTALL_LIB = mkdir -p ${LIBDIR} && cp -f ${STATIC} ${LIBDIR}/$(STATIC)
+- INSTALL_INC = mkdir -p ${INCDIR} && cp -r include/* ${INCDIR}
++ INSTALL_LIB = mkdir -p ${DESTDIR}${LIBDIR} && cp -f ${STATIC} ${DESTDIR}${LIBDIR}/$(STATIC)
++ INSTALL_INC = mkdir -p ${DESTDIR}${INCDIR} && cp -r include/* ${DESTDIR}${INCDIR}
+ endif
+
+ ifeq ($(findstring clang,$(COMPILER)),clang)
diff --git a/devel/libCello/pkg-descr b/devel/libCello/pkg-descr
new file mode 100644
index 000000000000..20d184d55c27
--- /dev/null
+++ b/devel/libCello/pkg-descr
@@ -0,0 +1,10 @@
+Cello is a library that introduces higher level programming to C.
+
+Interfaces allow for structured design
+Duck Typing allows for generic functions
+Exceptions control error handling
+Constructors/Destructors aid memory management
+Syntactic Sugar increases readability
+C Library means excellent performance and integration
+
+WWW: http://libcello.org
diff --git a/devel/libCello/pkg-plist b/devel/libCello/pkg-plist
new file mode 100644
index 000000000000..f8369efab7e9
--- /dev/null
+++ b/devel/libCello/pkg-plist
@@ -0,0 +1,27 @@
+include/Cello/FunctionAuto.h
+include/Cello/Lambda.h
+include/Cello/Dictionary.h
+include/Cello/Map.h
+include/Cello/Reference.h
+include/Cello/LambdaCurry.h
+include/Cello/Table.h
+include/Cello/Format.h
+include/Cello/String.h
+include/Cello/Value.h
+include/Cello/Array.h
+include/Cello/Function.h
+include/Cello/Pool.h
+include/Cello/Tree.h
+include/Cello/Type.h
+include/Cello/List.h
+include/Cello/None.h
+include/Cello/Module.h
+include/Cello/Exception.h
+include/Cello/File.h
+include/Cello/Prelude.h
+include/Cello/Thread.h
+include/Cello/Char.h
+include/Cello/Bool.h
+include/Cello/Number.h
+include/Cello.h
+lib/libCello.a