aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2004-10-29 11:11:11 +0800
committerclsung <clsung@FreeBSD.org>2004-10-29 11:11:11 +0800
commit0c744810aad3d9cea83949f9e5b57398b0544fc2 (patch)
treee6fd7e58eb42077c6ef2e40b5aae90a1324146ff /devel
parentabbd644bf40494120dad6b20f48d8ad3d48c3664 (diff)
downloadfreebsd-ports-gnome-0c744810aad3d9cea83949f9e5b57398b0544fc2.tar.gz
freebsd-ports-gnome-0c744810aad3d9cea83949f9e5b57398b0544fc2.tar.zst
freebsd-ports-gnome-0c744810aad3d9cea83949f9e5b57398b0544fc2.zip
- perl extensions that hide and store warnings while running test scripts
PR: ports/73235 Submitted by: Alex Kapranoff <kappa AT rambler-co dot ru> Approved by: co-mentor (vanilla)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-NoWarnings/Makefile30
-rw-r--r--devel/p5-Test-NoWarnings/distinfo2
-rw-r--r--devel/p5-Test-NoWarnings/pkg-descr8
-rw-r--r--devel/p5-Test-NoWarnings/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 43f773ba4ef4..2d7e6343c1bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1005,6 +1005,7 @@
SUBDIR += p5-Test-Inline
SUBDIR += p5-Test-Manifest
SUBDIR += p5-Test-MockObject
+ SUBDIR += p5-Test-NoWarnings
SUBDIR += p5-Test-Pod
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Simple
diff --git a/devel/p5-Test-NoWarnings/Makefile b/devel/p5-Test-NoWarnings/Makefile
new file mode 100644
index 000000000000..20825905d824
--- /dev/null
+++ b/devel/p5-Test-NoWarnings/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Test-NoWarnings
+# Date created: May 12th 2004
+# Whom: Alex Kapranoff <alex@kapranoff.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-NoWarnings
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alex@kapranoff.ru
+COMMENT= Hide and store warnings while running test scripts
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Tester.pm:${PORTSDIR}/devel/p5-Test-Tester
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Test::NoWarnings.3
+
+post-patch:
+ @${PERL} -i -pe 'm/INSTALLDIRS\s+=>/ and $$_ = ""' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-NoWarnings/distinfo b/devel/p5-Test-NoWarnings/distinfo
new file mode 100644
index 000000000000..bf789fe3524a
--- /dev/null
+++ b/devel/p5-Test-NoWarnings/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-NoWarnings-0.07.tar.gz) = 5489cacf1beefa45d97db1e204d9e842
+SIZE (Test-NoWarnings-0.07.tar.gz) = 14464
diff --git a/devel/p5-Test-NoWarnings/pkg-descr b/devel/p5-Test-NoWarnings/pkg-descr
new file mode 100644
index 000000000000..c107e509d345
--- /dev/null
+++ b/devel/p5-Test-NoWarnings/pkg-descr
@@ -0,0 +1,8 @@
+This modules causes any warnings produced by test scripts to be
+captured and stored. It automatically adds an extra test that will run
+when your script ends to check that there were no warnings. If there
+were any warings, the test will give a "not ok" and diagnostics of
+where, when and what the warning was, including a stack trace of what
+was going on when the it occurred.
+
+WWW: http://search.cpan.org/dist/Test-NoWarnings/
diff --git a/devel/p5-Test-NoWarnings/pkg-plist b/devel/p5-Test-NoWarnings/pkg-plist
new file mode 100644
index 000000000000..aa0c2c4ad596
--- /dev/null
+++ b/devel/p5-Test-NoWarnings/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/NoWarnings/.packlist
+%%SITE_PERL%%/Test/NoWarnings.pm
+%%SITE_PERL%%/Test/NoWarnings/Warning.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/NoWarnings
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Test/NoWarnings
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true