aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-05-03 05:49:44 +0800
committerbapt <bapt@FreeBSD.org>2011-05-03 05:49:44 +0800
commit0eef6a47c23a415e860483c1e6c75254007cb15e (patch)
treec665f714f62e3c9e444892f54d549c91e31e59de /devel
parent5786a123b77d9c8fe5c2fb1f3b1cf8fb1db0e2c4 (diff)
downloadfreebsd-ports-gnome-0eef6a47c23a415e860483c1e6c75254007cb15e.tar.gz
freebsd-ports-gnome-0eef6a47c23a415e860483c1e6c75254007cb15e.tar.zst
freebsd-ports-gnome-0eef6a47c23a415e860483c1e6c75254007cb15e.zip
Removed kxl related ports
2011-05-01 devel/kxl: Upstream disapear and distfile is no more available games/geki2: Upstream disapear and distfile is no more available, depends on expired kxl [1] games/geki3: Upstream disapear and distfile is no more available, depends on expired kxl [1] games/grande: Upstream disapear and distfile is no more available, depends on expired kxl games/spacearyarya: Upstream disapear and distfile is no more available, depends on expired kxl Approved by: edwin@mavetju.org (maintainer) [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/kxl/Makefile28
-rw-r--r--devel/kxl/distinfo3
-rw-r--r--devel/kxl/files/patch-aa57
-rw-r--r--devel/kxl/files/patch-ab9
-rw-r--r--devel/kxl/files/patch-src__KXL.h10
-rw-r--r--devel/kxl/files/patch-src__KXLjoystick.c40
-rw-r--r--devel/kxl/pkg-descr5
-rw-r--r--devel/kxl/pkg-plist6
9 files changed, 0 insertions, 159 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1cdb9cd883d6..bf22640feb4f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -704,7 +704,6 @@
SUBDIR += kodos
SUBDIR += kprof
SUBDIR += kscope
- SUBDIR += kxl
SUBDIR += kyra
SUBDIR += lasi
SUBDIR += lbpp
diff --git a/devel/kxl/Makefile b/devel/kxl/Makefile
deleted file mode 100644
index 5e9e5ac8d2f0..000000000000
--- a/devel/kxl/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# New ports collection makefile for: kxl
-# Date created: 16 June 2001
-# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= kxl
-PORTVERSION= 1.1.7
-PORTREVISION= 3
-CATEGORIES= devel games
-MASTER_SITES= http://kxl.orz.hm/download/
-DISTNAME= KXL-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A visual, sound library for games
-
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
-
-USE_AUTOTOOLS= libtool
-USE_XORG= xpm x11
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-.include <bsd.port.mk>
diff --git a/devel/kxl/distinfo b/devel/kxl/distinfo
deleted file mode 100644
index c10309031a4c..000000000000
--- a/devel/kxl/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (KXL-1.1.7.tar.gz) = 321bfad9dee29840656225b54bb6feb0
-SHA256 (KXL-1.1.7.tar.gz) = 118b704befa24992031b51c9da1bc3786da153cfb21a0452bae97b1d479bdd98
-SIZE (KXL-1.1.7.tar.gz) = 192070
diff --git a/devel/kxl/files/patch-aa b/devel/kxl/files/patch-aa
deleted file mode 100644
index 046035d8c6b9..000000000000
--- a/devel/kxl/files/patch-aa
+++ /dev/null
@@ -1,57 +0,0 @@
---- src/KXLsound.c.orig Fri Jan 17 01:29:09 2003
-+++ src/KXLsound.c Wed Oct 5 12:13:08 2005
-@@ -3,7 +3,6 @@
- #include <fcntl.h>
- #include <sys/ioctl.h>
- #include <sys/time.h>
--#include <linux/soundcard.h>
- #include "KXL.h"
-
- #define MIN(a, b) (((a) < (b)) ? (a) : (b))
-@@ -45,6 +44,7 @@
- //==============================================================
- void KXL_SoundServer(void)
- {
-+#ifndef __FreeBSD__
- Uint16 i;
- KXL_SoundControl Command;
- fd_set sound_fdset;
-@@ -163,6 +163,7 @@
- }
- }
- }
-+#endif
- }
-
- //==============================================================
-@@ -239,6 +240,7 @@
- //==============================================================
- void KXL_InitSound(Uint8 *path, Uint8 **fname)
- {
-+#ifndef __FreeBSD__
- KXL_SoundOk = False;
-
- KXL_LoadSoundData(path, fname);
-@@ -266,6 +268,7 @@
- close(KXL_SoundData.Pipe[0]);
- KXL_SoundOk = True;
- }
-+#endif
- }
-
- //==============================================================
-@@ -273,6 +276,7 @@
- //==============================================================
- void KXL_EndSound(void)
- {
-+#ifndef __FreeBSD__
- while (KXL_SoundData.ListCnt)
- KXL_Free(KXL_wavelist[-- KXL_SoundData.ListCnt].Data);
- KXL_Free(KXL_wavelist);
-@@ -282,5 +286,6 @@
- KXL_PlaySound(0, KXL_SOUND_STOP_ALL);
- kill(KXL_SoundData.ID, SIGTERM);
- }
-+#endif
- }
-
diff --git a/devel/kxl/files/patch-ab b/devel/kxl/files/patch-ab
deleted file mode 100644
index 089ad4dd4176..000000000000
--- a/devel/kxl/files/patch-ab
+++ /dev/null
@@ -1,9 +0,0 @@
---- src/KXLmisc.c.orig Sun Jan 20 01:10:31 2002
-+++ src/KXLmisc.c Sat Mar 30 19:26:06 2002
-@@ -1,6 +1,5 @@
- #include <stdio.h>
- #include <stdlib.h>
--#include <malloc.h>
- #include <signal.h>
- #include <sys/time.h>
- #include "KXL.h"
diff --git a/devel/kxl/files/patch-src__KXL.h b/devel/kxl/files/patch-src__KXL.h
deleted file mode 100644
index f355b4da9628..000000000000
--- a/devel/kxl/files/patch-src__KXL.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/KXL.h.orig Wed Oct 5 12:14:12 2005
-+++ src/KXL.h Wed Oct 5 12:14:18 2005
-@@ -4,7 +4,6 @@
- #include <stdio.h>
- #include <X11/Xlib.h>
- #include <X11/Xutil.h>
--#include <linux/joystick.h>
-
-
- //================================================================
diff --git a/devel/kxl/files/patch-src__KXLjoystick.c b/devel/kxl/files/patch-src__KXLjoystick.c
deleted file mode 100644
index 6937bcd9ecc2..000000000000
--- a/devel/kxl/files/patch-src__KXLjoystick.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/KXLjoystick.c.orig Wed Oct 5 12:14:36 2005
-+++ src/KXLjoystick.c Wed Oct 5 12:15:19 2005
-@@ -11,24 +11,7 @@
- // return value : True - ok, False - NG
- //==============================================================
- Bool KXL_OpenJoystick(Uint8 *devname) {
-- Uint8 name[128] = "Unknown";
-- Sint32 version = 0x000800;
-- Uint8 axis = 2;
-- Uint8 buttons = 2;
--
-- KXL_joydev = open(devname, O_RDONLY);
-- if (KXL_joydev < 0) {
-- fprintf(stderr, "KXL error message\nCannot open \"%s\".\n", devname);
-- return False;
-- }
-- ioctl(KXL_joydev, JSIOCGVERSION, &version);
-- ioctl(KXL_joydev, JSIOCGAXES, &axis);
-- ioctl(KXL_joydev, JSIOCGBUTTONS, &buttons);
-- ioctl(KXL_joydev, JSIOCGNAME(128), name);
-- //fcntl(KXL_joydev, F_SETFL, O_NONBLOCK);
-- fprintf(stderr, "KXL message\nJoystick (%s) has %d axes and %d buttons.\nDriver version is %d.%d.%d.\n",
-- name, axis, buttons, version >> 16, (version >> 8) & 0xff, version & 0xff);
-- return True;
-+ return False;
- }
-
- //==============================================================
-@@ -46,11 +29,4 @@
- // return value : True - ok, False - NG
- //==============================================================
- Bool KXL_ReadJoystick(KXL_Joystick *my) {
-- if (KXL_joydev >= 0) {
-- if (read(KXL_joydev, my, JS_RETURN) == JS_RETURN) {
-- return True;
-- }
-- }
-- fprintf(stderr, "KXL error message\njoystick reading error\n");
-- return False;
- }
diff --git a/devel/kxl/pkg-descr b/devel/kxl/pkg-descr
deleted file mode 100644
index 6dc687d4263a..000000000000
--- a/devel/kxl/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-a visual, sound library for games
-
-Sound is not available on FreeBSD.
-
-WWW: http://kxl.orz.hm/
diff --git a/devel/kxl/pkg-plist b/devel/kxl/pkg-plist
deleted file mode 100644
index cc35666f5419..000000000000
--- a/devel/kxl/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-include/KXL.h
-lib/libKXL-1.1.7.so
-lib/libKXL.so
-lib/libKXL.a
-lib/libKXL.la
-share/aclocal/KXL.m4