aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-22 19:13:02 +0800
committermarino <marino@FreeBSD.org>2014-05-22 19:13:02 +0800
commit16e0a2ccc7f2a7755d128b296343e88bec6102a0 (patch)
tree333cbe3370c8b26a0932eb066767fa30afcec31a /devel
parent9077dd2c34546c8e077b40b36e36290c7d31a339 (diff)
downloadfreebsd-ports-gnome-16e0a2ccc7f2a7755d128b296343e88bec6102a0.tar.gz
freebsd-ports-gnome-16e0a2ccc7f2a7755d128b296343e88bec6102a0.tar.zst
freebsd-ports-gnome-16e0a2ccc7f2a7755d128b296343e88bec6102a0.zip
Add new Ada port: devel/gnatcoll
These components are a major building block of the GNAT Programming Studio. As the package description below states, it can also be used generically. This splits GNATColl out prior to GPS version upgrade. ================================================================= The reusable library known as the GNAT Component Collection (GNATColl) is based on one main principle: general-purpose packages that are part of the GNAT technology should also be available to user application code. The compiler front end, the GNAT Programming Studio (GPS) Interactive Development Environment, and the GNAT Tracker web-based interface all served as sources for the components. The GNATColl components complement the predefined Ada and GNAT libraries and deal with a range of common programming issues including string and text processing, memory management, and file handling. Several of the components are especially useful in enterprise applications. * Scripts: Embedding script languages * Traces: Logging information * Memory: Monitoring memory usage * Mmap: Reading and writing files * Boyer-Moore: Searching strings * Paragraph filling: Formatting text * Templates: Generating text * Email: Processing email messages * Ravenscar: Patterns for multitasking * VFS: Manipulating files * Storage Pools: Controlling memory mgmt * Tribooleans: Three-state logic * Geometry: Primitive geometric ops * Refcount: Reference counting * Projects: Manipulating ``gpr`` files * Config: Parsing configuration files * Pools: Controlling access to resources * JSON: JavaScript Object Notation * SQL: Database interface WWW: http://libre.adacore.com/tools/gnat-component-collection
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gnatcoll/Makefile112
-rw-r--r--devel/gnatcoll/distinfo2
-rw-r--r--devel/gnatcoll/files/patch-src_gnatcoll__iconv.gpr12
-rw-r--r--devel/gnatcoll/files/patch-src_gnatcoll__readline.gpr.in21
-rw-r--r--devel/gnatcoll/files/patch-src_gnatcoll__tools.gpr13
-rw-r--r--devel/gnatcoll/pkg-descr24
-rw-r--r--devel/gnatcoll/pkg-plist312
8 files changed, 497 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1c9bc2f3a9fe..c9387754a38f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -577,6 +577,7 @@
SUBDIR += glrparser
SUBDIR += glui
SUBDIR += gmake
+ SUBDIR += gnatcoll
SUBDIR += gnatpython
SUBDIR += gnome-common
SUBDIR += gnome-js-common
diff --git a/devel/gnatcoll/Makefile b/devel/gnatcoll/Makefile
new file mode 100644
index 000000000000..24759d1c38ed
--- /dev/null
+++ b/devel/gnatcoll/Makefile
@@ -0,0 +1,112 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnatcoll
+PORTVERSION= 2014
+CATEGORIES= devel
+MASTER_SITES= http://downloads.dragonlace.net/src/
+DISTNAME= ${PORTNAME}-gpl-${PORTVERSION}-src
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= GNAT Component Collection from Adacore
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
+ gnat_util>=20140422:${PORTSDIR}/lang/gnat_util
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+
+USES= ada gmake
+GNU_CONFIGURE= yes
+PORTDOCS= html gnatcoll.pdf
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= READLINE SYSLOG SQLITE PYTHON GTK PGSQL ICONV \
+ DOCS EXAMPLES
+OPTIONS_DEFAULT= READLINE SYSLOG SQLITE PYTHON GTK PGSQL ICONV
+OPTIONS_SUB= yes
+DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+GTK_LIB_DEPENDS= libgtkada.so:${PORTSDIR}/x11-toolkits/gtkada3
+SYSLOG_CONFIGURE_ENABLE=syslog
+
+GTK_DESC= GTK3 toolkit support
+
+CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-aux-${OPSYS:tl}${OSREL}
+CONFIGURE_ARGS= --with-gmp=${PREFIX} \
+ --disable-shared \
+ --disable-pygtk
+
+MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER}
+MAKE_ARGS+= Gnatcoll_Build=Production
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MREADLINE}
+USES+= readline:port
+CONFIGURE_ARGS+= --enable-gpl
+.else
+CONFIGURE_ARGS+= --disable-readline
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+CONFIGURE_ARGS+= --with-sqlite=embedded
+.else
+CONFIGURE_ARGS+= --without-sqlite
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USES+= pgsql
+CONFIGURE_ARGS+= --with-postgresql=${PREFIX}
+.else
+CONFIGURE_ARGS+= --without-postgresql
+.endif
+
+.if ${PORT_OPTIONS:MICONV}
+USES+= iconv
+CONFIGURE_ARGS+= --with-iconv=${ICONV_PREFIX}
+.else
+CONFIGURE_ARGS+= --with-iconv
+.endif
+
+.if ${PORT_OPTIONS:MPYTHON}
+CONFIGURE_ARGS+= --with-python=${PREFIX} \
+ --enable-pygobject
+USE_PYTHON= 2
+USE_GNOME= pygobject3
+PYCOMPILE= ${PREFIX}/lib/${PYTHON_VERSION}/compileall.py
+.else
+CONFIGURE_ARGS+= --without-python \
+ --disable-pygobject
+.endif
+
+.if ${PORT_OPTIONS:MGTK}
+USES+= pkgconfig
+CONFIGURE_ARGS+= --with-gtk=3.0
+.else
+CONFIGURE_ARGS+= --without-gtk
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|@PREFIX@|${PREFIX}|g" \
+ ${WRKSRC}/src/gnatcoll_readline.gpr.in
+.if ! ${PORT_OPTIONS:MDOCS}
+ ${MV} ${WRKSRC}/docs/_build ${WRKSRC}/docs/_hide_build
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET}
+
+pre-install:
+.if ${PORT_OPTIONS:MPYTHON}
+ ${PYTHON_CMD} ${PYCOMPILE} ${WRKSRC}/share/plug-ins
+ ${PYTHON_CMD} ${PYCOMPILE} ${WRKSRC}/share/library
+.endif
+
+post-install:
+ ${RM} -rf ${STAGEDIR}${DOCSDIR}/html/_sources
+.if ! ${PORT_OPTIONS:MEXAMPLES}
+ ${RM} -rf ${STAGEDIR}${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/gnatcoll/distinfo b/devel/gnatcoll/distinfo
new file mode 100644
index 000000000000..3e2e619a64fa
--- /dev/null
+++ b/devel/gnatcoll/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnatcoll-gpl-2014-src.tar.gz) = 3a631c2d6b7569ac6821c91d276c93a09ceaf1caf9441ffca4cbe162b7b533e6
+SIZE (gnatcoll-gpl-2014-src.tar.gz) = 5398895
diff --git a/devel/gnatcoll/files/patch-src_gnatcoll__iconv.gpr b/devel/gnatcoll/files/patch-src_gnatcoll__iconv.gpr
new file mode 100644
index 000000000000..ac755752cdf6
--- /dev/null
+++ b/devel/gnatcoll/files/patch-src_gnatcoll__iconv.gpr
@@ -0,0 +1,12 @@
+--- src/gnatcoll_iconv.gpr.orig 2014-04-10 13:47:58.000000000 +0000
++++ src/gnatcoll_iconv.gpr
+@@ -27,7 +27,8 @@ project GnatColl_Iconv is
+ package Compiler is
+ for Switches ("Ada") use GnatColl_Shared.Compiler'Switches ("Ada");
+ for Switches ("C") use GnatColl_Shared.Compiler'Switches ("C")
+- & GnatColl_Shared.Iconv_Include;
++ & ("-nostdinc") & GnatColl_Shared.Iconv_Include
++ & ("-I/usr/include");
+ end Compiler;
+
+ package Builder renames GnatColl_Shared.Builder;
diff --git a/devel/gnatcoll/files/patch-src_gnatcoll__readline.gpr.in b/devel/gnatcoll/files/patch-src_gnatcoll__readline.gpr.in
new file mode 100644
index 000000000000..db54f3d25baf
--- /dev/null
+++ b/devel/gnatcoll/files/patch-src_gnatcoll__readline.gpr.in
@@ -0,0 +1,21 @@
+--- src/gnatcoll_readline.gpr.in.orig 2014-04-10 13:47:58.000000000 +0000
++++ src/gnatcoll_readline.gpr.in
+@@ -6,7 +6,7 @@ project GnatColl_Readline is
+ when "yes" =>
+ for Languages use ("Ada");
+ for Source_Dirs use ("readline", "readline/with_readline");
+- for Library_Options use ("-lreadline");
++ for Library_Options use ("-L@PREFIX@/lib", "-lreadline");
+ when "no" =>
+ for Source_Dirs use ("readline", "readline/no_readline");
+ end case;
+@@ -26,7 +26,8 @@ project GnatColl_Readline is
+ package Linker is
+ -- When linking an executable
+ case Gnatcoll_Shared.Readline is
+- when "yes" => for Linker_Options use ("-lreadline");
++ when "yes" => for Linker_Options use ("-rpath=@PREFIX@/lib",
++ "-L@PREFIX@/lib", "-lreadline");
+ when "no" => null;
+ end case;
+ end Linker;
diff --git a/devel/gnatcoll/files/patch-src_gnatcoll__tools.gpr b/devel/gnatcoll/files/patch-src_gnatcoll__tools.gpr
new file mode 100644
index 000000000000..874562d2d597
--- /dev/null
+++ b/devel/gnatcoll/files/patch-src_gnatcoll__tools.gpr
@@ -0,0 +1,13 @@
+--- src/gnatcoll_tools.gpr.orig 2014-04-10 13:47:58.000000000 +0000
++++ src/gnatcoll_tools.gpr
+@@ -33,6 +33,9 @@ project GnatColl_Tools is
+ package Compiler renames GnatColl_Shared.Compiler;
+ package Binder renames GnatColl_Shared.Binder;
+ package Ide renames GnatColl_Shared.Ide;
+- package Linker renames GnatColl_Shared.Linker;
++ package Linker is
++ for Leading_Switches ("Ada") use ("gnatcoll/static/set_std_prefix.o",
++ "gnatcoll/static/update_path.o");
++ end Linker;
+
+ end GnatColl_Tools;
diff --git a/devel/gnatcoll/pkg-descr b/devel/gnatcoll/pkg-descr
new file mode 100644
index 000000000000..aa1e0369f156
--- /dev/null
+++ b/devel/gnatcoll/pkg-descr
@@ -0,0 +1,24 @@
+The reusable library known as the GNAT Component Collection (GNATColl)
+is based on one main principle: general-purpose packages that are part of
+the GNAT technology should also be available to user application code.
+The compiler front end, the GNAT Programming Studio (GPS) Interactive
+Development Environment, and the GNAT Tracker web-based interface all
+served as sources for the components.
+
+The GNATColl components complement the predefined Ada and GNAT libraries
+and deal with a range of common programming issues including string and
+text processing, memory management, and file handling. Several of the
+components are especially useful in enterprise applications.
+
+* Scripts: Embedding script languages * Traces: Logging information
+* Memory: Monitoring memory usage * Mmap: Reading and writing files
+* Boyer-Moore: Searching strings * Paragraph filling: Formatting text
+* Templates: Generating text * Email: Processing email messages
+* Ravenscar: Patterns for multitasking * VFS: Manipulating files
+* Storage Pools: Controlling memory mgmt * Tribooleans: Three-state logic
+* Geometry: Primitive geometric ops * Refcount: Reference counting
+* Projects: Manipulating ``gpr`` files * Config: Parsing configuration files
+* Pools: Controlling access to resources * JSON: JavaScript Object Notation
+* SQL: Database interface
+
+WWW: http://libre.adacore.com/tools/gnat-component-collection
diff --git a/devel/gnatcoll/pkg-plist b/devel/gnatcoll/pkg-plist
new file mode 100644
index 000000000000..21fa4f9d4b4f
--- /dev/null
+++ b/devel/gnatcoll/pkg-plist
@@ -0,0 +1,312 @@
+bin/gnatcoll_db2ada
+bin/gnatinspect
+%%PYTHON%%include/gnatcoll/gnatcoll-any_types-python.adb
+%%PYTHON%%include/gnatcoll/gnatcoll-any_types-python.ads
+include/gnatcoll/gnatcoll-any_types.adb
+include/gnatcoll/gnatcoll-any_types.ads
+include/gnatcoll/gnatcoll-arg_lists.adb
+include/gnatcoll/gnatcoll-arg_lists.ads
+include/gnatcoll/gnatcoll-boyer_moore.adb
+include/gnatcoll/gnatcoll-boyer_moore.ads
+include/gnatcoll/gnatcoll-config.adb
+include/gnatcoll/gnatcoll-config.ads
+include/gnatcoll/gnatcoll-email-mailboxes.adb
+include/gnatcoll/gnatcoll-email-mailboxes.ads
+include/gnatcoll/gnatcoll-email-parser.adb
+include/gnatcoll/gnatcoll-email-parser.ads
+include/gnatcoll/gnatcoll-email-utils.adb
+include/gnatcoll/gnatcoll-email-utils.ads
+include/gnatcoll/gnatcoll-email.adb
+include/gnatcoll/gnatcoll-email.ads
+include/gnatcoll/gnatcoll-geometry.adb
+include/gnatcoll/gnatcoll-geometry.ads
+include/gnatcoll/gnatcoll-gmp-integers-io.adb
+include/gnatcoll/gnatcoll-gmp-integers-io.ads
+include/gnatcoll/gnatcoll-gmp-integers-misc.adb
+include/gnatcoll/gnatcoll-gmp-integers-misc.ads
+include/gnatcoll/gnatcoll-gmp-integers-number_theoretic.adb
+include/gnatcoll/gnatcoll-gmp-integers-number_theoretic.ads
+include/gnatcoll/gnatcoll-gmp-integers-random.adb
+include/gnatcoll/gnatcoll-gmp-integers-random.ads
+include/gnatcoll/gnatcoll-gmp-integers-root_extraction.adb
+include/gnatcoll/gnatcoll-gmp-integers-root_extraction.ads
+include/gnatcoll/gnatcoll-gmp-integers.adb
+include/gnatcoll/gnatcoll-gmp-integers.ads
+include/gnatcoll/gnatcoll-gmp-lib.ads
+include/gnatcoll/gnatcoll-gmp-random_state.adb
+include/gnatcoll/gnatcoll-gmp-random_state.ads
+include/gnatcoll/gnatcoll-gmp.ads
+include/gnatcoll/gnatcoll-iconv.adb
+include/gnatcoll/gnatcoll-iconv.ads
+include/gnatcoll/gnatcoll-io-native-codec__unix.adb
+include/gnatcoll/gnatcoll-io-native-codec__win32.adb
+include/gnatcoll/gnatcoll-io-native.adb
+include/gnatcoll/gnatcoll-io-native.ads
+include/gnatcoll/gnatcoll-io-remote-unix.adb
+include/gnatcoll/gnatcoll-io-remote-unix.ads
+include/gnatcoll/gnatcoll-io-remote-windows.adb
+include/gnatcoll/gnatcoll-io-remote-windows.ads
+include/gnatcoll/gnatcoll-io-remote.adb
+include/gnatcoll/gnatcoll-io-remote.ads
+include/gnatcoll/gnatcoll-io.adb
+include/gnatcoll/gnatcoll-io.ads
+include/gnatcoll/gnatcoll-json-utility.adb
+include/gnatcoll/gnatcoll-json-utility.ads
+include/gnatcoll/gnatcoll-json.adb
+include/gnatcoll/gnatcoll-json.ads
+include/gnatcoll/gnatcoll-memory.adb
+include/gnatcoll/gnatcoll-memory.ads
+include/gnatcoll/gnatcoll-mmap-system__unix.adb
+include/gnatcoll/gnatcoll-mmap-system__unix.ads
+include/gnatcoll/gnatcoll-mmap-system__win32.adb
+include/gnatcoll/gnatcoll-mmap-system__win32.ads
+include/gnatcoll/gnatcoll-mmap.adb
+include/gnatcoll/gnatcoll-mmap.ads
+include/gnatcoll/gnatcoll-paragraph_filling-badnesses.adb
+include/gnatcoll/gnatcoll-paragraph_filling-badnesses.ads
+include/gnatcoll/gnatcoll-paragraph_filling-words.adb
+include/gnatcoll/gnatcoll-paragraph_filling-words.ads
+include/gnatcoll/gnatcoll-paragraph_filling.adb
+include/gnatcoll/gnatcoll-paragraph_filling.ads
+include/gnatcoll/gnatcoll-path.adb
+include/gnatcoll/gnatcoll-path.ads
+include/gnatcoll/gnatcoll-pools.adb
+include/gnatcoll/gnatcoll-pools.ads
+include/gnatcoll/gnatcoll-projects-aux.adb
+include/gnatcoll/gnatcoll-projects-aux.ads
+include/gnatcoll/gnatcoll-projects-normalize.adb
+include/gnatcoll/gnatcoll-projects-normalize.ads
+include/gnatcoll/gnatcoll-projects.adb
+include/gnatcoll/gnatcoll-projects.ads
+include/gnatcoll/gnatcoll-python.adb
+include/gnatcoll/gnatcoll-python.ads
+include/gnatcoll/gnatcoll-ravenscar-multiple_queue_cyclic_server.adb
+include/gnatcoll/gnatcoll-ravenscar-multiple_queue_cyclic_server.ads
+include/gnatcoll/gnatcoll-ravenscar-multiple_queue_sporadic_server.adb
+include/gnatcoll/gnatcoll-ravenscar-multiple_queue_sporadic_server.ads
+include/gnatcoll/gnatcoll-ravenscar-simple_cyclic_task.adb
+include/gnatcoll/gnatcoll-ravenscar-simple_cyclic_task.ads
+include/gnatcoll/gnatcoll-ravenscar-simple_sporadic_task.adb
+include/gnatcoll/gnatcoll-ravenscar-simple_sporadic_task.ads
+include/gnatcoll/gnatcoll-ravenscar-sporadic_server.adb
+include/gnatcoll/gnatcoll-ravenscar-sporadic_server.ads
+include/gnatcoll/gnatcoll-ravenscar-sporadic_server_with_callback.adb
+include/gnatcoll/gnatcoll-ravenscar-sporadic_server_with_callback.ads
+include/gnatcoll/gnatcoll-ravenscar-timed_out_sporadic_server.adb
+include/gnatcoll/gnatcoll-ravenscar-timed_out_sporadic_server.ads
+include/gnatcoll/gnatcoll-ravenscar-timers-one_shot_timer.adb
+include/gnatcoll/gnatcoll-ravenscar-timers-one_shot_timer.ads
+include/gnatcoll/gnatcoll-ravenscar-timers.ads
+include/gnatcoll/gnatcoll-ravenscar-utils.adb
+include/gnatcoll/gnatcoll-ravenscar-utils.ads
+include/gnatcoll/gnatcoll-ravenscar.ads
+include/gnatcoll/gnatcoll-readline.adb
+include/gnatcoll/gnatcoll-readline.ads
+include/gnatcoll/gnatcoll-refcount-sync_counters.adb
+include/gnatcoll/gnatcoll-refcount-weakref.adb
+include/gnatcoll/gnatcoll-refcount-weakref.ads
+include/gnatcoll/gnatcoll-refcount.adb
+include/gnatcoll/gnatcoll-refcount.ads
+include/gnatcoll/gnatcoll-remote-db.adb
+include/gnatcoll/gnatcoll-remote-db.ads
+include/gnatcoll/gnatcoll-remote.ads
+%%GTK%%include/gnatcoll/gnatcoll-scripts-gtkada.adb
+%%GTK%%include/gnatcoll/gnatcoll-scripts-gtkada.ads
+include/gnatcoll/gnatcoll-scripts-impl.adb
+include/gnatcoll/gnatcoll-scripts-impl.ads
+%%GTK%%include/gnatcoll/gnatcoll-scripts-python-gtkada.adb
+%%GTK%%include/gnatcoll/gnatcoll-scripts-python-gtkada.ads
+include/gnatcoll/gnatcoll-scripts-python.adb
+include/gnatcoll/gnatcoll-scripts-python.ads
+include/gnatcoll/gnatcoll-scripts-shell.adb
+include/gnatcoll/gnatcoll-scripts-shell.ads
+include/gnatcoll/gnatcoll-scripts-utils.adb
+include/gnatcoll/gnatcoll-scripts-utils.ads
+include/gnatcoll/gnatcoll-scripts.adb
+include/gnatcoll/gnatcoll-scripts.ads
+include/gnatcoll/gnatcoll-sql-exec-tasking.adb
+include/gnatcoll/gnatcoll-sql-exec-tasking.ads
+include/gnatcoll/gnatcoll-sql-exec.adb
+include/gnatcoll/gnatcoll-sql-exec.ads
+include/gnatcoll/gnatcoll-sql-exec_private.adb
+include/gnatcoll/gnatcoll-sql-exec_private.ads
+include/gnatcoll/gnatcoll-sql-inspect.adb
+include/gnatcoll/gnatcoll-sql-inspect.ads
+include/gnatcoll/gnatcoll-sql-orm-impl.adb
+include/gnatcoll/gnatcoll-sql-orm-impl.ads
+include/gnatcoll/gnatcoll-sql-orm.adb
+include/gnatcoll/gnatcoll-sql-orm.ads
+include/gnatcoll/gnatcoll-sql-postgres-builder.adb
+include/gnatcoll/gnatcoll-sql-postgres-builder.ads
+%%PGSQL%%include/gnatcoll/gnatcoll-sql-postgres-gnade.adb
+%%PGSQL%%include/gnatcoll/gnatcoll-sql-postgres-gnade.ads
+include/gnatcoll/gnatcoll-sql-postgres.adb
+include/gnatcoll/gnatcoll-sql-postgres.ads
+include/gnatcoll/gnatcoll-sql-sessions.adb
+include/gnatcoll/gnatcoll-sql-sessions.ads
+include/gnatcoll/gnatcoll-sql-sqlite-builder.adb
+include/gnatcoll/gnatcoll-sql-sqlite-builder.ads
+%%SQLITE%%include/gnatcoll/gnatcoll-sql-sqlite-gnade.adb
+%%SQLITE%%include/gnatcoll/gnatcoll-sql-sqlite-gnade.ads
+include/gnatcoll/gnatcoll-sql-sqlite.adb
+include/gnatcoll/gnatcoll-sql-sqlite.ads
+include/gnatcoll/gnatcoll-sql.adb
+include/gnatcoll/gnatcoll-sql.ads
+include/gnatcoll/gnatcoll-sql_impl.adb
+include/gnatcoll/gnatcoll-sql_impl.ads
+include/gnatcoll/gnatcoll-storage_pools-alignment.adb
+include/gnatcoll/gnatcoll-storage_pools-alignment.ads
+include/gnatcoll/gnatcoll-storage_pools.ads
+include/gnatcoll/gnatcoll-symbols.adb
+include/gnatcoll/gnatcoll-symbols.ads
+include/gnatcoll/gnatcoll-templates.adb
+include/gnatcoll/gnatcoll-templates.ads
+include/gnatcoll/gnatcoll-terminal.adb
+include/gnatcoll/gnatcoll-terminal.ads
+include/gnatcoll/gnatcoll-traces-syslog.adb
+include/gnatcoll/gnatcoll-traces-syslog.ads
+include/gnatcoll/gnatcoll-traces.adb
+include/gnatcoll/gnatcoll-traces.ads
+include/gnatcoll/gnatcoll-tribooleans.adb
+include/gnatcoll/gnatcoll-tribooleans.ads
+include/gnatcoll/gnatcoll-utils.adb
+include/gnatcoll/gnatcoll-utils.ads
+%%GTK%%include/gnatcoll/gnatcoll-vfs-gtkada.adb
+%%GTK%%include/gnatcoll/gnatcoll-vfs-gtkada.ads
+include/gnatcoll/gnatcoll-vfs.adb
+include/gnatcoll/gnatcoll-vfs.ads
+include/gnatcoll/gnatcoll-vfs_types.ads
+include/gnatcoll/gnatcoll-vfs_utils.adb
+include/gnatcoll/gnatcoll-vfs_utils.ads
+include/gnatcoll/gnatcoll-xref.adb
+include/gnatcoll/gnatcoll-xref.ads
+include/gnatcoll/gnatcoll.ads
+lib/gnat/gnatcoll.gpr
+lib/gnat/gnatcoll/gnatcoll.lgpr
+lib/gnat/gnatcoll/gnatcoll_gmp.lgpr
+%%GTK%%lib/gnat/gnatcoll/gnatcoll_gtk.lgpr
+lib/gnat/gnatcoll/gnatcoll_iconv.lgpr
+lib/gnat/gnatcoll/gnatcoll_postgres.lgpr
+lib/gnat/gnatcoll/gnatcoll_python.lgpr
+lib/gnat/gnatcoll/gnatcoll_readline.lgpr
+lib/gnat/gnatcoll/gnatcoll_sqlite.lgpr
+lib/gnat/gnatcoll_gmp.gpr
+lib/gnat/gnatcoll_gtk.gpr
+lib/gnat/gnatcoll_iconv.gpr
+lib/gnat/gnatcoll_postgres.gpr
+lib/gnat/gnatcoll_python.gpr
+lib/gnat/gnatcoll_readline.gpr
+lib/gnat/gnatcoll_sqlite.gpr
+%%PYTHON%%lib/gnatcoll/static/gnatcoll-any_types-python.ali
+lib/gnatcoll/static/gnatcoll-any_types.ali
+lib/gnatcoll/static/gnatcoll-arg_lists.ali
+lib/gnatcoll/static/gnatcoll-boyer_moore.ali
+lib/gnatcoll/static/gnatcoll-config.ali
+lib/gnatcoll/static/gnatcoll-email-mailboxes.ali
+lib/gnatcoll/static/gnatcoll-email-parser.ali
+lib/gnatcoll/static/gnatcoll-email-utils.ali
+lib/gnatcoll/static/gnatcoll-email.ali
+lib/gnatcoll/static/gnatcoll-geometry.ali
+lib/gnatcoll/static/gnatcoll-gmp-integers-io.ali
+lib/gnatcoll/static/gnatcoll-gmp-integers-misc.ali
+lib/gnatcoll/static/gnatcoll-gmp-integers-number_theoretic.ali
+lib/gnatcoll/static/gnatcoll-gmp-integers-random.ali
+lib/gnatcoll/static/gnatcoll-gmp-integers-root_extraction.ali
+lib/gnatcoll/static/gnatcoll-gmp-integers.ali
+lib/gnatcoll/static/gnatcoll-gmp-lib.ali
+lib/gnatcoll/static/gnatcoll-gmp-random_state.ali
+lib/gnatcoll/static/gnatcoll-gmp.ali
+lib/gnatcoll/static/gnatcoll-iconv.ali
+lib/gnatcoll/static/gnatcoll-io-native.ali
+lib/gnatcoll/static/gnatcoll-io-remote-unix.ali
+lib/gnatcoll/static/gnatcoll-io-remote-windows.ali
+lib/gnatcoll/static/gnatcoll-io-remote.ali
+lib/gnatcoll/static/gnatcoll-io.ali
+lib/gnatcoll/static/gnatcoll-json-utility.ali
+lib/gnatcoll/static/gnatcoll-json.ali
+lib/gnatcoll/static/gnatcoll-memory.ali
+lib/gnatcoll/static/gnatcoll-mmap-system__unix.ali
+lib/gnatcoll/static/gnatcoll-mmap.ali
+lib/gnatcoll/static/gnatcoll-paragraph_filling-badnesses.ali
+lib/gnatcoll/static/gnatcoll-paragraph_filling-words.ali
+lib/gnatcoll/static/gnatcoll-paragraph_filling.ali
+lib/gnatcoll/static/gnatcoll-path.ali
+lib/gnatcoll/static/gnatcoll-pools.ali
+lib/gnatcoll/static/gnatcoll-projects-aux.ali
+lib/gnatcoll/static/gnatcoll-projects-normalize.ali
+lib/gnatcoll/static/gnatcoll-projects.ali
+lib/gnatcoll/static/gnatcoll-python.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-multiple_queue_cyclic_server.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-multiple_queue_sporadic_server.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-simple_cyclic_task.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-simple_sporadic_task.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-sporadic_server.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-sporadic_server_with_callback.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-timed_out_sporadic_server.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-timers-one_shot_timer.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-timers.ali
+lib/gnatcoll/static/gnatcoll-ravenscar-utils.ali
+lib/gnatcoll/static/gnatcoll-ravenscar.ali
+lib/gnatcoll/static/gnatcoll-readline.ali
+lib/gnatcoll/static/gnatcoll-refcount-weakref.ali
+lib/gnatcoll/static/gnatcoll-refcount.ali
+lib/gnatcoll/static/gnatcoll-remote-db.ali
+lib/gnatcoll/static/gnatcoll-remote.ali
+%%GTK%%lib/gnatcoll/static/gnatcoll-scripts-gtkada.ali
+lib/gnatcoll/static/gnatcoll-scripts-impl.ali
+%%GTK%%lib/gnatcoll/static/gnatcoll-scripts-python-gtkada.ali
+lib/gnatcoll/static/gnatcoll-scripts-python.ali
+lib/gnatcoll/static/gnatcoll-scripts-shell.ali
+lib/gnatcoll/static/gnatcoll-scripts-utils.ali
+lib/gnatcoll/static/gnatcoll-scripts.ali
+lib/gnatcoll/static/gnatcoll-sql-exec-tasking.ali
+lib/gnatcoll/static/gnatcoll-sql-exec.ali
+lib/gnatcoll/static/gnatcoll-sql-exec_private.ali
+lib/gnatcoll/static/gnatcoll-sql-inspect.ali
+lib/gnatcoll/static/gnatcoll-sql-orm-impl.ali
+lib/gnatcoll/static/gnatcoll-sql-orm.ali
+lib/gnatcoll/static/gnatcoll-sql-postgres-builder.ali
+%%PGSQL%%lib/gnatcoll/static/gnatcoll-sql-postgres-gnade.ali
+lib/gnatcoll/static/gnatcoll-sql-postgres.ali
+lib/gnatcoll/static/gnatcoll-sql-sessions.ali
+lib/gnatcoll/static/gnatcoll-sql-sqlite-builder.ali
+%%SQLITE%%lib/gnatcoll/static/gnatcoll-sql-sqlite-gnade.ali
+lib/gnatcoll/static/gnatcoll-sql-sqlite.ali
+lib/gnatcoll/static/gnatcoll-sql.ali
+lib/gnatcoll/static/gnatcoll-sql_impl.ali
+lib/gnatcoll/static/gnatcoll-storage_pools-alignment.ali
+lib/gnatcoll/static/gnatcoll-storage_pools.ali
+lib/gnatcoll/static/gnatcoll-symbols.ali
+lib/gnatcoll/static/gnatcoll-templates.ali
+lib/gnatcoll/static/gnatcoll-terminal.ali
+lib/gnatcoll/static/gnatcoll-traces-syslog.ali
+lib/gnatcoll/static/gnatcoll-traces.ali
+lib/gnatcoll/static/gnatcoll-tribooleans.ali
+lib/gnatcoll/static/gnatcoll-utils.ali
+%%GTK%%lib/gnatcoll/static/gnatcoll-vfs-gtkada.ali
+lib/gnatcoll/static/gnatcoll-vfs.ali
+lib/gnatcoll/static/gnatcoll-vfs_types.ali
+lib/gnatcoll/static/gnatcoll-vfs_utils.ali
+lib/gnatcoll/static/gnatcoll-xref-database.ali
+lib/gnatcoll/static/gnatcoll-xref-database_names.ali
+lib/gnatcoll/static/gnatcoll-xref.ali
+lib/gnatcoll/static/gnatcoll.ali
+lib/gnatcoll/static/libgnatcoll.a
+lib/gnatcoll/static/libgnatcoll_gmp.a
+%%GTK%%lib/gnatcoll/static/libgnatcoll_gtk.a
+lib/gnatcoll/static/libgnatcoll_iconv.a
+lib/gnatcoll/static/libgnatcoll_postgres.a
+lib/gnatcoll/static/libgnatcoll_python.a
+lib/gnatcoll/static/libgnatcoll_readline.a
+lib/gnatcoll/static/libgnatcoll_sqlite.a
+%%DATADIR%%/dborm.py
+share/gps/support/core/gnatcoll/__init__.py
+share/gps/support/core/gnatcoll/runtime.py
+@dirrm include/gnatcoll
+@dirrm lib/gnat/gnatcoll
+@dirrm lib/gnatcoll/static
+@dirrm lib/gnatcoll
+@dirrm %%DATADIR%%
+@dirrm share/gps/support/core/gnatcoll
+@dirrmtry share/gps/support/core
+@dirrmtry share/gps/support