aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-05 18:30:22 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-05 18:30:22 +0800
commit1ab2c95e8bd45d9009c2c60b98e22939346a21f0 (patch)
tree21593aa239298e325b848a16cc054f2dc9f60e30 /devel
parentb37920480af5b2496f67735921039a630a6de614 (diff)
downloadfreebsd-ports-gnome-1ab2c95e8bd45d9009c2c60b98e22939346a21f0.tar.gz
freebsd-ports-gnome-1ab2c95e8bd45d9009c2c60b98e22939346a21f0.tar.zst
freebsd-ports-gnome-1ab2c95e8bd45d9009c2c60b98e22939346a21f0.zip
- Add p5-Log-Dispatch-Configurator-Any 1.110690
Log::Dispatch::Config is a wrapper for Log::Dispatch and provides a way to configure Log::Dispatch objects with configuration files. Somewhat like a lite version of log4j and Log::Log4perl it allows multiple log destinations. The standard configuration file format for Log::Dispatch::Config is AppConfig. This module plugs in to Log::Dispatch::Config and allows the use of other file formats, in fact any format supported by the Config::Any module. As a bonus you can also pass in a configuration data structure instead of a file name. WWW: http://search.cpan.org/dist/Log-Dispatch-Configurator-Any/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Dispatch-Configurator-Any/Makefile32
-rw-r--r--devel/p5-Log-Dispatch-Configurator-Any/distinfo2
-rw-r--r--devel/p5-Log-Dispatch-Configurator-Any/pkg-descr10
-rw-r--r--devel/p5-Log-Dispatch-Configurator-Any/pkg-plist9
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03f5f2f4650b..55f6a0c01b18 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1919,6 +1919,7 @@
SUBDIR += p5-Log-Dispatch-Array
SUBDIR += p5-Log-Dispatch-Colorful
SUBDIR += p5-Log-Dispatch-Config
+ SUBDIR += p5-Log-Dispatch-Configurator-Any
SUBDIR += p5-Log-Dispatch-Configurator-YAML
SUBDIR += p5-Log-Dispatch-DBI
SUBDIR += p5-Log-Dispatch-Dir
diff --git a/devel/p5-Log-Dispatch-Configurator-Any/Makefile b/devel/p5-Log-Dispatch-Configurator-Any/Makefile
new file mode 100644
index 000000000000..e58c0272d373
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Configurator-Any/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Log-Dispatch-Configurator-Any
+# Date created: 2011-10-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatch-Configurator-Any
+PORTVERSION= 1.110.690
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Configurator implementation with Config::Any
+
+BUILD_DEPENDS= p5-Config-Any>=0.15:${PORTSDIR}/devel/p5-Config-Any \
+ p5-Log-Dispatch>=2.23:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Dispatch-Config>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Config
+RUN_DEPENDS= p5-Config-Any>=0.15:${PORTSDIR}/devel/p5-Config-Any \
+ p5-Log-Dispatch>=2.23:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Dispatch-Config>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Config
+
+TEST_DEPENDS= p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny \
+ p5-YAML-Tiny>=0:${PORTSDIR}/textproc/p5-YAML-Tiny
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatch::Configurator::Any.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Dispatch-Configurator-Any/distinfo b/devel/p5-Log-Dispatch-Configurator-Any/distinfo
new file mode 100644
index 000000000000..ab9926705c73
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Configurator-Any/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Log-Dispatch-Configurator-Any-1.110690.tar.gz) = 0d11cee6a43d237be139ae23c00fef082369d462f24c51ef878963d62ca02fcf
+SIZE (Log-Dispatch-Configurator-Any-1.110690.tar.gz) = 13952
diff --git a/devel/p5-Log-Dispatch-Configurator-Any/pkg-descr b/devel/p5-Log-Dispatch-Configurator-Any/pkg-descr
new file mode 100644
index 000000000000..536c4fe9e53a
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Configurator-Any/pkg-descr
@@ -0,0 +1,10 @@
+Log::Dispatch::Config is a wrapper for Log::Dispatch and provides a way to
+configure Log::Dispatch objects with configuration files. Somewhat like a lite
+version of log4j and Log::Log4perl it allows multiple log destinations. The
+standard configuration file format for Log::Dispatch::Config is AppConfig.
+
+This module plugs in to Log::Dispatch::Config and allows the use of other file
+formats, in fact any format supported by the Config::Any module. As a bonus you
+can also pass in a configuration data structure instead of a file name.
+
+WWW: http://search.cpan.org/dist/Log-Dispatch-Configurator-Any/
diff --git a/devel/p5-Log-Dispatch-Configurator-Any/pkg-plist b/devel/p5-Log-Dispatch-Configurator-Any/pkg-plist
new file mode 100644
index 000000000000..4aa0a35b9a13
--- /dev/null
+++ b/devel/p5-Log-Dispatch-Configurator-Any/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Log/Dispatch/Configurator/Any.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Configurator/Any/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Configurator/Any
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch/Configurator
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Dispatch
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log
+@dirrmtry %%SITE_PERL%%/Log/Dispatch/Configurator
+@dirrmtry %%SITE_PERL%%/Log/Dispatch
+@dirrmtry %%SITE_PERL%%/Log