aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2004-12-08 05:44:15 +0800
committerseanc <seanc@FreeBSD.org>2004-12-08 05:44:15 +0800
commit1b9e9caa679c8520d905553fcbcdabc3f7616c23 (patch)
tree476846cc3b9d3423c6a7af9dd460b32f3560806a /devel
parent847a7233f7d13ec0415439c0aaa7d0ece26a0d84 (diff)
downloadfreebsd-ports-gnome-1b9e9caa679c8520d905553fcbcdabc3f7616c23.tar.gz
freebsd-ports-gnome-1b9e9caa679c8520d905553fcbcdabc3f7616c23.tar.zst
freebsd-ports-gnome-1b9e9caa679c8520d905553fcbcdabc3f7616c23.zip
Fix plist droppings when a pmk.conf file wasn't already in existence. After
this commit, it is now possible to depend on pmk as a build dependency and have it work 100% correctly as a package or port. Previously, one would have to call pmksetup(1), now this is no longer required. Port version bump. Pointed out by: kris
Diffstat (limited to 'devel')
-rw-r--r--devel/pmk/Makefile2
-rw-r--r--devel/pmk/pkg-install3
-rw-r--r--devel/pmk/pkg-plist2
3 files changed, 5 insertions, 2 deletions
diff --git a/devel/pmk/Makefile b/devel/pmk/Makefile
index 0f73c22387d1..1f162d4f99e1 100644
--- a/devel/pmk/Makefile
+++ b/devel/pmk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pmk
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pmk
diff --git a/devel/pmk/pkg-install b/devel/pmk/pkg-install
index 5e2e6341de43..00cbd37b6e0b 100644
--- a/devel/pmk/pkg-install
+++ b/devel/pmk/pkg-install
@@ -11,6 +11,9 @@ if [ -f $pmkconf ]; then
%%PREFIX%%/sbin/pmksetup
mv -f ${pmkconf} ${pmkconf}.dist
mv -f ${pmkconf}.bak ${pmkconf}
+else
+ %%PREFIX%%/sbin/pmksetup
+ cp -fp ${pmkconf} ${pmkconf}.dist
fi
exit 0
diff --git a/devel/pmk/pkg-plist b/devel/pmk/pkg-plist
index 47bdf52c5d61..8167dcdb1d06 100644
--- a/devel/pmk/pkg-plist
+++ b/devel/pmk/pkg-plist
@@ -3,7 +3,7 @@ bin/pmkinstall
bin/pmkpc
bin/pmkscan
@unexec if cmp -s %D/etc/pmk/pmk.conf %D/etc/pmk/pmk.conf.dist; then rm -f %D/etc/pmk/pmk.conf; fi
-etc/pmk/pmk.conf.dist
+@unexec rm -f %D/etc/pmk/pmk.conf.dist
@unexec rmdir %D/etc/pmk 2>/dev/null || true
sbin/pmksetup
share/pmk/pmk.conf.sample