aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-06 03:35:11 +0800
committermiwi <miwi@FreeBSD.org>2007-01-06 03:35:11 +0800
commit1e5c9f3a72a8fe3affd6d0cc964bf9665103b611 (patch)
tree174129b69505f5c8b6d8daa0edffbd80474b8558 /devel
parent1f0faacda93f996db458a2d83b98e162d12060c1 (diff)
downloadfreebsd-ports-gnome-1e5c9f3a72a8fe3affd6d0cc964bf9665103b611.tar.gz
freebsd-ports-gnome-1e5c9f3a72a8fe3affd6d0cc964bf9665103b611.tar.zst
freebsd-ports-gnome-1e5c9f3a72a8fe3affd6d0cc964bf9665103b611.zip
By using the class Instant a Python extension module can be created at runtime.
For the user, it behaves somewhat like an inline module, except you have to import the module manually. The code can be either C or C++, but like when programming C or C++, it has to be inside a function or a similar C/C++ construct. WWW: http://pyinstant.sourceforge.net/ PR: ports/107517 Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-instant/Makefile28
-rw-r--r--devel/py-instant/distinfo3
-rw-r--r--devel/py-instant/pkg-descr8
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d84bf72af45e..3ffd77cd308c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1736,6 +1736,7 @@
SUBDIR += py-grouch
SUBDIR += py-icalendar
SUBDIR += py-ice
+ SUBDIR += py-instant
SUBDIR += py-istring
SUBDIR += py-json-py
SUBDIR += py-kid
diff --git a/devel/py-instant/Makefile b/devel/py-instant/Makefile
new file mode 100644
index 000000000000..ea82f4c111cc
--- /dev/null
+++ b/devel/py-instant/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-instant
+# Date created: Jan. 04, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= instant
+PORTVERSION= 0.9
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyinstant
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Instant-${PORTVERSION}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Python module for instant inlining of C and C++ code in Python
+
+RUN_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/Instant.py \
+ %%PYTHON_SITELIBDIR%%/Instant.pyc \
+ %%PYTHON_SITELIBDIR%%/Instant.pyo
+
+.include <bsd.port.mk>
diff --git a/devel/py-instant/distinfo b/devel/py-instant/distinfo
new file mode 100644
index 000000000000..1d889691469d
--- /dev/null
+++ b/devel/py-instant/distinfo
@@ -0,0 +1,3 @@
+MD5 (Instant-0.9.tar.gz) = b30dcce8492e98bfe2b8b5d12717e25a
+SHA256 (Instant-0.9.tar.gz) = bd6d305f15c7dee34f2f14a001037bdcc25516738757d2201dd8efbf97bb5b6e
+SIZE (Instant-0.9.tar.gz) = 34131
diff --git a/devel/py-instant/pkg-descr b/devel/py-instant/pkg-descr
new file mode 100644
index 000000000000..faea6ddfce82
--- /dev/null
+++ b/devel/py-instant/pkg-descr
@@ -0,0 +1,8 @@
+By using the class Instant a Python extension module can be created at runtime.
+For the user, it behaves somewhat like an inline module, except you have to
+import the module manually.
+
+The code can be either C or C++, but like when programming C or C++, it has to
+be inside a function or a similar C/C++ construct.
+
+WWW: http://pyinstant.sourceforge.net/