aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2014-04-15 05:34:25 +0800
committerbrooks <brooks@FreeBSD.org>2014-04-15 05:34:25 +0800
commit1ea165f13e6ba287dd709b4d7aa922aa27d3d8c2 (patch)
tree14a4c17f50cbc33514211ac0c921426394b64a17 /devel
parent6dc4fa3f3d0bff5d08f791fdf8b6f5471c2c53d1 (diff)
downloadfreebsd-ports-gnome-1ea165f13e6ba287dd709b4d7aa922aa27d3d8c2.tar.gz
freebsd-ports-gnome-1ea165f13e6ba287dd709b4d7aa922aa27d3d8c2.tar.zst
freebsd-ports-gnome-1ea165f13e6ba287dd709b4d7aa922aa27d3d8c2.zip
Our use of cmake is unconventional so we need to pass CC and CXX to it
directly rather than relying on ports infrastructure.
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm-devel/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 9e0d35002534..c7d0f0d03e10 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -178,7 +178,10 @@ post-patch:
.if ${PORT_OPTIONS:MCMAKE}
post-configure:
${MKDIR} ${WRKDIR}/cmake
- cd ${WRKDIR}/cmake && cmake -G "Unix Makefiles" ${WRKSRC}
+ cd ${WRKDIR}/cmake && cmake -G "Unix Makefiles" \
+ -DCMAKE_C_COMPILER:STRING="${CC}" \
+ -DCMAKE_CXX_COMPILER:STRING="${CXX}" \
+ ${WRKSRC}
${REINPLACE_CMD} -e 's|${WRKDIR}/cmake|${LLVM_PREFIX}|' \
-e 's|${WRKSRC}/cmake/modules|${DATADIR}/cmake|' \
${WRKDIR}/cmake/share/llvm/cmake/LLVMConfig.cmake