aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-04 21:07:20 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-04 21:07:20 +0800
commit201cafad506f5b75a58dfe446439f7f75048a168 (patch)
treee2c01b53045dbfb6541b6beff6bf4d28677d4ca2 /devel
parent59b443310dcf45a565daaa0f303752942c37c0ff (diff)
downloadfreebsd-ports-gnome-201cafad506f5b75a58dfe446439f7f75048a168.tar.gz
freebsd-ports-gnome-201cafad506f5b75a58dfe446439f7f75048a168.tar.zst
freebsd-ports-gnome-201cafad506f5b75a58dfe446439f7f75048a168.zip
- Unbreak the build on PowerPC (at least) by always using va_copy() macro for
copying variable argument lists, not just on AMD64 (also regenerate a patch with `make makepatch' command) - Simplify `check' target and rename it to our more standard `regression-test'
Diffstat (limited to 'devel')
-rw-r--r--devel/ossp-xds/Makefile13
-rw-r--r--devel/ossp-xds/files/patch-xds.c11
2 files changed, 8 insertions, 16 deletions
diff --git a/devel/ossp-xds/Makefile b/devel/ossp-xds/Makefile
index 390997cba4bf..e445304e108d 100644
--- a/devel/ossp-xds/Makefile
+++ b/devel/ossp-xds/Makefile
@@ -15,16 +15,11 @@ USES= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-check: build
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxds.so
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+regression-test: build
+ @${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${MAKE_ARGS} check -C ${WRKSRC}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ossp-xds/files/patch-xds.c b/devel/ossp-xds/files/patch-xds.c
index 5da808c582ab..5f8eb7ab3925 100644
--- a/devel/ossp-xds/files/patch-xds.c
+++ b/devel/ossp-xds/files/patch-xds.c
@@ -1,14 +1,11 @@
---- xds.c.orig Mon Feb 17 21:33:40 2003
-+++ xds.c Sat May 29 19:07:41 2004
-@@ -383,7 +383,11 @@
+--- xds.c.orig 2005-06-02 18:50:56 UTC
++++ xds.c
+@@ -383,7 +383,7 @@ int xds_vencode(xds_t *xds, const char *
/* Execute the engine. */
used_buffer_size = 0;
-+#ifdef __amd64__
+- args_backup = args;
+ va_copy(args_backup, args);
-+#else
- args_backup = args;
-+#endif
rc = (*xds->engines[pos].engine)(
xds, xds->engines[pos].context,
xds->buffer + xds->buffer_len,