aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-05-02 09:40:37 +0800
committerswills <swills@FreeBSD.org>2011-05-02 09:40:37 +0800
commit2182ce0a3769ad2b5e47d5238b4b1de80e020a7f (patch)
tree138046a3e03df4d0123ade3aa2ef563c48ffcb13 /devel
parenta0db200051aa2853ac8fb221f7d73d579fb41c78 (diff)
downloadfreebsd-ports-gnome-2182ce0a3769ad2b5e47d5238b4b1de80e020a7f.tar.gz
freebsd-ports-gnome-2182ce0a3769ad2b5e47d5238b4b1de80e020a7f.tar.zst
freebsd-ports-gnome-2182ce0a3769ad2b5e47d5238b4b1de80e020a7f.zip
Perl module which implements an ordered hash-like object. It's a cross between
a Perl hash and a linked list. Use it whenever you want the speed and structure of a Perl hash, but the orderedness of a list. WWW: http://search.cpan.org/dist/Tie-LLHash/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tie-LLHash/Makefile23
-rw-r--r--devel/p5-Tie-LLHash/distinfo2
-rw-r--r--devel/p5-Tie-LLHash/pkg-descr5
-rw-r--r--devel/p5-Tie-LLHash/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5bb5bbc9b14f..3c141e751afd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2411,6 +2411,7 @@
SUBDIR += p5-Tie-Hash-Sorted
SUBDIR += p5-Tie-Hash-TwoWay
SUBDIR += p5-Tie-IxHash
+ SUBDIR += p5-Tie-LLHash
SUBDIR += p5-Tie-RefHash
SUBDIR += p5-Tie-RefHash-Weak
SUBDIR += p5-Tie-RegexpHash
diff --git a/devel/p5-Tie-LLHash/Makefile b/devel/p5-Tie-LLHash/Makefile
new file mode 100644
index 000000000000..904237c056cb
--- /dev/null
+++ b/devel/p5-Tie-LLHash/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Tie-LLHash
+# Date created: 2011-04-26
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-LLHash
+PORTVERSION= 1.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:KWILLIAMS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Perl module which implements an ordered hash-like object
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= Tie::LLHash.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Tie-LLHash/distinfo b/devel/p5-Tie-LLHash/distinfo
new file mode 100644
index 000000000000..33cc696f781b
--- /dev/null
+++ b/devel/p5-Tie-LLHash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Tie-LLHash-1.003.tar.gz) = 7533dcb1331bdc727a4e18b23ba363afe2e08d15d6e931dfc61edbf7af2353cf
+SIZE (Tie-LLHash-1.003.tar.gz) = 5983
diff --git a/devel/p5-Tie-LLHash/pkg-descr b/devel/p5-Tie-LLHash/pkg-descr
new file mode 100644
index 000000000000..ea8871ec856f
--- /dev/null
+++ b/devel/p5-Tie-LLHash/pkg-descr
@@ -0,0 +1,5 @@
+Perl module which implements an ordered hash-like object. It's a cross between
+a Perl hash and a linked list. Use it whenever you want the speed and structure
+of a Perl hash, but the orderedness of a list.
+
+WWW: http://search.cpan.org/dist/Tie-LLHash/
diff --git a/devel/p5-Tie-LLHash/pkg-plist b/devel/p5-Tie-LLHash/pkg-plist
new file mode 100644
index 000000000000..a0057e6d5883
--- /dev/null
+++ b/devel/p5-Tie-LLHash/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Tie/LLHash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/LLHash/.packlist
+@dirrmtry %%SITE_PERL%%/Tie
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/LLHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie