aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2015-08-04 11:52:51 +0800
committerbrooks <brooks@FreeBSD.org>2015-08-04 11:52:51 +0800
commit271c74f31a163680e6afd4c2761527c4b7418bea (patch)
tree1a7a9cabe95063c73a39b7576740f7fcca4e1ebd /devel
parent83f871359de33960ee3c3c00afba9dd95e0a6f24 (diff)
downloadfreebsd-ports-gnome-271c74f31a163680e6afd4c2761527c4b7418bea.tar.gz
freebsd-ports-gnome-271c74f31a163680e6afd4c2761527c4b7418bea.tar.zst
freebsd-ports-gnome-271c74f31a163680e6afd4c2761527c4b7418bea.zip
Disable LLDB when the chosen compiler is gcc.
On platforms where the system compiler isn't clang (including 9.x), USES=compiler:c++11-lib uses gcc48 as the compiler. Unfortunatly, gcc48 does not provide a sufficently complient c++11 environment to build LLDB when compiled on 9.x and possiably on other platforms.
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm-devel/Makefile11
-rw-r--r--devel/llvm37/Makefile11
2 files changed, 16 insertions, 6 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index abc3c90e63fb..1ac3595bab1f 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -57,7 +57,7 @@ LIT_DESC= Install lit and FileCheck test tools
LLD_DESC= Install lld, the LLVM linker
LLD_GH_PROJECT= lld:lld
LLD_GH_TAGNAME= ${LLD_COMMIT}:lld
-LLDB_DESC= Install lldb, the LLVM debugger
+LLDB_DESC= Install lldb, the LLVM debugger (ignored on 9.x)
LLDB_BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LLDB_GH_PROJECT= lldb:lldb
LLDB_GH_TAGNAME= ${LLDB_COMMIT}:lldb
@@ -160,8 +160,9 @@ NOT_FOR_ARCH= ia64
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 900000
-BROKEN= GCC failing on 8.x
+.if ${COMPILER_TYPE} != clang
+# Evil hack around gcc48 not providing a usable c++11 environment on 9.x
+PLIST_SUB:= ${PLIST_SUB:NLLDB=*} LLDB="@comment "
.endif
post-extract-CLANG-on:
@@ -171,7 +172,9 @@ post-extract-LLD-on:
${MV} ${WRKSRC_lld} ${PATCH_WRKSRC}/tools/lld
post-extract-LLDB-on:
+.if ${COMPILER_TYPE} == clang
${MV} ${WRKSRC_lldb} ${PATCH_WRKSRC}/tools/lldb
+.endif
post-extract-OPENMP-on:
${MV} ${WRKSRC_openmp} ${PATCH_WRKSRC}/tools/openmp
@@ -204,7 +207,9 @@ post-install-DOCS-on:
${RMDIR} ${STAGEDIR}${LLVM_PREFIX}/share/man/
post-install-LLDB-on:
+.if ${COMPILER_TYPE} == clang
${RM} ${STAGEDIR}${LLVM_PREFIX}/lib/python*/site-packages/lib
+.endif
post-install-CLANG-on:
${LN} -f ${STAGEDIR}${LLVM_PREFIX}/bin/clang \
diff --git a/devel/llvm37/Makefile b/devel/llvm37/Makefile
index 9d28910c419b..ab076e02ca08 100644
--- a/devel/llvm37/Makefile
+++ b/devel/llvm37/Makefile
@@ -50,7 +50,7 @@ DOCS_PLIST_FILES= ${MAN1SRCS:S|^|man/man1/|:S|.1$|${LLVM_SUFFIX}.1.gz|}
LIT_DESC= Install lit and FileCheck test tools
LLD_DESC= Install lld, the LLVM linker
LLD_DISTFILES= lld-${DISTVERSION}.src${EXTRACT_SUFX}
-LLDB_DESC= Install lldb, the LLVM debugger
+LLDB_DESC= Install lldb, the LLVM debugger (ignored on 9.x)
LLDB_BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LLDB_DISTFILES= lldb-${DISTVERSION}.src${EXTRACT_SUFX}
OPENMP_DESC= Install libomp, the LLVM OpenMP runtime library
@@ -155,8 +155,9 @@ NOT_FOR_ARCH= ia64
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 900000
-BROKEN= GCC failing on 8.x
+.if ${COMPILER_TYPE} != clang
+# Evil hack around gcc48 not providing a usable c++11 environment on 9.x
+PLIST_SUB:= ${PLIST_SUB:NLLDB=*} LLDB="@comment "
.endif
post-extract-CLANG-on:
@@ -166,7 +167,9 @@ post-extract-LLD-on:
${MV} ${WRKSRC_lld} ${PATCH_WRKSRC}/tools/lld
post-extract-LLDB-on:
+.if ${COMPILER_TYPE} == clang
${MV} ${WRKSRC_lldb} ${PATCH_WRKSRC}/tools/lldb
+.endif
post-extract-OPENMP-on:
${MV} ${WRKSRC_openmp} ${PATCH_WRKSRC}/tools/openmp
@@ -200,7 +203,9 @@ post-install-DOCS-on:
${RMDIR} ${STAGEDIR}${LLVM_PREFIX}/share/man/
post-install-LLDB-on:
+.if ${COMPILER_TYPE} == clang
${RM} ${STAGEDIR}${LLVM_PREFIX}/lib/python*/site-packages/lib
+.endif
post-install-CLANG-on:
${LN} -f ${STAGEDIR}${LLVM_PREFIX}/bin/clang \