aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2010-02-12 05:32:50 +0800
committerjoerg <joerg@FreeBSD.org>2010-02-12 05:32:50 +0800
commit278bdc299ded0dbe62c392c30f5e5e405fa1087f (patch)
tree3c05535b6de4f8cb5a525de17c489672ff524b96 /devel
parentc50311a22641b7bb38336e2aa51a3b73c449fbe7 (diff)
downloadfreebsd-ports-gnome-278bdc299ded0dbe62c392c30f5e5e405fa1087f.tar.gz
freebsd-ports-gnome-278bdc299ded0dbe62c392c30f5e5e405fa1087f.tar.zst
freebsd-ports-gnome-278bdc299ded0dbe62c392c30f5e5e405fa1087f.zip
Fix build issue with disabled docs.
Submitted by: Warren Block
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-libc/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index c913e16b94ad..722df17e9a2e 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -26,7 +26,12 @@ OPTIONS= AVRLIBCDOCS "Build avr-libc documents" on
.include <bsd.port.options.mk>
-.if defined(WITH_AVRLIBCDOCS) && !defined(NOPORTDOCS)
+.if defined(WITHOUT_AVRLIBCDOCS) || defined(NOPORTDOCS)
+WITHOUT_AVRLIBCDOCS= true
+.undef WITH_AVRLIBCDOCS
+.endif
+
+.if defined(WITH_AVRLIBCDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
latex:${PORTSDIR}/print/teTeX \
pdflatex:${PORTSDIR}/print/teTeX \
@@ -41,7 +46,7 @@ HAS_CONFIGURE= yes
CONFLICTS= avr-libc-devel*
CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
-.if !defined(NOPORTDOCS)
+.if defined(WITH_AVRLIBCDOCS)
CONFIGURE_ARGS= --build=`./config.guess` --host=avr \
--enable-doc --disable-versioned-doc --prefix=${PREFIX}
PLIST_DOC= ${PKGDIR}/pkg-plist.doc
@@ -57,13 +62,13 @@ CFLAGS= -O
CXXFLAGS= -O
post-patch:
-.if defined(NOPORTDOCS)
+.if defined(WITHOUT_AVRLIBCDOCS)
${REINPLACE_CMD} -e '/SUBDIRS/s,examples,,' ${WRKSRC}/doc/Makefile.in
.endif
do-install:
${RM} -f ${TMPPLIST}
-.if !defined(NOPORTDOCS)
+.if defined(WITH_AVRLIBCDOCS)
(cd ${BUILD_WRKSRC}/doc/api/avr-libc-user-manual && \
${FIND} . -type f \
\( -name '*.html' -or -name '*.css' -or \