aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2015-03-08 18:32:29 +0800
committerbsam <bsam@FreeBSD.org>2015-03-08 18:32:29 +0800
commit2cfbb7ae821999a824bd6c258a39a0024d20846b (patch)
treed05f6e8851b7bfe35d3b36a818a2623ff10bf8ab /devel
parent351f65d9c103fc631a76006c85b4a23f87da4589 (diff)
downloadfreebsd-ports-gnome-2cfbb7ae821999a824bd6c258a39a0024d20846b.tar.gz
freebsd-ports-gnome-2cfbb7ae821999a824bd6c258a39a0024d20846b.tar.zst
freebsd-ports-gnome-2cfbb7ae821999a824bd6c258a39a0024d20846b.zip
Eric is a full featured Python and Ruby editor and IDE, written in python.
It is based on the cross platform Qt gui toolkit, integrating the highly flexible Scintilla editor control. It is designed to be usable as everyday's quick and dirty editor as well as being usable as a professional project management tool integrating many advanced features Python offers the professional coder. This is a port of eric6 (based on Qt4). WWW: http://eric-ide.python-projects.org/index.html
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/eric6/Makefile42
-rw-r--r--devel/eric6/Makefile.inc36
-rw-r--r--devel/eric6/distinfo2
-rw-r--r--devel/eric6/files/config22
-rw-r--r--devel/eric6/files/eric6.desktop.in10
-rw-r--r--devel/eric6/files/extra-patch-install-i18n.py58
-rw-r--r--devel/eric6/pkg-descr11
-rw-r--r--devel/eric6/pkg-plist31
9 files changed, 213 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cc68d9a1cdb9..e7781a5afaef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -404,6 +404,7 @@
SUBDIR += epm
SUBDIR += epydoc
SUBDIR += eric4
+ SUBDIR += eric6
SUBDIR += eris
SUBDIR += esdl
SUBDIR += etcd
diff --git a/devel/eric6/Makefile b/devel/eric6/Makefile
new file mode 100644
index 000000000000..9353e2b16fff
--- /dev/null
+++ b/devel/eric6/Makefile
@@ -0,0 +1,42 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= devel python
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
+ ${PYTHON_SITELIBDIR}/PyQt4/Qsci.so:${PORTSDIR}/devel/py-qt4-qscintilla2
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtNetwork.so:${PORTSDIR}/net/py-qt4-network \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtSvg.so:${PORTSDIR}/graphics/py-qt4-svg \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtSql.so:${PORTSDIR}/databases/py-qt4-sql \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtWebKit.so:${PORTSDIR}/www/py-qt4-webkit \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtHelp.so:${PORTSDIR}/devel/py-qt4-help \
+ ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+
+USES= desktop-file-utils
+INSTALL_CMD= install.py -c -f eric6config.freebsd -i ${STAGEDIR}
+PLIST_FILES=
+SUB_FILES= eric6.desktop
+OPTIONS_DEFINE= DOCS EXAMPLES
+EXTRA_PATCHES=
+
+PORTDATA= *
+PORTDOCS= *
+PORTEXAMPLES= *
+
+do-configure:
+ ${SED} -e 's,PYTHON_SITELIBDIR,${PYTHON_SITELIBDIR},' \
+ -e 's,PREFIX,${PREFIX},' \
+ -e 's,DATADIR,${DATADIR},' \
+ -e 's,LOCALBASE,${LOCALBASE},' \
+ -e 's,DOCSDIR,${DOCSDIR},' \
+ -e 's,EXAMPLESDIR,${EXAMPLESDIR},' \
+ < ${FILESDIR}/config > ${WRKSRC}/eric6config.freebsd
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/eric6.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${LN} -sf ${DATADIR}/icons/default/eric.png ${STAGEDIR}${PREFIX}/share/pixmaps/eric6.png
+ @${MKDIR} ${STAGEDIR}${DATADIR}/i18n
+
+.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
diff --git a/devel/eric6/Makefile.inc b/devel/eric6/Makefile.inc
new file mode 100644
index 000000000000..1ef334a27fdb
--- /dev/null
+++ b/devel/eric6/Makefile.inc
@@ -0,0 +1,36 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+# $FreeBSD$
+#
+# This is a set of Makefile macros which allow to build the core and
+# localized language packages for devel/eric6:
+# french/eric6, german/eric6, russian/eric6
+
+PORTNAME= eric6
+PORTVERSION= 6.0.3
+MASTER_SITES= SF/eric-ide/${PORTNAME}/stable/${PORTVERSION}
+DISTNAME?= ${PORTNAME}-i18n-${I18N_LANG}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER?= bsam@FreeBSD.org
+COMMENT= Full featured Python and Ruby editor and IDE based on Qt4
+
+LICENSE= GPLv3
+
+RUN_DEPENDS?= ${PREFIX}/bin/eric6:${PORTSDIR}/devel/eric6
+
+I18N_LANG?= ru
+INSTALL_CMD?= install-i18n.py -p ${STAGEDIR}
+MAKE_ENV+= "HOME=${WRKDIR}"
+
+USES+= python:2
+NO_BUILD= yes
+PLIST_FILES?= %%DATADIR%%/i18n/${PORTNAME}_${I18N_LANG}.qm
+EXTRA_PATCHES?= ${.CURDIR}/../../devel/eric6/files/extra-patch-install-i18n.py
+
+do-install:
+ @(cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${INSTALL_CMD})
+
+DESCR= ${.CURDIR}/../../devel/eric6/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/devel/eric6/distinfo b/devel/eric6/distinfo
new file mode 100644
index 000000000000..15a1339c99a6
--- /dev/null
+++ b/devel/eric6/distinfo
@@ -0,0 +1,2 @@
+SHA256 (eric6-6.0.3.tar.gz) = 72a70e03be3d3f2e28ffd0336486504c969761597b293188eaf45cccdcc4adc1
+SIZE (eric6-6.0.3.tar.gz) = 10618406
diff --git a/devel/eric6/files/config b/devel/eric6/files/config
new file mode 100644
index 000000000000..4fd47d8083ac
--- /dev/null
+++ b/devel/eric6/files/config
@@ -0,0 +1,22 @@
+# -*- coding: utf-8 -*-
+#
+# This module contains the configuration of the individual eric6 installation
+#
+
+cfg = {
+ 'ericDir' : 'DATADIR',
+ 'ericPixDir' : 'DATADIR/pixmaps',
+ 'ericIconDir' : 'DATADIR/icons',
+ 'ericDTDDir' : 'DATADIR/DTDs',
+ 'ericCSSDir' : 'DATADIR/CSSs',
+ 'ericStylesDir' : 'DATADIR/Styles',
+ 'ericDocDir' : 'DOCSDIR',
+ 'ericExamplesDir' : 'EXAMPLESDIR',
+ 'ericTranslationsDir' : 'DATADIR/i18n',
+ 'ericTemplatesDir' : 'DATADIR/DesignerTemplates',
+ 'ericCodeTemplatesDir' : 'DATADIR/CodeTemplates',
+ 'ericOthersDir' : 'DATADIR/Others',
+ 'bindir' : 'PREFIX/bin',
+ 'mdir' : 'PYTHON_SITELIBDIR',
+ 'apidir' : 'LOCALBASE/share/qt4/qsci/api',
+}
diff --git a/devel/eric6/files/eric6.desktop.in b/devel/eric6/files/eric6.desktop.in
new file mode 100644
index 000000000000..bdcfcabfaea2
--- /dev/null
+++ b/devel/eric6/files/eric6.desktop.in
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Eric IDE
+GenericName=Python and Ruby IDE
+Comment=Full featured Python and Ruby editor and IDE based on Qt4
+Type=Application
+Exec=eric6
+Icon=eric6
+MimeType=application/x-python;application/x-eric;
+Categories=Development;TextEditor;Qt;Application;
+Terminal=false
diff --git a/devel/eric6/files/extra-patch-install-i18n.py b/devel/eric6/files/extra-patch-install-i18n.py
new file mode 100644
index 000000000000..17ef476836a4
--- /dev/null
+++ b/devel/eric6/files/extra-patch-install-i18n.py
@@ -0,0 +1,58 @@
+--- install-i18n.py.orig 2013-08-19 13:16:47.862300000 +0400
++++ install-i18n.py 2013-10-05 17:55:20.162267518 +0400
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python3
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+
+ # Copyright (c) 2004 - 2015 Detlev Offenbach <detlev@die-offenbachs.de>
+@@ -16,7 +16,7 @@
+ import shutil
+ import glob
+
+-from PyQt5.QtCore import QDir
++from PyQt4.QtCore import QDir
+
+ try:
+ from eric6config import getConfig
+@@ -45,6 +45,7 @@
+ # Define the globals.
+ progName = None
+ configDir = getConfigDir()
++distDir = None
+ privateInstall = False
+
+ def usage(rcode = 2):
+@@ -71,7 +72,9 @@
+ global privateInstall, configDir
+
+ if privateInstall:
+- targetDir = configDir
++ targetDir = distDir + getConfig('ericTranslationsDir')
++ if not os.path.exists(targetDir):
++ os.makedirs(targetDir, 0755)
+ else:
+ targetDir = getConfig('ericTranslationsDir')
+
+@@ -97,11 +100,12 @@
+ progName = os.path.basename(argv[0])
+
+ try:
+- optlist, args = getopt.getopt(argv[1:], "hp")
++ optlist, args = getopt.getopt(argv[1:],"hp:")
+ except getopt.GetoptError:
+ usage()
+
+ global platBinDir
++ global distDir
+
+ depChecks = 1
+
+@@ -110,6 +114,7 @@
+ usage(0)
+ elif opt == "-p":
+ privateInstall = 1
++ distDir = os.path.normpath(arg)
+
+ installTranslations()
+
diff --git a/devel/eric6/pkg-descr b/devel/eric6/pkg-descr
new file mode 100644
index 000000000000..e15ab383dfe1
--- /dev/null
+++ b/devel/eric6/pkg-descr
@@ -0,0 +1,11 @@
+Eric is a full featured Python and Ruby editor and IDE, written in python.
+
+It is based on the cross platform Qt gui toolkit, integrating the highly
+flexible Scintilla editor control. It is designed to be usable as everyday's
+quick and dirty editor as well as being usable as a professional project
+management tool integrating many advanced features Python offers
+the professional coder.
+
+This is a port of eric6 (based on Qt4).
+
+WWW: http://eric-ide.python-projects.org/index.html
diff --git a/devel/eric6/pkg-plist b/devel/eric6/pkg-plist
new file mode 100644
index 000000000000..a5572c6c6560
--- /dev/null
+++ b/devel/eric6/pkg-plist
@@ -0,0 +1,31 @@
+bin/eric6
+bin/eric6_api
+bin/eric6_compare
+bin/eric6_configure
+bin/eric6_diff
+bin/eric6_doc
+bin/eric6_editor
+bin/eric6_iconeditor
+bin/eric6_plugininstall
+bin/eric6_pluginrepository
+bin/eric6_pluginuninstall
+bin/eric6_qregexp
+bin/eric6_re
+bin/eric6_sqlbrowser
+bin/eric6_tray
+bin/eric6_trpreviewer
+bin/eric6_uipreviewer
+bin/eric6_unittest
+bin/eric6_webbrowser
+@comment lib/python2.7/site-packages/eric6.pth
+lib/python2.7/site-packages/eric6config.py
+lib/python2.7/site-packages/eric6config.pyc
+lib/python2.7/site-packages/eric6plugins/__init__.py
+share/applications/eric6.desktop
+share/pixmaps/eric6.png
+share/qt4/qsci/api/python/eric6.api
+share/qt4/qsci/api/python/zope-2.10.7.api
+share/qt4/qsci/api/python/zope-2.11.2.api
+share/qt4/qsci/api/python/zope-3.3.1.api
+share/qt4/qsci/api/ruby/Ruby-1.8.7.api
+share/qt4/qsci/api/ruby/eric6.api