aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2013-11-27 08:00:54 +0800
committermatthew <matthew@FreeBSD.org>2013-11-27 08:00:54 +0800
commit312d1f947893473117a619932665fb7727792f60 (patch)
tree9685b7b97bafdb4da03d9f53c3404a496621af53 /devel
parent4e146c13c0951d3e8a5fdccbda41027ab94f6771 (diff)
downloadfreebsd-ports-gnome-312d1f947893473117a619932665fb7727792f60.tar.gz
freebsd-ports-gnome-312d1f947893473117a619932665fb7727792f60.tar.zst
freebsd-ports-gnome-312d1f947893473117a619932665fb7727792f60.zip
Sometimes you want roles. You're not sure about Moose, Mouse, Moo and
what was that damned Squirrel thing anyway? Then there's Class::Trait, but it has a funky syntax and the maintainer's deprecated it in favor of Moose::Role and you really don't care that it handles overloading, instance application or has a workaround for the SUPER:: bug. You think a meta-object protocol sounds nifty, but you don't understand it. Maybe you're not sure you want the syntactic sugar for object declaration. Maybe you've convinced your colleagues that roles are a good idea but they're leery of dragging in Moose (your author has had this happen more than once and heard of others making the same complaint). Sometimes you just want good old-fashioned roles which let you separate class responsibility from code reuse. WWW: http://search.cpan.org/dist/Role-Basic/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Role-Basic/Makefile21
-rw-r--r--devel/p5-Role-Basic/distinfo2
-rw-r--r--devel/p5-Role-Basic/pkg-descr14
-rw-r--r--devel/p5-Role-Basic/pkg-plist9
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ca50a6930d69..55d4afc4949a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2596,6 +2596,7 @@
SUBDIR += p5-ResourcePool
SUBDIR += p5-Resources
SUBDIR += p5-Return-Value
+ SUBDIR += p5-Role-Basic
SUBDIR += p5-Role-HasMessage
SUBDIR += p5-Role-Identifiable
SUBDIR += p5-Role-Tiny
diff --git a/devel/p5-Role-Basic/Makefile b/devel/p5-Role-Basic/Makefile
new file mode 100644
index 000000000000..a30354e1eac6
--- /dev/null
+++ b/devel/p5-Role-Basic/Makefile
@@ -0,0 +1,21 @@
+# Created by: Matthew Seaman <matthew@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Role-Basic
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:OVID
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Just roles. Nothing else
+
+PKGNAMEPREFIX= p5-
+
+USES= perl5
+USE_PERL5= configure
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Role-Basic/distinfo b/devel/p5-Role-Basic/distinfo
new file mode 100644
index 000000000000..0ac1178e4bbd
--- /dev/null
+++ b/devel/p5-Role-Basic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Role-Basic-0.13.tar.gz) = 38a0959ef9f193ff76e72c325a9e9211bc4868689bd0e2b005778f53f8b6f36a
+SIZE (Role-Basic-0.13.tar.gz) = 39625
diff --git a/devel/p5-Role-Basic/pkg-descr b/devel/p5-Role-Basic/pkg-descr
new file mode 100644
index 000000000000..937ae85470e3
--- /dev/null
+++ b/devel/p5-Role-Basic/pkg-descr
@@ -0,0 +1,14 @@
+Sometimes you want roles. You're not sure about Moose, Mouse, Moo and
+what was that damned Squirrel thing anyway? Then there's Class::Trait,
+but it has a funky syntax and the maintainer's deprecated it in favor
+of Moose::Role and you really don't care that it handles overloading,
+instance application or has a workaround for the SUPER:: bug. You
+think a meta-object protocol sounds nifty, but you don't understand
+it. Maybe you're not sure you want the syntactic sugar for object
+declaration. Maybe you've convinced your colleagues that roles are a
+good idea but they're leery of dragging in Moose (your author has had
+this happen more than once and heard of others making the same
+complaint). Sometimes you just want good old-fashioned roles which let
+you separate class responsibility from code reuse.
+
+WWW: http://search.cpan.org/dist/Role-Basic/
diff --git a/devel/p5-Role-Basic/pkg-plist b/devel/p5-Role-Basic/pkg-plist
new file mode 100644
index 000000000000..b1c70870ff54
--- /dev/null
+++ b/devel/p5-Role-Basic/pkg-plist
@@ -0,0 +1,9 @@
+%%PERL5_MAN3%%/Role::Basic.3.gz
+%%PERL5_MAN3%%/Role::Basic::Philosophy.3.gz
+%%SITE_PERL%%/Role/Basic.pm
+%%SITE_PERL%%/Role/Basic/Philosophy.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Role/Basic/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Role/Basic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Role
+@dirrmtry %%SITE_PERL%%/Role/Basic
+@dirrmtry %%SITE_PERL%%/Role