aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2014-01-12 01:46:33 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2014-01-12 01:46:33 +0800
commit324c5236b888759ebda3ce7af2aba391da348ea0 (patch)
tree2f8ae2a36fa3a470da851493054d7f7fafb0b259 /devel
parent5d776fa056c0b1c619072b2c1bc87f52687f2fd5 (diff)
downloadfreebsd-ports-gnome-324c5236b888759ebda3ce7af2aba391da348ea0.tar.gz
freebsd-ports-gnome-324c5236b888759ebda3ce7af2aba391da348ea0.tar.zst
freebsd-ports-gnome-324c5236b888759ebda3ce7af2aba391da348ea0.zip
- Change default location of Go packages to LOCALBASE/share/go
This fixes problems like ports failing to build if the port is already installed [1] - Bump PORTREVISION of affected ports - Support the install target in bsd.go.mk - STAGE support for free! PR: ports/180003 [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/go-pretty/Makefile17
-rw-r--r--devel/go-pretty/pkg-plist25
-rw-r--r--devel/goprotobuf/Makefile9
-rw-r--r--devel/goprotobuf/pkg-plist20
4 files changed, 32 insertions, 39 deletions
diff --git a/devel/go-pretty/Makefile b/devel/go-pretty/Makefile
index 339ffdf3879e..28e9d1b608fd 100644
--- a/devel/go-pretty/Makefile
+++ b/devel/go-pretty/Makefile
@@ -3,26 +3,17 @@
PORTNAME= go-pretty
PORTVERSION= 20130510
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= LOCAL/gblach/
MAINTAINER= gblach@FreeBSD.org
COMMENT= Pretty-printing package for go values
-BUILD_DEPENDS= ${LOCALBASE}/go/pkg/${OPSYS:L}_${GOARCH}/github.com/kr/text.a:${PORTSDIR}/textproc/go-text
-RUN_DEPENDS= ${LOCALBASE}/go/pkg/${OPSYS:L}_${GOARCH}/github.com/kr/text.a:${PORTSDIR}/textproc/go-text
+BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/github.com/kr/text.a:${PORTSDIR}/textproc/go-text
+RUN_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/github.com/kr/text.a:${PORTSDIR}/textproc/go-text
-SUBLIBDIR= github.com/kr
-GO_PKGNAME= ${SUBLIBDIR}/pretty
-
-NO_STAGE= yes
-do-install:
- ${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
- ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/pretty.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
- ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
-.for f in diff.go formatter.go pretty.go zero.go
- ${INSTALL_DATA} ${GO_WRKSRC}/${f} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
-.endfor
+GO_PKGNAME= github.com/kr/pretty
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
diff --git a/devel/go-pretty/pkg-plist b/devel/go-pretty/pkg-plist
index dd4369fb47ed..01d6ac4b0fff 100644
--- a/devel/go-pretty/pkg-plist
+++ b/devel/go-pretty/pkg-plist
@@ -1,10 +1,19 @@
-%%GO_LIBDIR%%/github.com/kr/pretty.a
-%%GO_SRCDIR%%/github.com/kr/pretty/diff.go
-%%GO_SRCDIR%%/github.com/kr/pretty/formatter.go
-%%GO_SRCDIR%%/github.com/kr/pretty/pretty.go
-%%GO_SRCDIR%%/github.com/kr/pretty/zero.go
-@dirrmtry %%GO_LIBDIR%%/github.com/kr
-@dirrmtry %%GO_LIBDIR%%/github.com
-@dirrm %%GO_SRCDIR%%/github.com/kr/pretty
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/License
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/Readme
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/diff.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/diff_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/example_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/formatter.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/formatter_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pretty.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/zero.go
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
@dirrmtry %%GO_SRCDIR%%/github.com/kr
@dirrmtry %%GO_SRCDIR%%/github.com
+@dirrmtry %%GO_SRCDIR%%
+@dirrmtry %%GO_LIBDIR%%/github.com/kr
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrmtry %%GO_LIBDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go
diff --git a/devel/goprotobuf/Makefile b/devel/goprotobuf/Makefile
index d20fcf4bd687..8a25672be37e 100644
--- a/devel/goprotobuf/Makefile
+++ b/devel/goprotobuf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= goprotobuf
PORTVERSION= 20131010
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.c-s.li/ports/
@@ -16,14 +17,6 @@ RUN_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
GO_PKGNAME= code.google.com/p/goprotobuf
GO_TARGET= ${GO_PKGNAME}/proto ${GO_PKGNAME}/protoc-gen-go
-do-install:
- ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/protoc-gen-go ${STAGEDIR}${LOCALBASE}/bin
- ${MKDIR} ${STAGEDIR}${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
- (cd ${GO_WRKDIR_PKG}/${GO_PKGNAME}/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${GO_LOCAL_LIBDIR}/${GO_PKGNAME})
- ${MKDIR} ${STAGEDIR}${GO_LOCAL_SRCDIR}/${GO_PKGNAME}/proto
- (cd ${GO_WRKSRC}/proto && ${COPYTREE_SHARE} \* \
- ${STAGEDIR}${GO_LOCAL_SRCDIR}/${GO_PKGNAME}/proto)
-
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
.include <bsd.port.post.mk>
diff --git a/devel/goprotobuf/pkg-plist b/devel/goprotobuf/pkg-plist
index cf9cc90cf094..6f75f72bcde1 100644
--- a/devel/goprotobuf/pkg-plist
+++ b/devel/goprotobuf/pkg-plist
@@ -1,7 +1,5 @@
bin/protoc-gen-go
-%%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go/descriptor.a
-%%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go/generator.a
-%%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go/plugin.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/proto.a
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/Makefile
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/all_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/clone.go
@@ -26,13 +24,15 @@ bin/protoc-gen-go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text_parser.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text_parser_test.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text_test.go
-@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go
-@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%
-@dirrmtry %%GO_LIBDIR%%/code.google.com/p
-@dirrmtry %%GO_LIBDIR%%/code.google.com
-@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata
-@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/proto
-@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%/proto
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
@dirrmtry %%GO_SRCDIR%%/code.google.com/p
@dirrmtry %%GO_SRCDIR%%/code.google.com
@dirrmtry %%GO_SRCDIR%%
+@dirrmtry %%GO_LIBDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_LIBDIR%%/code.google.com/p
+@dirrmtry %%GO_LIBDIR%%/code.google.com
+@dirrmtry %%GO_LIBDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go