aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-10-04 19:09:38 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-10-04 19:09:38 +0800
commit338c28c51fd664d3d842d85b53e0927a9915c0be (patch)
treeda87131e39ed52f5c6d6b109dae2ff8dedf24feb /devel
parentf63344d74966c2b97ba8646da9aba4a0ed89b395 (diff)
downloadfreebsd-ports-gnome-338c28c51fd664d3d842d85b53e0927a9915c0be.tar.gz
freebsd-ports-gnome-338c28c51fd664d3d842d85b53e0927a9915c0be.tar.zst
freebsd-ports-gnome-338c28c51fd664d3d842d85b53e0927a9915c0be.zip
A highly-available key value store for shared
configuration and service discovery. etcd is inspired by zookeeper and doozer, with a focus on: * Simple: curl'able user facing API (HTTP+JSON) * Secure: optional SSL client cert authentication * Fast: benchmarked 1000s of writes/s per instance * Reliable: Properly distributed using Raft Etcd is written in Go and uses the raft consensus algorithm to manage a highly-available replicated log. WWW: https://github.com/coreos/etcd#etcd Use PKGNAMEPREFIX=coreos to avoid PKGNAME conflict with audio/etcd PR: ports/182419 Submitted by: Bartek Rutkowski <ports@robakdesign.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/etcd/Makefile39
-rw-r--r--devel/etcd/distinfo2
-rw-r--r--devel/etcd/pkg-descr13
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9e9d2429534a..11fbe7e473a2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -410,6 +410,7 @@
SUBDIR += eric4
SUBDIR += eris
SUBDIR += esdl
+ SUBDIR += etcd
SUBDIR += etl
SUBDIR += eventxx
SUBDIR += evolution-gconf-tools
diff --git a/devel/etcd/Makefile b/devel/etcd/Makefile
new file mode 100644
index 000000000000..615407fac01f
--- /dev/null
+++ b/devel/etcd/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= etcd
+PORTVERSION= 0.1.1
+CATEGORIES= devel
+PKGNAMEPREFIX= coreos
+
+MAINTAINER= ports@robakdesign.com
+COMMENT= Highly-available key value store and service discovery
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= coreos
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 7b28904
+
+PLIST_FILES+= bin/${PORTNAME}
+
+PORTDOCS= README.md
+
+NO_BUILD= yes
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$VER|${DISTVERSION}|' ${WRKSRC}/scripts/release-version
+ @${REINPLACE_CMD} -e '/VER=/d' ${WRKSRC}/scripts/release-version
+ @${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|' ${WRKSRC}/build
+
+pre-install:
+ @(cd ${WRKSRC}; ${SH} build)
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/devel/etcd/distinfo b/devel/etcd/distinfo
new file mode 100644
index 000000000000..940e9185429e
--- /dev/null
+++ b/devel/etcd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (etcd-0.1.1.tar.gz) = 337f173b165360889586a7388f5874bf0b16746992f3cd43ed162f39cd30e9ff
+SIZE (etcd-0.1.1.tar.gz) = 601641
diff --git a/devel/etcd/pkg-descr b/devel/etcd/pkg-descr
new file mode 100644
index 000000000000..d593ab8c93e1
--- /dev/null
+++ b/devel/etcd/pkg-descr
@@ -0,0 +1,13 @@
+A highly-available key value store for shared
+configuration and service discovery. etcd is
+inspired by zookeeper and doozer, with a focus on:
+
+* Simple: curl'able user facing API (HTTP+JSON)
+* Secure: optional SSL client cert authentication
+* Fast: benchmarked 1000s of writes/s per instance
+* Reliable: Properly distributed using Raft
+
+Etcd is written in Go and uses the raft consensus
+algorithm to manage a highly-available replicated log.
+
+WWW: https://github.com/coreos/etcd#etcd