aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2008-06-15 12:46:11 +0800
committerlwhsu <lwhsu@FreeBSD.org>2008-06-15 12:46:11 +0800
commit3432692292285942a9d7e355f954740ec2999666 (patch)
tree7264e5e7d7f7086fd4b209d0814f63afa537b0e3 /devel
parent7cda2577cf7c46c19bbbc27f8dd13166ab4677b3 (diff)
downloadfreebsd-ports-gnome-3432692292285942a9d7e355f954740ec2999666.tar.gz
freebsd-ports-gnome-3432692292285942a9d7e355f954740ec2999666.tar.zst
freebsd-ports-gnome-3432692292285942a9d7e355f954740ec2999666.zip
Add distorm 1.7.29, fast x86 and x86-64 disassembler library.
PR: ports/123627 Submitted by: bf <bf2006a at yahoo.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/distorm/Makefile42
-rw-r--r--devel/distorm/distinfo3
-rw-r--r--devel/distorm/files/patch-Makefile22
-rw-r--r--devel/distorm/pkg-descr10
5 files changed, 78 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5a8ac9120f29..2c9175c0eb3d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -257,6 +257,7 @@
SUBDIR += directfb
SUBDIR += distcc
SUBDIR += distel
+ SUBDIR += distorm
SUBDIR += ditrack
SUBDIR += dits
SUBDIR += djgpp-binutils
diff --git a/devel/distorm/Makefile b/devel/distorm/Makefile
new file mode 100644
index 000000000000..5c23733f3dff
--- /dev/null
+++ b/devel/distorm/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: distorm
+# Date created: 13 May 2008
+# Whom: bf <bf2006a@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= distorm
+PORTVERSION= 1.7.29
+CATEGORIES= devel
+MASTER_SITES= http://www.ragestorm.net/distorm/ \
+ http://www.damogran.de/ports/distorm/
+DISTNAME= ${PORTNAME}64-pkg${PORTVERSION}
+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= Fast x86 and x86-64 disassembler library
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+
+MAKE_ENV+= CC=${CC}
+WRKSRC= ${WRKDIR}/distorm/build/linux
+ALL_TARGET= clib
+PLIST_FILES= bin/disasm lib/libdistorm64.a lib/libdistorm64.so
+
+.ifndef(NOPORTDOCS)
+PORTDOCS= distorm.html qa.txt vol1.html vol2.html
+.endif
+
+do-install:
+ ( cd ${WRKSRC} && ${INSTALL_PROGRAM} libdistorm64.a libdistorm64.so ${PREFIX}/lib \
+ && ${INSTALL_PROGRAM} disasm ${PREFIX}/bin )
+
+.ifndef(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKDIR}/distorm/doc/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/distorm/distinfo b/devel/distorm/distinfo
new file mode 100644
index 000000000000..b0af7dfd412b
--- /dev/null
+++ b/devel/distorm/distinfo
@@ -0,0 +1,3 @@
+MD5 (distorm64-pkg1.7.29.tar.bz2) = 47f13753cd335463aea6011d76ea1660
+SHA256 (distorm64-pkg1.7.29.tar.bz2) = 6f29b6ada8d0bfbc3945b3aa594db389da18861824a9a42846bbc02bc4a091bc
+SIZE (distorm64-pkg1.7.29.tar.bz2) = 90049
diff --git a/devel/distorm/files/patch-Makefile b/devel/distorm/files/patch-Makefile
new file mode 100644
index 000000000000..fa77b74037a3
--- /dev/null
+++ b/devel/distorm/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig 2008-05-12 02:39:48.081089220 -0400
++++ Makefile 2008-05-13 03:48:02.113028254 -0400
+@@ -5,8 +5,7 @@
+ TARGET = libdistorm64.so
+ COBJS = ../../src/x86defs.o ../../src/wstring.o ../../src/textdefs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
+ PYOBJS = ../../src/x86defs.o ../../src/wstring.o ../../src/textdefs.o ../../src/pydistorm.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/decoder.o
+-CC = gcc
+-CFLAGS = -O2 -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL
++CFLAGS += -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL
+
+ all: clib py
+
+@@ -15,7 +14,8 @@
+
+ clib: ${COBJS}
+ ${CC} ${CFLAGS} ${VERSION} ${COBJS} -fPIC -shared -o ${TARGET}
+- ar rs ../../distorm64.a ${COBJS}
++ ar rs libdistorm64.a ${COBJS}
++ ${CC} ${CFLAGS} -o disasm ../../linuxproj/main.c libdistorm64.a
+
+ py: ${PYOBJS}
+ ${CC} ${CFLAGS} ${VERSION} ${PYOBJS} -fPIC -shared -o ${TARGET}
diff --git a/devel/distorm/pkg-descr b/devel/distorm/pkg-descr
new file mode 100644
index 000000000000..f662bb7d0aae
--- /dev/null
+++ b/devel/distorm/pkg-descr
@@ -0,0 +1,10 @@
+diStorm is a binary stream disassembler. It's capable of disassembling
+80x86 instructions in 16, 32, and 64 bits (AMD64, X86-64). In
+addition, it disassembles FPU, MMX, SSE, SSE2, SSE3, SSE4, 3DNow!
+(with extensions), new x86-64 instruction sets, VMX, and AMD's SVM!
+diStorm was written to decode every instruction quickly and accurately,
+with robust handling of valid and unused prefixes. It supports
+multi-threading, which means you can disassemble several streams
+simultaneously.
+
+WWW: http://www.ragestorm.net/distorm/