aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-03-29 19:31:05 +0800
committersat <sat@FreeBSD.org>2007-03-29 19:31:05 +0800
commit34ff6b7530df8f732600e59d96587781fc23017f (patch)
tree7775b81d98b1a56a678fa631cddfa73a0d2cc567 /devel
parent63032085194c131d767076d885b98b982f31ed36 (diff)
downloadfreebsd-ports-gnome-34ff6b7530df8f732600e59d96587781fc23017f.tar.gz
freebsd-ports-gnome-34ff6b7530df8f732600e59d96587781fc23017f.tar.zst
freebsd-ports-gnome-34ff6b7530df8f732600e59d96587781fc23017f.zip
Add port devel/stfl:
STFL is a library which implements a curses-based widget set for text terminals. The STFL API can be used from C, SPL, Python, Perl and Ruby. Since the API is only 14 simple function calls big and there are already generic SWIG bindings it is very easy to port STFL to additional scripting languages. A special language (the Structured Terminal Forms Language) is used to describe STFL GUIs. The language is designed to be easy and fast to write so an application programmer does not need to spend ages fiddling around with the GUI and can concentrate on the more interesting programming tasks. WWW: http://www.clifford.at/stfl/ Author: Clifford Wolf <clifford@clifford.at>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/stfl/Makefile36
-rw-r--r--devel/stfl/distinfo3
-rw-r--r--devel/stfl/pkg-descr14
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e5cf38fa0007..b7b69dd422c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2068,6 +2068,7 @@
SUBDIR += spin
SUBDIR += splint
SUBDIR += st
+ SUBDIR += stfl
SUBDIR += stlfilt
SUBDIR += stlport
SUBDIR += str
diff --git a/devel/stfl/Makefile b/devel/stfl/Makefile
new file mode 100644
index 000000000000..bb627d53d417
--- /dev/null
+++ b/devel/stfl/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: stfl
+# Date created: 28 March 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stfl
+PORTVERSION= 0.7
+CATEGORIES= devel
+MASTER_SITES= http://www.clifford.at/stfl/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Structured Terminal Forms Language/Library
+
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+ALL_TARGET= libstfl.so
+CFLAGS+= -fPIC
+PLIST_FILES= lib/libstfl.so.0 lib/libstfl.so include/stfl.h
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\.a|.so|g;/ranlib/d;s|ar qc|${CC} -shared -fPIC -o|'\
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|alloca.h|stdlib.h|' ${WRKSRC}/widgets/*.c
+ @${ECHO_CMD} 'prefix = ${PREFIX}' > ${WRKSRC}/Makefile.cfg
+
+pre-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} Makefile.deps)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/libstfl.so ${PREFIX}/lib/libstfl.so.0
+ @${LN} -sf ${PREFIX}/lib/libstfl.so.0 ${PREFIX}/lib/libstfl.so
+ @${INSTALL_DATA} ${WRKSRC}/stfl.h ${PREFIX}/include/
+
+.include <bsd.port.mk>
diff --git a/devel/stfl/distinfo b/devel/stfl/distinfo
new file mode 100644
index 000000000000..e0d3fc2362dc
--- /dev/null
+++ b/devel/stfl/distinfo
@@ -0,0 +1,3 @@
+MD5 (stfl-0.7.tar.gz) = 508166ca4031b2728b4c26ed60fa167f
+SHA256 (stfl-0.7.tar.gz) = d8d444ab93232715c47e59a9f2a037f622a662d393a6de7f2f143f8b7811bb7e
+SIZE (stfl-0.7.tar.gz) = 27980
diff --git a/devel/stfl/pkg-descr b/devel/stfl/pkg-descr
new file mode 100644
index 000000000000..0db096a6ced8
--- /dev/null
+++ b/devel/stfl/pkg-descr
@@ -0,0 +1,14 @@
+STFL is a library which implements a curses-based widget set for text
+terminals. The STFL API can be used from C, SPL, Python, Perl and Ruby.
+Since the API is only 14 simple function calls big and there are
+already generic SWIG bindings it is very easy to port STFL to
+additional scripting languages.
+
+A special language (the Structured Terminal Forms Language) is used to
+describe STFL GUIs. The language is designed to be easy and fast to
+write so an application programmer does not need to spend ages fiddling
+around with the GUI and can concentrate on the more interesting
+programming tasks.
+
+WWW: http://www.clifford.at/stfl/
+Author: Clifford Wolf <clifford@clifford.at>