aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-07-29 07:20:25 +0800
committerswills <swills@FreeBSD.org>2013-07-29 07:20:25 +0800
commit3549f1857197473c42842ea8d5f240f47287edb1 (patch)
treedafbeb6ea822fdf82ea46a5d5dd3c52b79400ce0 /devel
parent029097c4124d45bfb9f128d9835587a1d7687248 (diff)
downloadfreebsd-ports-gnome-3549f1857197473c42842ea8d5f240f47287edb1.tar.gz
freebsd-ports-gnome-3549f1857197473c42842ea8d5f240f47287edb1.tar.zst
freebsd-ports-gnome-3549f1857197473c42842ea8d5f240f47287edb1.zip
Ruby wrapper that supports all of the GitHub API v3 methods(nearly 200). It's
build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Repos.new if working solely with repositories is your main concern. WWW: https://github.com/peter-murach/github
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-github_api/Makefile23
-rw-r--r--devel/rubygem-github_api/distinfo2
-rw-r--r--devel/rubygem-github_api/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a7513258cfba..71dc2e769d2a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4091,6 +4091,7 @@
SUBDIR += rubygem-gibbler
SUBDIR += rubygem-gio2
SUBDIR += rubygem-git
+ SUBDIR += rubygem-github_api
SUBDIR += rubygem-glib2
SUBDIR += rubygem-gobject-introspection
SUBDIR += rubygem-grit
diff --git a/devel/rubygem-github_api/Makefile b/devel/rubygem-github_api/Makefile
new file mode 100644
index 000000000000..bc275be4d441
--- /dev/null
+++ b/devel/rubygem-github_api/Makefile
@@ -0,0 +1,23 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= github_api
+PORTVERSION= 0.10.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Wrapper that supports all of the GitHub API v3 methods
+
+RUN_DEPENDS= rubygem-addressable>=0:${PORTSDIR}/www/rubygem-addressable \
+ rubygem-faraday>=0.8.7:${PORTSDIR}/www/rubygem-faraday \
+ rubygem-hashie>=1.2:${PORTSDIR}/devel/rubygem-hashie \
+ rubygem-multi_json>=1.4:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-nokogiri>=1.6.0:${PORTSDIR}/textproc/rubygem-nokogiri \
+ rubygem-oauth2>=0:${PORTSDIR}/net/rubygem-oauth2
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-github_api/distinfo b/devel/rubygem-github_api/distinfo
new file mode 100644
index 000000000000..ac1159d709ae
--- /dev/null
+++ b/devel/rubygem-github_api/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/github_api-0.10.2.gem) = 89e5e9cf093c9ff06691f747f512e8df24e6ad3454f1e7cc97529a1af7529734
+SIZE (rubygem/github_api-0.10.2.gem) = 689152
diff --git a/devel/rubygem-github_api/pkg-descr b/devel/rubygem-github_api/pkg-descr
new file mode 100644
index 000000000000..d19e350a7831
--- /dev/null
+++ b/devel/rubygem-github_api/pkg-descr
@@ -0,0 +1,6 @@
+Ruby wrapper that supports all of the GitHub API v3 methods(nearly 200). It's
+build in a modular way, that is, you can either instantiate the whole api
+wrapper Github.new or use parts of it e.i. Github::Repos.new if working solely
+with repositories is your main concern.
+
+WWW: https://github.com/peter-murach/github