aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2016-10-12 18:17:16 +0800
committernovel <novel@FreeBSD.org>2016-10-12 18:17:16 +0800
commit35cdaf0caf25a77908f3ca29c17bbe6e46b83acd (patch)
tree36d236030a042f85558cf72581d2caca005facf8 /devel
parent8995b235e5063a5746e5f5e5c251c2d62719766b (diff)
downloadfreebsd-ports-gnome-35cdaf0caf25a77908f3ca29c17bbe6e46b83acd.tar.gz
freebsd-ports-gnome-35cdaf0caf25a77908f3ca29c17bbe6e46b83acd.tar.zst
freebsd-ports-gnome-35cdaf0caf25a77908f3ca29c17bbe6e46b83acd.zip
Add py-os-client-config 1.21.1, OpenStack Client Configuation Library.
PR: 213337 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-os-client-config/Makefile26
-rw-r--r--devel/py-os-client-config/distinfo3
-rw-r--r--devel/py-os-client-config/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 15ea70019112..c276aa809673 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4307,6 +4307,7 @@
SUBDIR += py-option_merge
SUBDIR += py-orbit
SUBDIR += py-ordereddict
+ SUBDIR += py-os-client-config
SUBDIR += py-oslo.i18n
SUBDIR += py-oslo.serialization
SUBDIR += py-oslo.utils
diff --git a/devel/py-os-client-config/Makefile b/devel/py-os-client-config/Makefile
new file mode 100644
index 000000000000..13a2a03050db
--- /dev/null
+++ b/devel/py-os-client-config/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= os-client-config
+PORTVERSION= 1.21.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= OpenStack Client Configuation Library
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.1.0:devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}appdirs>=1.3.0:devel/py-appdirs \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=2.1.0:devel/py-keystoneauth1 \
+ ${PYTHON_PKGNAMEPREFIX}requestsexceptions>=1.1.1:devel/py-requestsexceptions
+
+USES= python
+USE_PYTHON= distutils autoplist noegginfo
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,install_requires.*,,' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/devel/py-os-client-config/distinfo b/devel/py-os-client-config/distinfo
new file mode 100644
index 000000000000..f6b8787e9dc2
--- /dev/null
+++ b/devel/py-os-client-config/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475933234
+SHA256 (os-client-config-1.21.1.tar.gz) = ad4c2d07c0468c8d11916ea690b977abb3e903e0c599f6eae02c4776edab2f96
+SIZE (os-client-config-1.21.1.tar.gz) = 62581
diff --git a/devel/py-os-client-config/pkg-descr b/devel/py-os-client-config/pkg-descr
new file mode 100644
index 000000000000..e0d4c823e0de
--- /dev/null
+++ b/devel/py-os-client-config/pkg-descr
@@ -0,0 +1,6 @@
+os-client-config is a library for collecting client configuration for
+using an OpenStack cloud in a consistent and comprehensive manner.
+It will find cloud config for as few as 1 cloud and as many as you
+want to put in a config file.
+
+WWW: https://pypi.python.org/pypi/os-client-config