aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2009-05-10 05:43:48 +0800
committerkwm <kwm@FreeBSD.org>2009-05-10 05:43:48 +0800
commit35d9176fe89cd633d7b45778ab101b7202fbbc41 (patch)
treee9643649e0ab9fd5a33e8f3395583319c1c4bc3e /devel
parenta32d2c6e5fa0034a742f123985f0fcb2b9914c00 (diff)
downloadfreebsd-ports-gnome-35d9176fe89cd633d7b45778ab101b7202fbbc41.tar.gz
freebsd-ports-gnome-35d9176fe89cd633d7b45778ab101b7202fbbc41.tar.zst
freebsd-ports-gnome-35d9176fe89cd633d7b45778ab101b7202fbbc41.zip
libgdata is a GLib-based library for accessing online service APIs using the
GData protocol - most notably, Google's services. It provides APIs to access the common Google services, and has full asynchronous support. WWW: http://live.gnome.org/libgdata
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libgdata/Makefile33
-rw-r--r--devel/libgdata/distinfo3
-rw-r--r--devel/libgdata/pkg-descr8
-rw-r--r--devel/libgdata/pkg-plist70
5 files changed, 115 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 339a26a095ac..68da5aa130c9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -643,6 +643,7 @@
SUBDIR += libgalago
SUBDIR += libgamepad
SUBDIR += libgconf-java
+ SUBDIR += libgdata
SUBDIR += libgetline
SUBDIR += libghthash
SUBDIR += libgii
diff --git a/devel/libgdata/Makefile b/devel/libgdata/Makefile
new file mode 100644
index 000000000000..6ac100d76a62
--- /dev/null
+++ b/devel/libgdata/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libgdata
+# Date created: 9 May 2009
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgdata
+PORTVERSION= 0.2.0
+CATEGORIES= devel
+MASTER_SITES= GNOME
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= GLib based implimentation of the GData protocol
+
+LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= intltool
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--with-html-dir="${PREFIX}/share/doc"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/libgdata/distinfo b/devel/libgdata/distinfo
new file mode 100644
index 000000000000..acc5f0869d94
--- /dev/null
+++ b/devel/libgdata/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgdata-0.2.0.tar.bz2) = 3772ccf571ee0f5113934d83e51579e3
+SHA256 (libgdata-0.2.0.tar.bz2) = 41a6d518376278ca560554009cb737d37a59890fb8a79c1ca10233f995d34813
+SIZE (libgdata-0.2.0.tar.bz2) = 487674
diff --git a/devel/libgdata/pkg-descr b/devel/libgdata/pkg-descr
new file mode 100644
index 000000000000..748252c4cb8b
--- /dev/null
+++ b/devel/libgdata/pkg-descr
@@ -0,0 +1,8 @@
+libgdata is a GLib-based library for accessing online service APIs using the
+GData protocol - most notably, Google's services. It provides APIs to access
+the common Google services, and has full asynchronous support.
+
+A link with more information about the GData protocol is available on the
+website.
+
+WWW: http://live.gnome.org/libgdata
diff --git a/devel/libgdata/pkg-plist b/devel/libgdata/pkg-plist
new file mode 100644
index 000000000000..4d51c73ede21
--- /dev/null
+++ b/devel/libgdata/pkg-plist
@@ -0,0 +1,70 @@
+include/libgdata/gdata/gdata-atom.h
+include/libgdata/gdata/gdata-entry.h
+include/libgdata/gdata/gdata-enums.h
+include/libgdata/gdata/gdata-feed.h
+include/libgdata/gdata/gdata-gdata.h
+include/libgdata/gdata/gdata-media-rss.h
+include/libgdata/gdata/gdata-parser.h
+include/libgdata/gdata/gdata-query.h
+include/libgdata/gdata/gdata-service.h
+include/libgdata/gdata/gdata-types.h
+include/libgdata/gdata/gdata.h
+include/libgdata/gdata/services/calendar/gdata-calendar-calendar.h
+include/libgdata/gdata/services/calendar/gdata-calendar-event.h
+include/libgdata/gdata/services/calendar/gdata-calendar-query.h
+include/libgdata/gdata/services/calendar/gdata-calendar-service.h
+include/libgdata/gdata/services/contacts/gdata-contacts-contact.h
+include/libgdata/gdata/services/contacts/gdata-contacts-query.h
+include/libgdata/gdata/services/contacts/gdata-contacts-service.h
+include/libgdata/gdata/services/youtube/gdata-youtube-enums.h
+include/libgdata/gdata/services/youtube/gdata-youtube-service.h
+include/libgdata/gdata/services/youtube/gdata-youtube-video.h
+include/libgdata/gdata/services/youtube/gdata-youtube.h
+lib/libgdata.a
+lib/libgdata.la
+lib/libgdata.so
+lib/libgdata.so.3
+libdata/pkgconfig/libgdata.pc
+share/doc/gdata/GDataCalendarCalendar.html
+share/doc/gdata/GDataCalendarEvent.html
+share/doc/gdata/GDataCalendarQuery.html
+share/doc/gdata/GDataCalendarService.html
+share/doc/gdata/GDataContactsContact.html
+share/doc/gdata/GDataContactsQuery.html
+share/doc/gdata/GDataContactsService.html
+share/doc/gdata/GDataEntry.html
+share/doc/gdata/GDataFeed.html
+share/doc/gdata/GDataQuery.html
+share/doc/gdata/GDataService.html
+share/doc/gdata/GDataYouTubeService.html
+share/doc/gdata/GDataYouTubeVideo.html
+share/doc/gdata/api-index-full.html
+share/doc/gdata/ch01.html
+share/doc/gdata/ch02.html
+share/doc/gdata/ch03.html
+share/doc/gdata/ch04.html
+share/doc/gdata/ch05.html
+share/doc/gdata/gdata-Atom-API.html
+share/doc/gdata/gdata-GData-API.html
+share/doc/gdata/gdata-GData-Types.html
+share/doc/gdata/gdata-YouTube-API.html
+share/doc/gdata/gdata.devhelp
+share/doc/gdata/gdata.devhelp2
+share/doc/gdata/home.png
+share/doc/gdata/index.html
+share/doc/gdata/index.sgml
+share/doc/gdata/left.png
+share/doc/gdata/object-tree.html
+share/doc/gdata/right.png
+share/doc/gdata/style.css
+share/doc/gdata/up.png
+share/locale/de/LC_MESSAGES/gdata.mo
+share/locale/en_GB/LC_MESSAGES/gdata.mo
+share/locale/sv/LC_MESSAGES/gdata.mo
+@dirrm share/doc/gdata
+@dirrm include/libgdata/gdata/services/youtube
+@dirrm include/libgdata/gdata/services/contacts
+@dirrm include/libgdata/gdata/services/calendar
+@dirrm include/libgdata/gdata/services
+@dirrm include/libgdata/gdata
+@dirrm include/libgdata