aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-03-27 05:05:51 +0800
committersem <sem@FreeBSD.org>2006-03-27 05:05:51 +0800
commit36a83292ddc9d6b6f3393e9b5f36b2de09943644 (patch)
tree97eacab02959564916c1c7413462bca2d9ffe958 /devel
parent343b9461ff47dd403cfde6f650441669ae588d2f (diff)
downloadfreebsd-ports-gnome-36a83292ddc9d6b6f3393e9b5f36b2de09943644.tar.gz
freebsd-ports-gnome-36a83292ddc9d6b6f3393e9b5f36b2de09943644.tar.zst
freebsd-ports-gnome-36a83292ddc9d6b6f3393e9b5f36b2de09943644.zip
This module is a simple visitor implementation for Perl values.
It has a main dispatcher method, visit, which takes a single perl value and then calls the methods appropriate for that value. WWW: http://search.cpan.org/dist/Data-Visitor/ PR: ports/94954 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Visitor/Makefile33
-rw-r--r--devel/p5-Data-Visitor/distinfo3
-rw-r--r--devel/p5-Data-Visitor/pkg-descr6
-rw-r--r--devel/p5-Data-Visitor/pkg-plist4
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 314e874e2160..1e297e8b0990 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -825,6 +825,7 @@
SUBDIR += p5-Data-TreeDumper
SUBDIR += p5-Data-Types
SUBDIR += p5-Data-UUID
+ SUBDIR += p5-Data-Visitor
SUBDIR += p5-Date-Calc
SUBDIR += p5-Date-DayOfWeek
SUBDIR += p5-Date-Easter
diff --git a/devel/p5-Data-Visitor/Makefile b/devel/p5-Data-Visitor/Makefile
new file mode 100644
index 000000000000..3ca20920bc3b
--- /dev/null
+++ b/devel/p5-Data-Visitor/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Data-Visitor
+# Date created: 26 Mar 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Visitor
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Visitor style traversal of Perl data structures
+
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Data::Visitor.3 \
+ Data::Visitor::Callback.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Visitor/distinfo b/devel/p5-Data-Visitor/distinfo
new file mode 100644
index 000000000000..351095d64a47
--- /dev/null
+++ b/devel/p5-Data-Visitor/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Visitor-0.03.tar.gz) = 8109cb2a2c2fda150ed30532b88b84bb
+SHA256 (Data-Visitor-0.03.tar.gz) = e82960aa7f85a2fc03f52e4082317ffdd8fe8ed82c8ef512284608dd241f345a
+SIZE (Data-Visitor-0.03.tar.gz) = 6243
diff --git a/devel/p5-Data-Visitor/pkg-descr b/devel/p5-Data-Visitor/pkg-descr
new file mode 100644
index 000000000000..b5e03001e507
--- /dev/null
+++ b/devel/p5-Data-Visitor/pkg-descr
@@ -0,0 +1,6 @@
+This module is a simple visitor implementation for Perl values.
+
+It has a main dispatcher method, visit, which takes a single perl
+value and then calls the methods appropriate for that value.
+
+WWW: http://search.cpan.org/dist/Data-Visitor/
diff --git a/devel/p5-Data-Visitor/pkg-plist b/devel/p5-Data-Visitor/pkg-plist
new file mode 100644
index 000000000000..57d80b398ac0
--- /dev/null
+++ b/devel/p5-Data-Visitor/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Data/Visitor/Callback.pm
+%%SITE_PERL%%/Data/Visitor.pm
+@dirrmtry %%SITE_PERL%%/Data/Visitor
+@dirrmtry %%SITE_PERL%%/Data