aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-05 02:58:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-05 02:58:31 +0800
commit36f12858be9776bc9d7dec58fd4393719c4265c5 (patch)
tree59fdd7932b3f6e309f02baff574d6f9c2f1be920 /devel
parent87c4fe6e903e672989ad7a2d64b4cccbe93bc38b (diff)
downloadfreebsd-ports-gnome-36f12858be9776bc9d7dec58fd4393719c4265c5.tar.gz
freebsd-ports-gnome-36f12858be9776bc9d7dec58fd4393719c4265c5.tar.zst
freebsd-ports-gnome-36f12858be9776bc9d7dec58fd4393719c4265c5.zip
- Add p5-Data-Clone 0.003
Data::Clone does data cloning, i.e. copies things recursively. This is smart so that it works with not only non-blessed references, but also with blessed references (i.e. objects). When clone() finds an object, it calls a clone method of the object if the object has a clone, otherwise it makes a surface copy of the object. That is, this module does polymorphic data cloning. Although there are several modules on CPAN which can clone data, this module has a different cloning policy from almost all of them. See "Cloning policy" and "Comparison to other cloning modules" [1] for details. [1] http://search.cpan.org/dist/Data-Clone/lib/Data/Clone.pm WWW: http://search.cpan.org/dist/Data-Clone/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Clone/Makefile36
-rw-r--r--devel/p5-Data-Clone/distinfo2
-rw-r--r--devel/p5-Data-Clone/pkg-descr13
-rw-r--r--devel/p5-Data-Clone/pkg-plist8
5 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b38603a2bad8..b6155cb5bf04 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1432,6 +1432,7 @@
SUBDIR += p5-Data-Average
SUBDIR += p5-Data-Bind
SUBDIR += p5-Data-ClearSilver-HDF
+ SUBDIR += p5-Data-Clone
SUBDIR += p5-Data-Compare
SUBDIR += p5-Data-Domain
SUBDIR += p5-Data-Dump
diff --git a/devel/p5-Data-Clone/Makefile b/devel/p5-Data-Clone/Makefile
new file mode 100644
index 000000000000..d1ad68ce7974
--- /dev/null
+++ b/devel/p5-Data-Clone/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Data-Clone
+# Date created: 2011-10-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Clone
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Polymorphic data cloning
+
+TEST_DEPENDS= p5-Test-Requires>=0.03:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Clone.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+RUN_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+RUN_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Clone/distinfo b/devel/p5-Data-Clone/distinfo
new file mode 100644
index 000000000000..99ceb461e56d
--- /dev/null
+++ b/devel/p5-Data-Clone/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Clone-0.003.tar.gz) = 2fb8f1207a6929469d0c00b4e3b9aa22ff2c8290a100a9f51bac91a79c9c8d9a
+SIZE (Data-Clone-0.003.tar.gz) = 33712
diff --git a/devel/p5-Data-Clone/pkg-descr b/devel/p5-Data-Clone/pkg-descr
new file mode 100644
index 000000000000..5cbcd75a7b48
--- /dev/null
+++ b/devel/p5-Data-Clone/pkg-descr
@@ -0,0 +1,13 @@
+Data::Clone does data cloning, i.e. copies things recursively. This is smart so
+that it works with not only non-blessed references, but also with blessed
+references (i.e. objects). When clone() finds an object, it calls a clone method
+of the object if the object has a clone, otherwise it makes a surface copy of
+the object. That is, this module does polymorphic data cloning.
+
+Although there are several modules on CPAN which can clone data, this module has
+a different cloning policy from almost all of them. See "Cloning policy" and
+"Comparison to other cloning modules" [1] for details.
+
+[1] http://search.cpan.org/dist/Data-Clone/lib/Data/Clone.pm
+
+WWW: http://search.cpan.org/dist/Data-Clone/
diff --git a/devel/p5-Data-Clone/pkg-plist b/devel/p5-Data-Clone/pkg-plist
new file mode 100644
index 000000000000..7f0429c24d5a
--- /dev/null
+++ b/devel/p5-Data-Clone/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Clone.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Clone/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Clone/Clone.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Clone/Clone.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Clone/data_clone.h
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Clone
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Data