aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-04-22 20:40:15 +0800
committerpgj <pgj@FreeBSD.org>2009-04-22 20:40:15 +0800
commit39fe538c92c671768264606bf305efc6ee24013b (patch)
tree60449008267f6608a30e21c01caaae79cdfd1553 /devel
parentf2e01a93df70f9ed8accbb90e2b23015fd33c2d2 (diff)
downloadfreebsd-ports-gnome-39fe538c92c671768264606bf305efc6ee24013b.tar.gz
freebsd-ports-gnome-39fe538c92c671768264606bf305efc6ee24013b.tar.zst
freebsd-ports-gnome-39fe538c92c671768264606bf305efc6ee24013b.zip
- Update to 1.31
- Respect NO_INSTALL_MAN_PAGES, CXX - Add "regression-test" target for regression testing - Switch to bzip2 PR: ports/133749 Submitted by: bf <bf2006a (at) yahoo (dot) com> Approved by: tabthorpe (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/cppcheck/Makefile26
-rw-r--r--devel/cppcheck/distinfo6
2 files changed, 22 insertions, 10 deletions
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index efea4862f753..3aa296b77256 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -6,30 +6,42 @@
#
PORTNAME= cppcheck
-PORTVERSION= 1.30
+PORTVERSION= 1.31
CATEGORIES= devel
MASTER_SITES= SF
MAINTAINER= pgj@FreeBSD.org
COMMENT= Static analysis of C/C++ code
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+PLIST_FILES= bin/cppcheck
+
+ALL_TARGET= cppcheck
+
+.if !defined(NO_INSTALL_MANPAGES)
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
MANCOMPRESSED= no
MAN1= cppcheck.1
+ALL_TARGET+= cppcheck.1
-USE_GMAKE= yes
-ALL_TARGET= cppcheck cppcheck.1
-
-PLIST_FILES= bin/cppcheck
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/cppcheck.1 ${PREFIX}/man/man1
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|CXXFLAGS=|CXXFLAGS= ${CXXFLAGS} |' \
+ @${REINPLACE_CMD} -e 's|CXXFLAGS=|CXXFLAGS= ${CXXFLAGS} | ; \
+ s|CXX=(.*)|CXX= ${CXX}|' \
${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/cppcheck ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/cppcheck.1 ${PREFIX}/man/man1
+
+regression-test: build
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} test)
.include <bsd.port.mk>
diff --git a/devel/cppcheck/distinfo b/devel/cppcheck/distinfo
index e886447b03f6..77c27e27de67 100644
--- a/devel/cppcheck/distinfo
+++ b/devel/cppcheck/distinfo
@@ -1,3 +1,3 @@
-MD5 (cppcheck-1.30.tar.gz) = db18605e41e178764c8e809d76396b49
-SHA256 (cppcheck-1.30.tar.gz) = cb6648f9ca2f6085eb4f6d4978fb872a0a2e0bc4dcc7d24fcc9f200d6301211c
-SIZE (cppcheck-1.30.tar.gz) = 133684
+MD5 (cppcheck-1.31.tar.bz2) = db500cee39ceaa7379bb105046d36cce
+SHA256 (cppcheck-1.31.tar.bz2) = 40861e2dbbd9760000eda73058196dba021353d2eaaff50a7d9fa6d0b2f17563
+SIZE (cppcheck-1.31.tar.bz2) = 107894