aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-06-14 22:30:39 +0800
committerculot <culot@FreeBSD.org>2012-06-14 22:30:39 +0800
commit3a0c5c7b4f7ae379a4cd7b38108cbda75e9f404f (patch)
treef5f7ae131e438695eed4141897dc194574049d0b /devel
parent76dc9b274b0134f5dff3c97fd0f7139a86479685 (diff)
downloadfreebsd-ports-gnome-3a0c5c7b4f7ae379a4cd7b38108cbda75e9f404f.tar.gz
freebsd-ports-gnome-3a0c5c7b4f7ae379a4cd7b38108cbda75e9f404f.tar.zst
freebsd-ports-gnome-3a0c5c7b4f7ae379a4cd7b38108cbda75e9f404f.zip
IO::HTML provides an easy way to open a file containing HTML while
automatically determining its encoding. It uses the HTML5 encoding sniffing algorithm specified in section 8.2.2.1 of the draft standard. WWW: http://search.cpan.org/dist/IO-HTML/ This new port is needed to update textproc/p5-HTML-HTML5-Parser.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IO-HTML/Makefile30
-rw-r--r--devel/p5-IO-HTML/distinfo2
-rw-r--r--devel/p5-IO-HTML/pkg-descr5
-rw-r--r--devel/p5-IO-HTML/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c33896804f69..021803d413bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1938,6 +1938,7 @@
SUBDIR += p5-IO-Capture
SUBDIR += p5-IO-CaptureOutput
SUBDIR += p5-IO-Digest
+ SUBDIR += p5-IO-HTML
SUBDIR += p5-IO-Handle-Util
SUBDIR += p5-IO-Interactive
SUBDIR += p5-IO-KQueue
diff --git a/devel/p5-IO-HTML/Makefile b/devel/p5-IO-HTML/Makefile
new file mode 100644
index 000000000000..612009fadb24
--- /dev/null
+++ b/devel/p5-IO-HTML/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-IO-HTML
+# Date created: 2012-06-14
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-HTML
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Open an HTML file with automatic charset detection
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::HTML.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IO-HTML/distinfo b/devel/p5-IO-HTML/distinfo
new file mode 100644
index 000000000000..4dd9fa24fbe8
--- /dev/null
+++ b/devel/p5-IO-HTML/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IO-HTML-0.04.tar.gz) = 854364b7a9ebb34c31a4a70ceea15da32747b1c82b5aad1c6fd7bfc0cc619030
+SIZE (IO-HTML-0.04.tar.gz) = 18582
diff --git a/devel/p5-IO-HTML/pkg-descr b/devel/p5-IO-HTML/pkg-descr
new file mode 100644
index 000000000000..019d8d322ad4
--- /dev/null
+++ b/devel/p5-IO-HTML/pkg-descr
@@ -0,0 +1,5 @@
+IO::HTML provides an easy way to open a file containing HTML while
+automatically determining its encoding. It uses the HTML5 encoding
+sniffing algorithm specified in section 8.2.2.1 of the draft standard.
+
+WWW: http://search.cpan.org/dist/IO-HTML/
diff --git a/devel/p5-IO-HTML/pkg-plist b/devel/p5-IO-HTML/pkg-plist
new file mode 100644
index 000000000000..450f7a607b43
--- /dev/null
+++ b/devel/p5-IO-HTML/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/IO/HTML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/HTML/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/HTML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO
+@dirrmtry %%SITE_PERL%%/IO