aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-07 00:38:36 +0800
committervs <vs@FreeBSD.org>2005-10-07 00:38:36 +0800
commit3a5a10d1a9aae2eae8deb0460fc6098dcf483c4d (patch)
tree057e8081aa78f4ba35839c0aa6d6eb205ef6d192 /devel
parent0899f963034bd9575b6bfbad3097205b367a7e7e (diff)
downloadfreebsd-ports-gnome-3a5a10d1a9aae2eae8deb0460fc6098dcf483c4d.tar.gz
freebsd-ports-gnome-3a5a10d1a9aae2eae8deb0460fc6098dcf483c4d.tar.zst
freebsd-ports-gnome-3a5a10d1a9aae2eae8deb0460fc6098dcf483c4d.zip
USE_INC_LIBTOOL instead of local patch
Diffstat (limited to 'devel')
-rw-r--r--devel/libcwd/Makefile4
-rw-r--r--devel/libcwd/files/patch-ltmain.sh15
2 files changed, 4 insertions, 15 deletions
diff --git a/devel/libcwd/Makefile b/devel/libcwd/Makefile
index cb118862a073..768e134df1fb 100644
--- a/devel/libcwd/Makefile
+++ b/devel/libcwd/Makefile
@@ -19,6 +19,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-threading
USE_GMAKE= yes
USE_GNOME= pkgconfig
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_GETOPT_LONG=yes
@@ -41,4 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|--tag=CXX||g' ${WRKSRC}/${MAKEFILE}.in \
${WRKSRC}/utils/${MAKEFILE}.in
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}
+
.include <bsd.port.post.mk>
diff --git a/devel/libcwd/files/patch-ltmain.sh b/devel/libcwd/files/patch-ltmain.sh
deleted file mode 100644
index 8504e351627c..000000000000
--- a/devel/libcwd/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Mon Nov 10 15:51:52 2003
-+++ ltmain.sh Mon Nov 10 15:52:02 2003
-@@ -4330,10 +4330,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"