aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2004-05-27 22:12:50 +0800
committernobutaka <nobutaka@FreeBSD.org>2004-05-27 22:12:50 +0800
commit3b347191d9111d69ca03a20b16d9c0273ac4d794 (patch)
tree1b1a29fbc6ce95ef5e184d1787d0011f4612a764 /devel
parente5d59655cf9be316fe7eb33d88d2c2b272b9d5cb (diff)
downloadfreebsd-ports-gnome-3b347191d9111d69ca03a20b16d9c0273ac4d794.tar.gz
freebsd-ports-gnome-3b347191d9111d69ca03a20b16d9c0273ac4d794.tar.zst
freebsd-ports-gnome-3b347191d9111d69ca03a20b16d9c0273ac4d794.zip
Use "on" and "off" instead of "yes" and "no" in OPTIONS. [1]
Check WITHOUT_* knobs. [2] Use USE_GNOME=lthack. Fix PKGNAMESUFFIX recursion. Submitted by: kris [1] [2]
Diffstat (limited to 'devel')
-rw-r--r--devel/boehm-gc/Makefile26
-rw-r--r--devel/boehm-gc/files/patch-configure10
2 files changed, 14 insertions, 22 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 7a17d2b9e407..e6eebe4ee0ed 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= boehm-gc
PORTVERSION= 6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/
DISTNAME= gc${PORTVERSION:S/.a/alpha/}
@@ -16,33 +16,35 @@ MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Garbage collection and memory leak detection for C and C++
USE_LIBTOOL_VER= 13
+USE_GNOME= lthack
USE_REINPLACE= yes
HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-cplusplus
-OPTIONS= REDIRECT "Define malloc(3)-family replacements" no \
- FULLDEBUG "full-debug support (see documentation)" no \
- THREADING "POSIX thread support" no \
- PARALLEL_MARK "Parallel-thread marking (faster for SMP)" yes
+OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
+ FULLDEBUG "full-debug support (see documentation)" off \
+ THREADING "POSIX thread support" off \
+ PARALLEL_MARK "Parallel-thread marking (faster for SMP)" on
.include <bsd.port.pre.mk>
-.ifdef WITH_THREADING
+.if defined(WITH_THREADING) && !defined(WITHOUT_THREADING)
CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
-.ifdef WITH_PARALLEL_MARK
+.if defined(WITH_PARALLEL_MARK) && !defined(WITHOUT_PARALLEL_MARK)
CONFIGURE_ARGS+= --enable-parallel-mark
.endif
-PKGNAMESUFFIX= +threaded
+PKGNAMESUFFIX= +threaded
.else
CONFIGURE_ARGS+= --disable-threads
+PKGNAMESUFFIX= # empty
.endif
-.ifdef WITH_REDIRECT
+.if defined(WITH_REDIRECT) && !defined(WITHOUT_REDIRECT)
CONFIGURE_ARGS+= --enable-redirect-malloc
-PKGNAMESUFFIX:=${PKGNAMESUFFIX}+redirect
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+redirect
.endif
-.ifdef WITH_FULLDEBUG
+.if defined(WITH_FULLDEBUG) && !defined(WITHOUT_FULLDEBUG)
CONFIGURE_ARGS+= --enable-full-debug
-PKGNAMESUFFIX:=${PKGNAMESUFFIX}+fulldebug
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
.endif
MAN3= gc.3
diff --git a/devel/boehm-gc/files/patch-configure b/devel/boehm-gc/files/patch-configure
deleted file mode 100644
index c57796210d9f..000000000000
--- a/devel/boehm-gc/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Wed May 14 05:07:49 2003
-+++ configure Mon Jun 2 22:48:04 2003
-@@ -8488,6 +8488,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'