aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-04-14 09:29:04 +0800
committerclsung <clsung@FreeBSD.org>2008-04-14 09:29:04 +0800
commit405072f66a780e50052b67ec608769d2fb05a1b2 (patch)
treef24c8aef985b691acbaf5d73c111a0a9796fa057 /devel
parent129d3691c0f46236b373f33603940cbfbc63d2fb (diff)
downloadfreebsd-ports-gnome-405072f66a780e50052b67ec608769d2fb05a1b2.tar.gz
freebsd-ports-gnome-405072f66a780e50052b67ec608769d2fb05a1b2.tar.zst
freebsd-ports-gnome-405072f66a780e50052b67ec608769d2fb05a1b2.zip
Class::Component is pluggable component framework. The compatibilities such
as dump and load such as YAML are good. WWW: http://search.cpan.org/dist/Class-Component/ PR: ports/122719 Submitted by: Tomoyuki Sakurai <cherry at trombik.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Component/Makefile29
-rw-r--r--devel/p5-Class-Component/distinfo3
-rw-r--r--devel/p5-Class-Component/pkg-descr4
-rw-r--r--devel/p5-Class-Component/pkg-plist24
5 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fa1c10c3e488..de12cdf88e9a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -974,6 +974,7 @@
SUBDIR += p5-Class-C3-XS
SUBDIR += p5-Class-Closure
SUBDIR += p5-Class-CodeStyler
+ SUBDIR += p5-Class-Component
SUBDIR += p5-Class-Constant
SUBDIR += p5-Class-Container
SUBDIR += p5-Class-Contract
diff --git a/devel/p5-Class-Component/Makefile b/devel/p5-Class-Component/Makefile
new file mode 100644
index 000000000000..2ffaaea7d4b0
--- /dev/null
+++ b/devel/p5-Class-Component/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Class-Component
+# Date created: Fri Apr 11 16:34:55 2008
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Component
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Pluggable component framework
+
+RUN_DEPENDS= p5-Carp-Clan>0:${PORTSDIR}/devel/p5-Carp-Clan \
+ p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Inspector>0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_CONFIGURE= Yes
+
+MAN3= Class::Component::Component::Plaggerize.3 \
+ Class::Component.3 \
+ Class::Component::Plugin.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Component/distinfo b/devel/p5-Class-Component/distinfo
new file mode 100644
index 000000000000..d691da38ba52
--- /dev/null
+++ b/devel/p5-Class-Component/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Component-0.15.tar.gz) = 2c4547864f878d0140d67dcca5f71e36
+SHA256 (Class-Component-0.15.tar.gz) = 75478f8b8302acad449daf76996be91afff9e7c5b47219ba08231b6155cee25e
+SIZE (Class-Component-0.15.tar.gz) = 28924
diff --git a/devel/p5-Class-Component/pkg-descr b/devel/p5-Class-Component/pkg-descr
new file mode 100644
index 000000000000..2628259047b9
--- /dev/null
+++ b/devel/p5-Class-Component/pkg-descr
@@ -0,0 +1,4 @@
+Class::Component is pluggable component framework. The compatibilities such
+as dump and load such as YAML are good.
+
+WWW: http://search.cpan.org/dist/Class-Component/
diff --git a/devel/p5-Class-Component/pkg-plist b/devel/p5-Class-Component/pkg-plist
new file mode 100644
index 000000000000..d81a1ba1751a
--- /dev/null
+++ b/devel/p5-Class-Component/pkg-plist
@@ -0,0 +1,24 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Class/Component/Attribute/Hook.pm
+%%SITE_PERL%%/Class/Component/Attribute/Method.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall/SingletonMethod.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall/InjectMethod.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall/Autoload.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize/Log.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize/PluginLoader.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize/ConfigLoader.pm
+%%SITE_PERL%%/Class/Component/Component/AutoloadPlugin.pm
+%%SITE_PERL%%/Class/Component/Component/DisableDynamicPlugin.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize.pm
+%%SITE_PERL%%/Class/Component/Component/SingletonMethod.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall.pm
+%%SITE_PERL%%/Class/Component/Attribute.pm
+%%SITE_PERL%%/Class/Component/Plugin.pm
+%%SITE_PERL%%/Class/Component.pm
+%%SITE_PERL%%/mach/auto/Class/Component/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Class/Component
+@dirrmtry %%SITE_PERL%%/Class/Component/Component/Plaggerize
+@dirrmtry %%SITE_PERL%%/Class/Component/Component/Autocall
+@dirrmtry %%SITE_PERL%%/Class/Component/Component
+@dirrmtry %%SITE_PERL%%/Class/Component/Attribute
+@dirrmtry %%SITE_PERL%%/Class/Component