aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-26 22:11:35 +0800
committermiwi <miwi@FreeBSD.org>2013-03-26 22:11:35 +0800
commit42cedb70759337fe3ce71cf48a01852ba079c431 (patch)
tree856d89fa391fd0153ae07ee10860006069ad96d1 /devel
parent0f64e7d97a1e906bb5339b8823118eaecaf484b6 (diff)
downloadfreebsd-ports-gnome-42cedb70759337fe3ce71cf48a01852ba079c431.tar.gz
freebsd-ports-gnome-42cedb70759337fe3ce71cf48a01852ba079c431.tar.zst
freebsd-ports-gnome-42cedb70759337fe3ce71cf48a01852ba079c431.zip
- Update to 2.1.3
PR: v176562 Submitted by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/kyra/Makefile48
-rw-r--r--devel/kyra/distinfo4
-rw-r--r--devel/kyra/files/patch-encoder__MakefileKyra11
-rw-r--r--devel/kyra/files/patch-engine__MakefileKyra10
-rw-r--r--devel/kyra/files/patch-engine_imagetree.h6
-rw-r--r--devel/kyra/files/patch-engine_imnode.h11
-rw-r--r--devel/kyra/files/patch-guitest__guitest.cpp26
-rw-r--r--devel/kyra/files/patch-util_gltypes.h13
-rw-r--r--devel/kyra/pkg-plist21
9 files changed, 86 insertions, 64 deletions
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index 8d86f75e13a7..6b0895018fd2 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -1,32 +1,46 @@
-# New ports collection makefile for: kyra
-# Date created: 10.05.2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
-#
PORTNAME= kyra
-PORTVERSION= 2.0.7
-PORTREVISION= 12
+PORTVERSION= 2.1.3
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2/${PORTVERSION}
DISTNAME= ${PORTNAME}_src_${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A simple Sprite engine written in C++
+COMMENT= Simple Sprite engine written in C++
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LICENSE= GPLv2
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png15:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_AUTOTOOLS= libtool
+USE_ZIP= yes
+USE_GL= gl
USE_SDL= image sdl
-USE_GNOME= lthack
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
+USE_GMAKE= yes
+MAKEFILE= MakefileKyra
+MAKE_ENV= MAKE_KYRA=RELEASE KYRA_OPENGL=YES
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
+ RELEASE_CFLAGS="${CFLAGS}" RELEASE_CXXFLAGS="${CXXFLAGS}"
+MAKE_JOBS_SAFE= yes
+
+do-install:
+.for i in encoder spriteed
+ (cd ${WRKSRC}/${i} && ${INSTALL_PROGRAM} kr${i} ${PREFIX}/bin)
+.endfor
+ (cd ${WRKSRC}/engine && ${INSTALL_DATA} libkyra.a ${PREFIX}/lib)
+ @${MKDIR} ${PREFIX}/include/Kyra
+ (cd ${WRKSRC} && ${INSTALL_DATA} kyra.h ${PREFIX}/include/Kyra)
+.for i in engine gui guiExtended util
+ @${MKDIR} ${PREFIX}/include/Kyra/${i}
+ (cd ${WRKSRC}/${i} && ${INSTALL_DATA} *.h ${PREFIX}/include/Kyra/${i})
+.endfor
+ @${MKDIR} ${PREFIX}/include/Kyra/tinyxml
+ (cd ${WRKSRC}/../tinyxml && ${INSTALL_DATA} *.h \
+ ${PREFIX}/include/Kyra/tinyxml)
.include <bsd.port.mk>
diff --git a/devel/kyra/distinfo b/devel/kyra/distinfo
index a54aa7038e2f..d7569e6db02d 100644
--- a/devel/kyra/distinfo
+++ b/devel/kyra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kyra_src_2_0_7.tar.gz) = 63502490ed5e0a0c1c7fb68410412ab498eb3b26898ec7ebdd328845bba114c6
-SIZE (kyra_src_2_0_7.tar.gz) = 1994743
+SHA256 (kyra_src_2_1_3.zip) = 19a9f2bceca6ddd5945fb687590e18f29b73819901a476f85ce9c37bec4170f0
+SIZE (kyra_src_2_1_3.zip) = 3595503
diff --git a/devel/kyra/files/patch-encoder__MakefileKyra b/devel/kyra/files/patch-encoder__MakefileKyra
new file mode 100644
index 000000000000..7dccfc1b79dd
--- /dev/null
+++ b/devel/kyra/files/patch-encoder__MakefileKyra
@@ -0,0 +1,11 @@
+--- encoder/MakefileKyra.orig
++++ encoder/MakefileKyra
+@@ -110,7 +110,7 @@
+ # Output
+ #****************************************************************************
+
+-${OUTPUT}: ${OBJS} ${LIBS}
++${OUTPUT}: ${OBJS} ../engine/libkyra.a
+ ${LD} -o $@ ${LDFLAGS} ${OBJS} ${LIBS} ${EXTRA_LIBS}
+
+ #****************************************************************************
diff --git a/devel/kyra/files/patch-engine__MakefileKyra b/devel/kyra/files/patch-engine__MakefileKyra
new file mode 100644
index 000000000000..c0ee8d2ed656
--- /dev/null
+++ b/devel/kyra/files/patch-engine__MakefileKyra
@@ -0,0 +1,10 @@
+--- engine/MakefileKyra.orig
++++ engine/MakefileKyra
+@@ -130,6 +130,7 @@
+ ../util/glstring.cpp \
+ ../util/glisomath.cpp \
+ ../../grinliz/gldebug.cpp \
++ ../../grinliz/gldynamic.cpp \
+ ../../grinliz/glperformance.cpp \
+ ../../grinliz/glgeometry.cpp \
+ ../../grinliz/glprime.cpp \
diff --git a/devel/kyra/files/patch-engine_imagetree.h b/devel/kyra/files/patch-engine_imagetree.h
index 8152be4256ca..3a80086453cb 100644
--- a/devel/kyra/files/patch-engine_imagetree.h
+++ b/devel/kyra/files/patch-engine_imagetree.h
@@ -1,11 +1,11 @@
--- engine/imagetree.h.orig 2007-11-12 17:22:54.000000000 +0100
+++ engine/imagetree.h 2007-11-12 17:23:06.000000000 +0100
-@@ -217,7 +217,7 @@
+@@ -190,7 +190,7 @@
void Clear( KrImNode* root ); // delete the entire tree
// Recursive hit test walk.
-- bool KrImageTree::HitTestRec( KrImNode* node, int x, int y, int flags, GlDynArray<KrImage*>* outputArray, int windowIndex );
-+ bool HitTestRec( KrImNode* node, int x, int y, int flags, GlDynArray<KrImage*>* outputArray, int windowIndex );
+- bool KrImageTree::HitTestRec( KrImNode* node, int x, int y, int flags, std::vector<KrImage*>* outputArray, int windowIndex );
++ bool HitTestRec( KrImNode* node, int x, int y, int flags, std::vector<KrImage*>* outputArray, int windowIndex );
KrImNode* root; // The root to position the window
KrImNode* offsetRoot; // The root as returned to the client
diff --git a/devel/kyra/files/patch-engine_imnode.h b/devel/kyra/files/patch-engine_imnode.h
deleted file mode 100644
index 694f234e6def..000000000000
--- a/devel/kyra/files/patch-engine_imnode.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- engine/imnode.h.orig 2007-11-13 12:15:46.000000000 +0100
-+++ engine/imnode.h 2007-11-13 12:18:19.000000000 +0100
-@@ -288,7 +288,7 @@
- /// Fetches the user defined data.
- void* GetUserData() { return userData; }
- /// Fetches the user defined data. Fetches the *same* user data as GetUserData, just uses a convenience cast.
-- U32 GetUserDataU32() { return (U32) userData; }
-+ //U32 GetUserDataU32() { return (U32) userData; }
-
- /** Return a copy if this object, not in a Tree(). It is
- return untransformed. In the case of a sprite, the action
diff --git a/devel/kyra/files/patch-guitest__guitest.cpp b/devel/kyra/files/patch-guitest__guitest.cpp
new file mode 100644
index 000000000000..d70993b5656c
--- /dev/null
+++ b/devel/kyra/files/patch-guitest__guitest.cpp
@@ -0,0 +1,26 @@
+--- guitest/guitest.cpp.orig
++++ guitest/guitest.cpp
+@@ -96,19 +96,19 @@
+ switch ( event.type )
+ {
+ case KrWidgetEvent::ACTIVATED:
+- sprintf( buf, "ACTIVATED %s source=0x%x\n", source->WidgetType(), (unsigned)source );
++ sprintf( buf, "ACTIVATED %s source=0x%x\n", source->WidgetType(), (uintptr_t)source );
+ break;
+
+ case KrWidgetEvent::DEACTIVATED:
+- sprintf( buf, "DEACTIVATED %s source=0x%x\n", source->WidgetType(), (unsigned)source );
++ sprintf( buf, "DEACTIVATED %s source=0x%x\n", source->WidgetType(), (uintptr_t)source );
+ break;
+
+ case KrWidgetEvent::COMMAND:
+- sprintf( buf, "COMMAND %s source=0x%x command=%s arg=%s\n", source->WidgetType(), (unsigned)source, event.command.command, event.command.arg );
++ sprintf( buf, "COMMAND %s source=0x%x command=%s arg=%s\n", source->WidgetType(), (uintptr_t)source, event.command.command, event.command.arg );
+ break;
+
+ case KrWidgetEvent::SELECTION:
+- sprintf( buf, "SELECTION %s source=0x%x id=%d text=%s\n", source->WidgetType(), (unsigned)source, event.selection.index, event.selection.text ? event.selection.text : "(null)" );
++ sprintf( buf, "SELECTION %s source=0x%x id=%d text=%s\n", source->WidgetType(), (uintptr_t)source, event.selection.index, event.selection.text ? event.selection.text : "(null)" );
+ break;
+
+ default:
diff --git a/devel/kyra/files/patch-util_gltypes.h b/devel/kyra/files/patch-util_gltypes.h
deleted file mode 100644
index 1b858a22e3e3..000000000000
--- a/devel/kyra/files/patch-util_gltypes.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- util/gltypes.h.orig Tue Sep 12 19:01:55 2006
-+++ util/gltypes.h Tue Sep 12 19:02:26 2006
-@@ -40,8 +40,8 @@
- typedef Sint32 S32;
-
- #ifdef SDL_HAS_64BIT_TYPE
-- typedef SDL_HAS_64BIT_TYPE S64;
-- typedef unsigned SDL_HAS_64BIT_TYPE U64;
-+ typedef Sint64 S64;
-+ typedef Uint64 U64;
- #else
- #error No 64-bit integer.
- #endif
diff --git a/devel/kyra/pkg-plist b/devel/kyra/pkg-plist
index a7a9bf1a04f2..263c6f984509 100644
--- a/devel/kyra/pkg-plist
+++ b/devel/kyra/pkg-plist
@@ -1,6 +1,5 @@
bin/krencoder
bin/krspriteed
-bin/kyra-config
include/Kyra/engine/action.h
include/Kyra/engine/box.h
include/Kyra/engine/boxresource.h
@@ -28,7 +27,6 @@ include/Kyra/engine/parser.h
include/Kyra/engine/pixelblock.h
include/Kyra/engine/rle.h
include/Kyra/engine/sdlutil.h
-include/Kyra/engine/splash.h
include/Kyra/engine/sprite.h
include/Kyra/engine/spriteresource.h
include/Kyra/engine/tags.h
@@ -46,33 +44,20 @@ include/Kyra/guiExtended/KrImageListBox.h
include/Kyra/guiExtended/progress.h
include/Kyra/kyra.h
include/Kyra/tinyxml/tinyxml.h
+include/Kyra/tinyxml/tinystr.h
include/Kyra/util/glbitstream.h
include/Kyra/util/glcirclelist.h
include/Kyra/util/gldebug.h
-include/Kyra/util/gldynarray.h
include/Kyra/util/glfixed.h
-include/Kyra/util/glgraph.h
include/Kyra/util/glinsidelist.h
include/Kyra/util/glintarrayset.h
include/Kyra/util/glisomath.h
include/Kyra/util/gllist.h
-include/Kyra/util/glmap.h
-include/Kyra/util/glmemorypool.h
-include/Kyra/util/glperformance.h
-include/Kyra/util/glprime.h
-include/Kyra/util/glrandom.h
-include/Kyra/util/glstack.h
include/Kyra/util/glstring.h
-include/Kyra/util/gltypes.h
-include/Kyra/util/glutil.h
lib/libkyra.a
-lib/libkyra.la
-lib/libkyra.so
-lib/libkyra.so.0
-share/aclocal/kyra.m4
@dirrm include/Kyra/util
-@dirrm include/Kyra/gui
+@dirrm include/Kyra/tinyxml
@dirrm include/Kyra/guiExtended
+@dirrm include/Kyra/gui
@dirrm include/Kyra/engine
-@dirrm include/Kyra/tinyxml
@dirrm include/Kyra