aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-09 19:14:18 +0800
committermiwi <miwi@FreeBSD.org>2009-09-09 19:14:18 +0800
commit43eb2ed293bb0a1ac5174319be45f0ad271819c5 (patch)
tree9f5bf44aa05db79e28bbd5e5d7d4e024a560a113 /devel
parentfa54abfc5ecc2ccd0d1946ecac171d3c4a61057c (diff)
downloadfreebsd-ports-gnome-43eb2ed293bb0a1ac5174319be45f0ad271819c5.tar.gz
freebsd-ports-gnome-43eb2ed293bb0a1ac5174319be45f0ad271819c5.tar.zst
freebsd-ports-gnome-43eb2ed293bb0a1ac5174319be45f0ad271819c5.zip
- Update to 1.3.0a2
PR: 138558 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/shapelib/Makefile11
-rw-r--r--devel/shapelib/distinfo6
-rw-r--r--devel/shapelib/files/patch-Makefile39
-rw-r--r--devel/shapelib/files/patch-contrib-Makefile26
-rw-r--r--devel/shapelib/files/patch-shapefil.h6
-rw-r--r--devel/shapelib/files/patch-shputils.c20
-rw-r--r--devel/shapelib/pkg-plist8
7 files changed, 58 insertions, 58 deletions
diff --git a/devel/shapelib/Makefile b/devel/shapelib/Makefile
index 259400b3936a..1a855a6c1a4e 100644
--- a/devel/shapelib/Makefile
+++ b/devel/shapelib/Makefile
@@ -6,20 +6,23 @@
#
PORTNAME= shapelib
-PORTVERSION= 1.2.10
-PORTREVISION= 2
+PORTVERSION= 1.3.0
CATEGORIES= devel
-MASTER_SITES= http://dl.maptools.org/dl/shapelib/ \
+MASTER_SITES= http://download.osgeo.org/shapelib/ \
http://sunpoet.net/distfiles/
+DISTNAME= ${PORTNAME}-${SHAPELIB_VER}
MAINTAINER= sunpoet@sunpoet.net
COMMENT= C API for reading and writing ArcView Shapefiles
USE_AUTOTOOLS= libtool:22:env
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${SHAPELIB_VER}
OPTIONS= PROJ4 "Cartographic Projections library" off
+SHAPELIB_VER= ${PORTVERSION}a2
+
.include <bsd.port.pre.mk>
.if defined(WITH_PROJ4)
@@ -49,7 +52,7 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/web/*.html ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/devel/shapelib/distinfo b/devel/shapelib/distinfo
index 2223a9a094e1..a4c534fb31a8 100644
--- a/devel/shapelib/distinfo
+++ b/devel/shapelib/distinfo
@@ -1,3 +1,3 @@
-MD5 (shapelib-1.2.10.tar.gz) = 4d96bd926167193d27bf14d56e2d484e
-SHA256 (shapelib-1.2.10.tar.gz) = afa54d60369e49a3d2ebcd1ffca75104bdc85d7f539b81aec8a6e2d311ca6b78
-SIZE (shapelib-1.2.10.tar.gz) = 167219
+MD5 (shapelib-1.3.0a2.tar.gz) = fb6e252a0aba3de6870b79ee664d5862
+SHA256 (shapelib-1.3.0a2.tar.gz) = bfc4aa0a164f5f2ee6533d15a5667b7686805ecd80cbedca7d6d4b8ff91b6293
+SIZE (shapelib-1.3.0a2.tar.gz) = 177688
diff --git a/devel/shapelib/files/patch-Makefile b/devel/shapelib/files/patch-Makefile
index 7211a6b294a0..9a1face89568 100644
--- a/devel/shapelib/files/patch-Makefile
+++ b/devel/shapelib/files/patch-Makefile
@@ -1,11 +1,17 @@
---- Makefile.orig 2003-04-07 21:03:22.000000000 +0800
-+++ Makefile 2008-02-25 13:53:10.000000000 +0800
-@@ -1,10 +1,35 @@
--
--#LINKOPT = /usr/local/lib/libdbmalloc.a
--CFLAGS = -g
+--- Makefile.orig 2007-12-14 04:27:13.000000000 +0800
++++ Makefile 2009-09-06 05:40:38.000000000 +0800
+@@ -1,7 +1,7 @@
+
+-#LINKOPT = /usr/local/lib/libdbmalloc.a
+-#LINKOPT = /usr/local/lib/cpl.a
+-CFLAGS = -g -Wall
+#LINKOPT = %%PREFIX%%/lib/libdbmalloc.a
-+CFLAGS += -g
++#LINKOPT = %%PREFIX%%/lib/cpl.a
++CFLAGS += -g -Wall
+ #CFLAGS = -g -DUSE_CPL
+ INSTALL = /usr/bin/install
+ LD = /usr/bin/ld
+@@ -9,7 +9,33 @@
default: all
@@ -40,14 +46,14 @@
shpopen.o: shpopen.c shapefil.h
$(CC) $(CFLAGS) -c shpopen.c
-@@ -92,51 +117,18 @@
+@@ -100,51 +126,19 @@
# -----------------------------------------------------------------------------
-# The following is contributed by Jan-Oliver Wagner, and should allow for
-# creating shared libraries on most platforms with gcc, and libtool installed.
+# A truly insane amount of hackery to make things actually work with
-+# libtool-1.5.x -- you'd not believe the garbage that was here before.
++# libtool-2.2.x -- you'd not believe the garbage that was here before.
-SHPLIB_VERSION=1.2.9
-LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
@@ -73,7 +79,7 @@
- rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
- rm -fr .libs/libshp.lax
- mkdir .libs/libshp.lax
-- /usr/bin/ld -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
-
- (cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
@@ -84,21 +90,22 @@
+ %%LIBTOOL%% --mode=compile --tag=CXX $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I%%PREFIX%%/include $(CFLAGS) -c shpopen.c
+ %%LIBTOOL%% --mode=compile --tag=CXX $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I%%PREFIX%%/include $(CFLAGS) -c shptree.c
+ %%LIBTOOL%% --mode=compile --tag=CXX $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I%%PREFIX%%/include $(CFLAGS) -c dbfopen.c
-+ %%LIBTOOL%% --mode=link --tag=CXX $(CC) $(CFLAGS) -o libshp.la -rpath %%PREFIX%%/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
++ %%LIBTOOL%% --mode=compile --tag=CXX $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I%%PREFIX%%/include $(CFLAGS) -c safileio.c
++ %%LIBTOOL%% --mode=link --tag=CXX $(CC) $(CFLAGS) -o libshp.la -rpath %%PREFIX%%/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo safileio.lo
lib_install:
- cp .libs/libshp.la .libs/libshp.lai
- /bin/sh ./mkinstalldirs /usr/local/lib
-- /bin/sh ./libtool --mode=install /usr/bin/install -c libshp.la /usr/local/lib/libshp.la
-- /usr/bin/install -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
+- /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la /usr/local/lib/libshp.la
+- $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
- chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
-- /usr/bin/install -c .libs/libshp.la /usr/local/lib/libshp.la
-- /usr/bin/install -c .libs/libshp.a /usr/local/lib/libshp.a
+- $(INSTALL) -c .libs/libshp.la /usr/local/lib/libshp.la
+- $(INSTALL) -c .libs/libshp.a /usr/local/lib/libshp.a
- ranlib /usr/local/lib/libshp.a
- chmod 644 /usr/local/lib/libshp.a
- /bin/sh ./mkinstalldirs /usr/local/include/libshp
-- /usr/bin/install -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+- $(INSTALL) -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+ %%LIBTOOL%% --mode=install %%INSTALL%% -c libshp.la %%PREFIX%%/lib/libshp.la
+ %%INSTALL%% -c -m 644 shapefil.h %%PREFIX%%/include/shapefil.h
diff --git a/devel/shapelib/files/patch-contrib-Makefile b/devel/shapelib/files/patch-contrib-Makefile
index b4bd99573822..03d492244a1e 100644
--- a/devel/shapelib/files/patch-contrib-Makefile
+++ b/devel/shapelib/files/patch-contrib-Makefile
@@ -1,6 +1,6 @@
---- contrib/Makefile.orig 2003-04-07 21:03:22.000000000 +0800
-+++ contrib/Makefile 2008-02-25 13:54:58.000000000 +0800
-@@ -3,9 +3,9 @@
+--- contrib/Makefile.orig 2004-06-24 08:55:52.000000000 +0800
++++ contrib/Makefile 2009-09-06 05:35:24.000000000 +0800
+@@ -3,19 +3,44 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
@@ -10,14 +10,18 @@
-CFLAGS = -g -I.. -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+CFLAGS += -g -I.. -DDEBUG -DDEBUG2 %%ENDIAN%% %%PROJ4%% -I%%PREFIX%%/include -L%%PREFIX%%/lib
- SHPOBJ = ../shpopen.o ../dbfopen.o
+-SHPOBJ = ../shpopen.o ../dbfopen.o
++SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
-@@ -15,7 +15,32 @@
+-SHPGOBJ = ../shpopen.o ../dbfopen.o shpgeo.o
++SHPGOBJ = ../shpopen.o ../dbfopen.o ../safileio.o shpgeo.o
+
+ GEOOBJ = ./shpgeo.o -lm -lproj
default: all
--all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat
-+#all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat
+-all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
++#all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
+
+.if defined(PROJ4)
+all: allprog allproj
@@ -27,20 +31,20 @@
+install: allprog_install
+.endif
+
-+ALLPROG= dbfcat dbfinfo shpcat shpdxf shpfix
-+ALLPROJ= shpcentrd shpdata shpinfo shpproj shpwkb
++ALLPROG= dbfcat dbfinfo shpcat shpdxf shpfix Shape_PointInPoly
++ALLPROJ= shpcentrd shpdata shpinfo shpproj shpwkb shpsort
+
+allprog: $(ALLPROG)
+
+allprog_install: $(ALLPROG)
-+.for _ALLPROG in ${ALLPROG}
++.for _ALLPROG in $(ALLPROG)
+ %%INSTALL%% -c -m 755 ${_ALLPROG} %%PREFIX%%/bin/${_ALLPROG}
+.endfor
+
+allproj: $(ALLPROJ)
+
+allproj_install: $(ALLPROJ)
-+.for _ALLPROJ in ${ALLPROJ}
++.for _ALLPROJ in $(ALLPROJ)
+ %%INSTALL%% -c -m 755 ${_ALLPROJ} %%PREFIX%%/bin/${_ALLPROJ}
+.endfor
diff --git a/devel/shapelib/files/patch-shapefil.h b/devel/shapelib/files/patch-shapefil.h
index 249b77879a5c..884e42b74403 100644
--- a/devel/shapelib/files/patch-shapefil.h
+++ b/devel/shapelib/files/patch-shapefil.h
@@ -1,6 +1,6 @@
---- shapefil.h.orig Mon Apr 7 21:03:22 2003
-+++ shapefil.h Fri Jan 12 01:46:29 2007
-@@ -115,6 +115,8 @@
+--- shapefil.h.orig 2008-11-12 22:28:15.000000000 +0800
++++ shapefil.h 2009-09-05 05:33:07.000000000 +0800
+@@ -123,6 +123,8 @@
*/
#include <stdio.h>
diff --git a/devel/shapelib/files/patch-shputils.c b/devel/shapelib/files/patch-shputils.c
deleted file mode 100644
index 11ebe51b0d65..000000000000
--- a/devel/shapelib/files/patch-shputils.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- shputils.c.orig Mon Apr 7 21:03:22 2003
-+++ shputils.c Tue Dec 12 21:28:33 2006
-@@ -274,7 +274,7 @@
- if (factor == 0)
- {
- if (infactor ==0)
-- { puts("ERROR: Input unit must be defined before output unit"); exit(); }
-+ { puts("ERROR: Input unit must be defined before output unit"); exit( 1 ); }
- factor=infactor/outfactor;
- }
- printf("Output file coordinate values will be factored by %lg\n",factor);
-@@ -319,7 +319,7 @@
- {
- ti = DBFGetFieldCount( hDBF );
- showitems();
-- exit(0);
-+ exit( 0 );
- }
-
- if (iclip) check_theme_bnd();
diff --git a/devel/shapelib/pkg-plist b/devel/shapelib/pkg-plist
index 12857d64d04a..c26f91e82476 100644
--- a/devel/shapelib/pkg-plist
+++ b/devel/shapelib/pkg-plist
@@ -13,10 +13,12 @@ bin/dbfinfo
bin/shpcat
bin/shpdxf
bin/shpfix
+bin/Shape_PointInPoly
%%PROJ4%%bin/shpcentrd
%%PROJ4%%bin/shpdata
%%PROJ4%%bin/shpinfo
%%PROJ4%%bin/shpproj
+%%PROJ4%%bin/shpsort
%%PROJ4%%bin/shpwkb
include/shapefil.h
lib/libshp.a
@@ -24,6 +26,10 @@ lib/libshp.la
lib/libshp.so
lib/libshp.so.1
%%PORTDOCS%%%%DOCSDIR%%/dbf_api.html
-%%PORTDOCS%%%%DOCSDIR%%/shapelib.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/manifest.html
+%%PORTDOCS%%%%DOCSDIR%%/release.html
+%%PORTDOCS%%%%DOCSDIR%%/shapelib-tools.html
%%PORTDOCS%%%%DOCSDIR%%/shp_api.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%