aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-11 02:07:50 +0800
committermiwi <miwi@FreeBSD.org>2009-05-11 02:07:50 +0800
commit44422c6b2e0c8f315bcc9fc34f923b0bb9b89355 (patch)
tree9fdb36968a42468f613922bf343ec125b664c025 /devel
parent740b5dc7e198e0cca6f53cb6966496c6352c12d3 (diff)
downloadfreebsd-ports-gnome-44422c6b2e0c8f315bcc9fc34f923b0bb9b89355.tar.gz
freebsd-ports-gnome-44422c6b2e0c8f315bcc9fc34f923b0bb9b89355.tar.zst
freebsd-ports-gnome-44422c6b2e0c8f315bcc9fc34f923b0bb9b89355.zip
rubygem-igraph is a Ruby extension for using the igraph library.
igraph is a library for creating and manipulating graphs with a particular emphasis on network analysis functions. WWW: http://rubyforge.org/projects/igraph/ PR: ports/134392 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-igraph/Makefile25
-rw-r--r--devel/rubygem-igraph/distinfo3
-rw-r--r--devel/rubygem-igraph/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 68da5aa130c9..14fa1608ce49 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2581,6 +2581,7 @@
SUBDIR += rubygem-highline
SUBDIR += rubygem-hoe
SUBDIR += rubygem-icalendar
+ SUBDIR += rubygem-igraph
SUBDIR += rubygem-inline
SUBDIR += rubygem-json
SUBDIR += rubygem-json_pure
diff --git a/devel/rubygem-igraph/Makefile b/devel/rubygem-igraph/Makefile
new file mode 100644
index 000000000000..b96c5096c3cd
--- /dev/null
+++ b/devel/rubygem-igraph/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: igraph
+# Date created: 09 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= igraph
+PORTVERSION= 0.9.6
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Ruby extension for using the igraph library
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libigraph.so:${PORTSDIR}/math/igraph
+
+CONFIGURE_ARGS+= --with-igraph-include=${LOCALBASE}/include/igraph \
+ --without-igraph-lib=${LOCALBASE}/lib
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-igraph/distinfo b/devel/rubygem-igraph/distinfo
new file mode 100644
index 000000000000..2fac098e5944
--- /dev/null
+++ b/devel/rubygem-igraph/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/igraph-0.9.6.gem) = 8cc075cc3a553dbe3ba5aff1421d8694
+SHA256 (rubygem/igraph-0.9.6.gem) = f6c6fb3c12e25f53eb17a944040b362f95ba5cf302f5dc8dbc245294ce4aa603
+SIZE (rubygem/igraph-0.9.6.gem) = 72704
diff --git a/devel/rubygem-igraph/pkg-descr b/devel/rubygem-igraph/pkg-descr
new file mode 100644
index 000000000000..9dd5784b866f
--- /dev/null
+++ b/devel/rubygem-igraph/pkg-descr
@@ -0,0 +1,5 @@
+rubygem-igraph is a Ruby extension for using the igraph library.
+igraph is a library for creating and manipulating graphs with a
+particular emphasis on network analysis functions.
+
+WWW: http://rubyforge.org/projects/igraph/