aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
committerkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
commit4490d4bc75707dbdea79b297aac91b4ce174c25f (patch)
tree3fa9947d2b38c86d548ab0b4face968420a2825b /devel
parent929b8a6a2120516c63b8fecd8eba713ab5aafae2 (diff)
downloadfreebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.gz
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.zst
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.zip
Convert code in bsd.port.mk for USE_GHOSTSCRIPT* to USES=ghostscript.
Add GHOSTSCRIPT_DEFAULT to bsd.default-versions.mk for easy version selection. Arguments supported: <empty>, build, run, nox11 and agpl PR: 201201 (exp-run) Approved by: portmgr (mat@) Exp run by: antione@ (previous patch) Differential Revision: https://reviews.freebsd.org/D2938
Diffstat (limited to 'devel')
-rw-r--r--devel/doxygen/Makefile2
-rw-r--r--devel/gdcm/Makefile2
-rw-r--r--devel/libexplain/Makefile3
3 files changed, 3 insertions, 4 deletions
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 4e23f13978b6..578126c64fef 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -65,7 +65,7 @@ IGNORE= PDFDOCS option requires HTMLDOCS and LATEX options to be set
.endif
.if ${PORT_OPTIONS:MPDFDOCS}
-USE_GHOSTSCRIPT_BUILD= yes
+USES+= ghostscript:build
.endif
.if ${PORT_OPTIONS:MQT4}
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index 04996af33c77..2a20987198ad 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -66,7 +66,7 @@ PLIST_SUB+= GDCM_MAJOR="${GDCM_MAJOR}" \
.if ${PORT_OPTIONS:MDOCS}
USE_TEX= latex:build
-USE_GHOSTSCRIPT=yes
+USES+= ghostscript
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
CMAKE_ARGS+= -DGDCM_DOCUMENTATION:BOOL=YES \
-DGDCM_INSTALL_MAN_DIR:STRING=man \
diff --git a/devel/libexplain/Makefile b/devel/libexplain/Makefile
index d6dd2f20ec39..862a1b46496d 100644
--- a/devel/libexplain/Makefile
+++ b/devel/libexplain/Makefile
@@ -17,8 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
-USES= bison gettext gmake libtool:build
-USE_GHOSTSCRIPT_BUILD= yes
+USES= bison gettext ghostscript:build gmake libtool:build
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_linux_kd_h=no
USE_LDCONFIG= yes