aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-11-28 01:12:44 +0800
committerkwm <kwm@FreeBSD.org>2013-11-28 01:12:44 +0800
commit46c75a397bdcb56d38658f0057594b8cd1d2dcad (patch)
treeb411fe3788e50307da0608150f6cd9d11549370c /devel
parent982615684d6ff83b4d0515cc927b7f5895b5eec3 (diff)
downloadfreebsd-ports-gnome-46c75a397bdcb56d38658f0057594b8cd1d2dcad.tar.gz
freebsd-ports-gnome-46c75a397bdcb56d38658f0057594b8cd1d2dcad.tar.zst
freebsd-ports-gnome-46c75a397bdcb56d38658f0057594b8cd1d2dcad.zip
Resolve pkgname conflict.
Stageify and switch to libtool-less ltverhack.
Diffstat (limited to 'devel')
-rw-r--r--devel/goffice/Makefile16
-rw-r--r--devel/goffice/pkg-plist10
-rw-r--r--devel/goffice010/Makefile10
-rw-r--r--devel/goffice010/pkg-plist10
4 files changed, 15 insertions, 31 deletions
diff --git a/devel/goffice/Makefile b/devel/goffice/Makefile
index 8273df296654..89f5b554cfc0 100644
--- a/devel/goffice/Makefile
+++ b/devel/goffice/Makefile
@@ -4,9 +4,10 @@
PORTNAME= goffice
PORTVERSION= 0.8.17
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel gnome
MASTER_SITES= GNOME
+PKGNAMESUFFIX= 08
MAINTAINER= gnome@FreeBSD.org
COMMENT= GLib/GTK+ set of document centric objects and utilities
@@ -16,24 +17,21 @@ LICENSE_FILE= ${WRKSRC}/COPYING
PORTSCOUT= ignore
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
USE_XZ= yes
-USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gtk20 libgsf ltverhack
-USES= gettext pathfix pkgconfig
-USE_AUTOTOOLS= libtool
+USES= gettext gmake pathfix pkgconfig
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION=${PORTVERSION} \
SHORT_VER=0.8
-
OPTIONS_DEFINE= GCONF
OPTIONS_DEFAULT=GCONF
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGCONF}
@@ -42,4 +40,8 @@ USE_GNOME+= gconf2
CONFIGURE_ARGS+=--with-config-backend=keyfile
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgoffice-0.8.so.8
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/goffice/*/plugins/*/*.so
+
.include <bsd.port.mk>
diff --git a/devel/goffice/pkg-plist b/devel/goffice/pkg-plist
index 8a46a3e39005..de8120b8a693 100644
--- a/devel/goffice/pkg-plist
+++ b/devel/goffice/pkg-plist
@@ -163,7 +163,6 @@ include/libgoffice-%%SHORT_VER%%/goffice/utils/go-undo.h
include/libgoffice-%%SHORT_VER%%/goffice/utils/go-units.h
include/libgoffice-%%SHORT_VER%%/goffice/utils/goffice-utils.h
include/libgoffice-%%SHORT_VER%%/goffice/utils/regutf8.h
-lib/goffice/%%VERSION%%/plugins/plot_barcol/barcol.a
lib/goffice/%%VERSION%%/plugins/plot_barcol/barcol.la
lib/goffice/%%VERSION%%/plugins/plot_barcol/barcol.so
lib/goffice/%%VERSION%%/plugins/plot_barcol/gog-area-prefs.ui
@@ -171,7 +170,6 @@ lib/goffice/%%VERSION%%/plugins/plot_barcol/gog-barcol-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_barcol/gog-minmax-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_barcol/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_barcol/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_distrib/distrib.a
lib/goffice/%%VERSION%%/plugins/plot_distrib/distrib.la
lib/goffice/%%VERSION%%/plugins/plot_distrib/distrib.so
lib/goffice/%%VERSION%%/plugins/plot_distrib/gog-boxplot-prefs.ui
@@ -182,7 +180,6 @@ lib/goffice/%%VERSION%%/plugins/plot_distrib/plugin.xml
lib/goffice/%%VERSION%%/plugins/plot_pie/gog-pie-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_pie/gog-pie-series.ui
lib/goffice/%%VERSION%%/plugins/plot_pie/gog-ring-prefs.ui
-lib/goffice/%%VERSION%%/plugins/plot_pie/pie.a
lib/goffice/%%VERSION%%/plugins/plot_pie/pie.la
lib/goffice/%%VERSION%%/plugins/plot_pie/pie.so
lib/goffice/%%VERSION%%/plugins/plot_pie/plot-types.xml
@@ -191,14 +188,12 @@ lib/goffice/%%VERSION%%/plugins/plot_radar/gog-color-polar-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_radar/gog-polar-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_radar/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_radar/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_radar/radar.a
lib/goffice/%%VERSION%%/plugins/plot_radar/radar.la
lib/goffice/%%VERSION%%/plugins/plot_radar/radar.so
lib/goffice/%%VERSION%%/plugins/plot_surface/gog-xyz-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_surface/gog-xyz-surface-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_surface/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_surface/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_surface/surface.a
lib/goffice/%%VERSION%%/plugins/plot_surface/surface.la
lib/goffice/%%VERSION%%/plugins/plot_surface/surface.so
lib/goffice/%%VERSION%%/plugins/plot_xy/gog-bubble-prefs.ui
@@ -208,15 +203,12 @@ lib/goffice/%%VERSION%%/plugins/plot_xy/gog-xy-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_xy/gog-xy-series-prefs.ui
lib/goffice/%%VERSION%%/plugins/plot_xy/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_xy/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_xy/xy.a
lib/goffice/%%VERSION%%/plugins/plot_xy/xy.la
lib/goffice/%%VERSION%%/plugins/plot_xy/xy.so
-lib/goffice/%%VERSION%%/plugins/reg_linear/linreg.a
lib/goffice/%%VERSION%%/plugins/reg_linear/linreg.la
lib/goffice/%%VERSION%%/plugins/reg_linear/linreg.so
lib/goffice/%%VERSION%%/plugins/reg_linear/plugin.xml
lib/goffice/%%VERSION%%/plugins/reg_linear/reg-types.xml
-lib/goffice/%%VERSION%%/plugins/reg_logfit/logfit.a
lib/goffice/%%VERSION%%/plugins/reg_logfit/logfit.la
lib/goffice/%%VERSION%%/plugins/reg_logfit/logfit.so
lib/goffice/%%VERSION%%/plugins/reg_logfit/plugin.xml
@@ -224,11 +216,9 @@ lib/goffice/%%VERSION%%/plugins/reg_logfit/reg-types.xml
lib/goffice/%%VERSION%%/plugins/smoothing/gog-exp-smooth.ui
lib/goffice/%%VERSION%%/plugins/smoothing/gog-moving-avg.ui
lib/goffice/%%VERSION%%/plugins/smoothing/plugin.xml
-lib/goffice/%%VERSION%%/plugins/smoothing/smoothing.a
lib/goffice/%%VERSION%%/plugins/smoothing/smoothing.la
lib/goffice/%%VERSION%%/plugins/smoothing/smoothing.so
lib/goffice/%%VERSION%%/plugins/smoothing/types.xml
-lib/libgoffice-%%SHORT_VER%%.a
lib/libgoffice-%%SHORT_VER%%.la
lib/libgoffice-%%SHORT_VER%%.so
lib/libgoffice-%%SHORT_VER%%.so.8
diff --git a/devel/goffice010/Makefile b/devel/goffice010/Makefile
index e4c6a0895f7b..42e518dc8e90 100644
--- a/devel/goffice010/Makefile
+++ b/devel/goffice010/Makefile
@@ -4,8 +4,10 @@
PORTNAME= goffice
PORTVERSION= 0.10.7
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= GNOME
+PKGNAMESUFFIX= 010
MAINTAINER= gnome@FreeBSD.org
COMMENT= GLib/GTK+ set of document centric objects and utilities
@@ -13,11 +15,10 @@ COMMENT= GLib/GTK+ set of document centric objects and utilities
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LATEST_LINK= goffice010
USE_XZ= yes
USE_GNOME= gnomeprefix gtk30 intlhack libgsf librsvg2 ltverhack
USES= gettext gmake pathfix pkgconfig
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,8 +27,9 @@ CONFIGURE_ARGS= --with-lasem=no --with-config-backend=gsettings
PLIST_SUB= VERSION=${PORTVERSION} SHORT_VER=${SHORT_VER}
SHORT_VER= 0.10
-NO_STAGE= yes
post-install:
- @${MKDIR} ${PREFIX}/lib/goffice/${SHORT_VER}/plugins
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/goffice/${SHORT_VER}/plugins
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgoffice-0.10.so.10
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/goffice/*/plugins/*/*.so
.include <bsd.port.mk>
diff --git a/devel/goffice010/pkg-plist b/devel/goffice010/pkg-plist
index 032e719f2c5c..92357396d5fc 100644
--- a/devel/goffice010/pkg-plist
+++ b/devel/goffice010/pkg-plist
@@ -161,52 +161,42 @@ include/libgoffice-%%SHORT_VER%%/goffice/utils/go-undo.h
include/libgoffice-%%SHORT_VER%%/goffice/utils/go-units.h
include/libgoffice-%%SHORT_VER%%/goffice/utils/goffice-utils.h
include/libgoffice-%%SHORT_VER%%/goffice/utils/regutf8.h
-lib/goffice/%%VERSION%%/plugins/plot_barcol/barcol.a
lib/goffice/%%VERSION%%/plugins/plot_barcol/barcol.la
lib/goffice/%%VERSION%%/plugins/plot_barcol/barcol.so
lib/goffice/%%VERSION%%/plugins/plot_barcol/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_barcol/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_distrib/distrib.a
lib/goffice/%%VERSION%%/plugins/plot_distrib/distrib.la
lib/goffice/%%VERSION%%/plugins/plot_distrib/distrib.so
lib/goffice/%%VERSION%%/plugins/plot_distrib/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_distrib/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_pie/pie.a
lib/goffice/%%VERSION%%/plugins/plot_pie/pie.la
lib/goffice/%%VERSION%%/plugins/plot_pie/pie.so
lib/goffice/%%VERSION%%/plugins/plot_pie/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_pie/plugin.xml
lib/goffice/%%VERSION%%/plugins/plot_radar/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_radar/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_radar/radar.a
lib/goffice/%%VERSION%%/plugins/plot_radar/radar.la
lib/goffice/%%VERSION%%/plugins/plot_radar/radar.so
lib/goffice/%%VERSION%%/plugins/plot_surface/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_surface/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_surface/surface.a
lib/goffice/%%VERSION%%/plugins/plot_surface/surface.la
lib/goffice/%%VERSION%%/plugins/plot_surface/surface.so
lib/goffice/%%VERSION%%/plugins/plot_xy/plot-types.xml
lib/goffice/%%VERSION%%/plugins/plot_xy/plugin.xml
-lib/goffice/%%VERSION%%/plugins/plot_xy/xy.a
lib/goffice/%%VERSION%%/plugins/plot_xy/xy.la
lib/goffice/%%VERSION%%/plugins/plot_xy/xy.so
-lib/goffice/%%VERSION%%/plugins/reg_linear/linreg.a
lib/goffice/%%VERSION%%/plugins/reg_linear/linreg.la
lib/goffice/%%VERSION%%/plugins/reg_linear/linreg.so
lib/goffice/%%VERSION%%/plugins/reg_linear/plugin.xml
lib/goffice/%%VERSION%%/plugins/reg_linear/reg-types.xml
-lib/goffice/%%VERSION%%/plugins/reg_logfit/logfit.a
lib/goffice/%%VERSION%%/plugins/reg_logfit/logfit.la
lib/goffice/%%VERSION%%/plugins/reg_logfit/logfit.so
lib/goffice/%%VERSION%%/plugins/reg_logfit/plugin.xml
lib/goffice/%%VERSION%%/plugins/reg_logfit/reg-types.xml
lib/goffice/%%VERSION%%/plugins/smoothing/plugin.xml
-lib/goffice/%%VERSION%%/plugins/smoothing/smoothing.a
lib/goffice/%%VERSION%%/plugins/smoothing/smoothing.la
lib/goffice/%%VERSION%%/plugins/smoothing/smoothing.so
lib/goffice/%%VERSION%%/plugins/smoothing/types.xml
-lib/libgoffice-%%SHORT_VER%%.a
lib/libgoffice-%%SHORT_VER%%.la
lib/libgoffice-%%SHORT_VER%%.so
lib/libgoffice-%%SHORT_VER%%.so.10