aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-12 17:05:07 +0800
committervs <vs@FreeBSD.org>2005-10-12 17:05:07 +0800
commit4c4644d9b65e63e9b8eb7b1361b4c8edc50c9394 (patch)
treed50852f0c7d5857da2260e6fa780d39b605d1730 /devel
parentff6c39a5010eae256b2c87846e75315ebca29cdf (diff)
downloadfreebsd-ports-gnome-4c4644d9b65e63e9b8eb7b1361b4c8edc50c9394.tar.gz
freebsd-ports-gnome-4c4644d9b65e63e9b8eb7b1361b4c8edc50c9394.tar.zst
freebsd-ports-gnome-4c4644d9b65e63e9b8eb7b1361b4c8edc50c9394.zip
USE_INC_LIBTOOL instead of local patch
Diffstat (limited to 'devel')
-rw-r--r--devel/ixlib/Makefile5
-rw-r--r--devel/ixlib/files/patch-ltmain.sh41
2 files changed, 5 insertions, 41 deletions
diff --git a/devel/ixlib/Makefile b/devel/ixlib/Makefile
index ab50adba725b..a7e881c5179c 100644
--- a/devel/ixlib/Makefile
+++ b/devel/ixlib/Makefile
@@ -18,9 +18,11 @@ COMMENT= A small C++ tools library based on STL
USE_GETTEXT= yes
USE_GMAKE= yes
+USE_INC_LIBTOOL_VER=15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+MAKE_ENV+= SED="sed"
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -29,4 +31,7 @@ INSTALLS_SHLIB= yes
BROKEN= "Does not compile on !i386 or on FreeBSD >= 5.x"
.endif
+pre-configure:
+ ${CP} ${LTMAIN} ${WRKSRC}
+
.include <bsd.port.post.mk>
diff --git a/devel/ixlib/files/patch-ltmain.sh b/devel/ixlib/files/patch-ltmain.sh
deleted file mode 100644
index 78fde5161990..000000000000
--- a/devel/ixlib/files/patch-ltmain.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- ltmain.sh.orig Sun Sep 23 09:10:52 2001
-+++ ltmain.sh Sat Dec 8 17:01:25 2001
-@@ -1043,14 +1043,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2441,7 +2441,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4210,10 +4210,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"