aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2014-09-06 05:15:25 +0800
committercs <cs@FreeBSD.org>2014-09-06 05:15:25 +0800
commit4df724b7b4ec5424a3ce51f02fb9c4177b99934b (patch)
tree2849865bed67a2f8bee165dca845c96b4b6135ed /devel
parent9bbd47afd8af416db0911da16448306e82d15b25 (diff)
downloadfreebsd-ports-gnome-4df724b7b4ec5424a3ce51f02fb9c4177b99934b.tar.gz
freebsd-ports-gnome-4df724b7b4ec5424a3ce51f02fb9c4177b99934b.tar.zst
freebsd-ports-gnome-4df724b7b4ec5424a3ce51f02fb9c4177b99934b.zip
logutils is a Go package that augments the standard library "log"
package to make logging a bit more modern, without fragmenting the Go ecosystem with new logging packages. PR: ports/192964 Submitted by: Thomas Bartelmess <thomas@bartelmess.io>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/go-hashicorp-logutils/Makefile23
-rw-r--r--devel/go-hashicorp-logutils/distinfo2
-rw-r--r--devel/go-hashicorp-logutils/pkg-descr3
-rw-r--r--devel/go-hashicorp-logutils/pkg-plist15
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 794389210864..59e7feba62c7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -583,6 +583,7 @@
SUBDIR += gnustep
SUBDIR += gnustep-make
SUBDIR += go-flags
+ SUBDIR += go-hashicorp-logutils
SUBDIR += go-json-rest
SUBDIR += go-pretty
SUBDIR += go-runewidth
diff --git a/devel/go-hashicorp-logutils/Makefile b/devel/go-hashicorp-logutils/Makefile
new file mode 100644
index 000000000000..66d607488ba8
--- /dev/null
+++ b/devel/go-hashicorp-logutils/Makefile
@@ -0,0 +1,23 @@
+# Created by: Thomas Bartelmess <thomas@bartelmess.io>
+# $FreeBSD$
+
+PORTNAME= go-hachicorp-logutils
+PORTVERSION= 0.1
+CATEGORIES= devel
+
+MAINTAINER= thomas@bartelmess.io
+COMMENT= Utilities for slightly better logging in Go (Golang)
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= hashicorp
+GH_PROJECT= logutils
+GH_COMMIT= 8e0820f
+GH_TAGNAME= 8e0820fe7ac5eb2b01626b1d99df47c5449eb2d8
+
+GO_PKGNAME= github.com/hashicorp/logutils
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-hashicorp-logutils/distinfo b/devel/go-hashicorp-logutils/distinfo
new file mode 100644
index 000000000000..616bdaaec07c
--- /dev/null
+++ b/devel/go-hashicorp-logutils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (go-hachicorp-logutils-0.1.tar.gz) = caffe2bd138d62b35ba5fda122be003e983b7d4c6fe3e0db73a64ef69578031c
+SIZE (go-hachicorp-logutils-0.1.tar.gz) = 7379
diff --git a/devel/go-hashicorp-logutils/pkg-descr b/devel/go-hashicorp-logutils/pkg-descr
new file mode 100644
index 000000000000..daa0f7963517
--- /dev/null
+++ b/devel/go-hashicorp-logutils/pkg-descr
@@ -0,0 +1,3 @@
+logutils is a Go package that augments the standard library "log"
+package to make logging a bit more modern, without fragmenting
+the Go ecosystem with new logging packages.
diff --git a/devel/go-hashicorp-logutils/pkg-plist b/devel/go-hashicorp-logutils/pkg-plist
new file mode 100644
index 000000000000..4e00a3b253ea
--- /dev/null
+++ b/devel/go-hashicorp-logutils/pkg-plist
@@ -0,0 +1,15 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/level.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/level_benchmark_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/level_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/github.com/hashicorp
+@dirrmtry %%GO_SRCDIR%%/github.com
+@dirrmtry %%GO_SRCDIR%%
+@dirrmtry %%GO_LIBDIR%%/github.com/hashicorp
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrmtry %%GO_LIBDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go