aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-01-20 17:33:17 +0800
committergarga <garga@FreeBSD.org>2006-01-20 17:33:17 +0800
commit51318569ef761fd827b5ecea2abb4036480ec5ec (patch)
tree7d4a2070f4d71563613d6eeb614eb10c360fcbca /devel
parent1bc9bfe526566531357ca09c95ed77db917b7b87 (diff)
downloadfreebsd-ports-gnome-51318569ef761fd827b5ecea2abb4036480ec5ec.tar.gz
freebsd-ports-gnome-51318569ef761fd827b5ecea2abb4036480ec5ec.tar.zst
freebsd-ports-gnome-51318569ef761fd827b5ecea2abb4036480ec5ec.zip
Add p5-SSN-Validate 0.14, perl extension to do SSN Validation.
PR: ports/91920 Submitted by: tiger <tiger@whitetigersd.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SSN-Validate/Makefile32
-rw-r--r--devel/p5-SSN-Validate/distinfo3
-rw-r--r--devel/p5-SSN-Validate/pkg-descr8
-rw-r--r--devel/p5-SSN-Validate/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f2c09d01991a..cd06c6df798d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1116,6 +1116,7 @@
SUBDIR += p5-Return-Value
SUBDIR += p5-SDL
SUBDIR += p5-SPOPS
+ SUBDIR += p5-SSN-Validate
SUBDIR += p5-SVN-ACL
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
diff --git a/devel/p5-SSN-Validate/Makefile b/devel/p5-SSN-Validate/Makefile
new file mode 100644
index 000000000000..ac03ff6c30e8
--- /dev/null
+++ b/devel/p5-SSN-Validate/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-SSN-Validate
+# Date created: 17 Jan 2006
+# Whom: tiger <tiger@whitetigersd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SSN-Validate
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/K/KM/KMELTZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tiger@whitetigersd.com
+COMMENT= Perl extension to do SSN Validation
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+MAN3= SSN::Validate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or higher
+.endif
+
+test: all
+ cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-SSN-Validate/distinfo b/devel/p5-SSN-Validate/distinfo
new file mode 100644
index 000000000000..6351165914fc
--- /dev/null
+++ b/devel/p5-SSN-Validate/distinfo
@@ -0,0 +1,3 @@
+MD5 (SSN-Validate-0.14.tar.gz) = b79e9d7929478e43a7430cf874b0a4ae
+SHA256 (SSN-Validate-0.14.tar.gz) = 2eda951bedfb7fedcce710e99cd0d539f3f8184005cff8cfc41a75e3bed551a4
+SIZE (SSN-Validate-0.14.tar.gz) = 12326
diff --git a/devel/p5-SSN-Validate/pkg-descr b/devel/p5-SSN-Validate/pkg-descr
new file mode 100644
index 000000000000..9b41e7ebc942
--- /dev/null
+++ b/devel/p5-SSN-Validate/pkg-descr
@@ -0,0 +1,8 @@
+This module is intented to do some Social Security Number validation
+(not verification) beyond just seeing if it contains 9 digits and isn't
+all 0s. The data is taken from the Social Security Admin. website,
+specifically:
+
+http://www.ssa.gov/foia/stateweb.html
+
+WWW: http://search.cpan.org/dist/SSN-Validate
diff --git a/devel/p5-SSN-Validate/pkg-plist b/devel/p5-SSN-Validate/pkg-plist
new file mode 100644
index 000000000000..6a0405482b6a
--- /dev/null
+++ b/devel/p5-SSN-Validate/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SSN/Validate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SSN/Validate/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SSN/Validate 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SSN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/SSN 2>/dev/null || true