aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /devel
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'devel')
-rw-r--r--devel/amulet/Makefile18
-rw-r--r--devel/ilu/Makefile34
2 files changed, 28 insertions, 24 deletions
diff --git a/devel/amulet/Makefile b/devel/amulet/Makefile
index ed5183bda5af..e785723ada5e 100644
--- a/devel/amulet/Makefile
+++ b/devel/amulet/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 July 1997
# Whom: Filip Bovyn (bovynf@awe.be)
#
-# $Id: Makefile,v 1.5 1998/10/12 15:36:27 jseger Exp $
+# $Id: Makefile,v 1.6 1998/10/20 01:32:14 steve Exp $
DISTNAME= amulet
PKGNAME= amulet-3.0
@@ -17,6 +17,14 @@ USE_X_PREFIX= yes
WRKSRC= $(WRKDIR)/amulet
MAKE_ENV= AMULET_DIR=$(WRKSRC) AMULET_VARS_FILE=Makefile.vars.gcc.FreeBSD
+.include <bsd.port.pre.mk>
+
+.if $(PORTOBJFORMAT) == "elf"
+SO_VERSION= 3
+.else
+SO_VERSION= 3.0
+.endif
+
pre-build:
${CP} $(FILESDIR)/Makefile.vars.gcc.FreeBSD $(WRKSRC)/bin
@@ -93,10 +101,4 @@ do-install:
$(INSTALL_PROGRAM) $(WRKSRC)/bin/$$a $(PREFIX)/share/amulet/samples; \
done)
-.include <bsd.port.mk>
-
-.if $(PORTOBJFORMAT) == "elf"
-SO_VERSION= 3
-.else
-SO_VERSION= 3.0
-.endif
+.include <bsd.port.post.mk>
diff --git a/devel/ilu/Makefile b/devel/ilu/Makefile
index 30e062d3dc46..59b55fbd0230 100644
--- a/devel/ilu/Makefile
+++ b/devel/ilu/Makefile
@@ -3,7 +3,7 @@
# Date created: 29.9.1997
# Whom: cracauer@cons.org "Martin Cracauer"
#
-# $Id: Makefile,v 1.12 1998/10/08 16:37:18 cracauer Exp $
+# $Id: Makefile,v 1.13 1998/10/08 18:48:56 cracauer Exp $
#
DISTNAME= ilu-2.0alpha12
@@ -25,6 +25,22 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/ilu
INSTALL_TARGET= Install
PLIST= ${WRKSRC}/PLIST
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+SHLIBPATCH=files/shlib-elf.patch
+# The FreeBSD Java Development Kit is still in aout object format.
+# You might want to enable it if you have an ELF JDK and/or build
+# a seperate aout ILU runtime to use with Java.
+CONFIGURE_ARGS+= --disable-java-support
+.else
+SHLIBPATCH=files/shlib-aout.patch
+# Java support on -stable does not work (ILU runtime dumps core).
+# You might want to enable it if you know what you are doing.
+# Maybe taking -O out of patches/patch-1-cra-cflags help.
+CONFIGURE_ARGS+= --disable-java-support
+.endif
+
# Startup script, run at boot time
startup_dir= ${PREFIX}/etc/rc.d
startup_script= ${startup_dir}/50.ilu.sh
@@ -63,18 +79,4 @@ do-install:
chmod 755 ${startup_script};
${startup_script}
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-SHLIBPATCH=files/shlib-elf.patch
-# The FreeBSD Java Development Kit is still in aout object format.
-# You might want to enable it if you have an ELF JDK and/or build
-# a seperate aout ILU runtime to use with Java.
-CONFIGURE_ARGS+= --disable-java-support
-.else
-SHLIBPATCH=files/shlib-aout.patch
-# Java support on -stable does not work (ILU runtime dumps core).
-# You might want to enable it if you know what you are doing.
-# Maybe taking -O out of patches/patch-1-cra-cflags help.
-CONFIGURE_ARGS+= --disable-java-support
-.endif
+.include <bsd.port.post.mk>