aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-09-18 03:54:38 +0800
committerswills <swills@FreeBSD.org>2014-09-18 03:54:38 +0800
commit53320bade0c026467fb913d873a9c13489ba755c (patch)
treebff1fe05fa3556b4dacfc716172ab47df086a470 /devel
parentcb224ba517003d10e009238f2f2562c2790f722c (diff)
downloadfreebsd-ports-gnome-53320bade0c026467fb913d873a9c13489ba755c.tar.gz
freebsd-ports-gnome-53320bade0c026467fb913d873a9c13489ba755c.tar.zst
freebsd-ports-gnome-53320bade0c026467fb913d873a9c13489ba755c.zip
devel/py-pyparsing15: create port of older pyparsing module for py-mwlib
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyparsing15/Makefile19
-rw-r--r--devel/py-pyparsing15/distinfo2
-rw-r--r--devel/py-pyparsing15/pkg-descr6
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e024021bbf37..b99a0991ebc4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3838,6 +3838,7 @@
SUBDIR += py-pylib
SUBDIR += py-pymarc
SUBDIR += py-pympler
+ SUBDIR += py-pyparsing15
SUBDIR += py-pyro
SUBDIR += py-pyshapelib
SUBDIR += py-pytemplate
diff --git a/devel/py-pyparsing15/Makefile b/devel/py-pyparsing15/Makefile
new file mode 100644
index 000000000000..3bc6db2d3479
--- /dev/null
+++ b/devel/py-pyparsing15/Makefile
@@ -0,0 +1,19 @@
+# Created by: Hye-Shik Chang
+# $FreeBSD$
+
+PORTNAME= pyparsing
+PORTVERSION= 1.5.7
+CATEGORIES= devel python
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 15
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= General parsing module for Python
+
+LICENSE= MIT
+
+USES= python:2
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyparsing15/distinfo b/devel/py-pyparsing15/distinfo
new file mode 100644
index 000000000000..ed92b82fe89d
--- /dev/null
+++ b/devel/py-pyparsing15/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyparsing-1.5.7.tar.gz) = 2b3a013582cbff858e71ff23129e01acc5e99f511578d106ffb1e74bde15e893
+SIZE (pyparsing-1.5.7.tar.gz) = 939642
diff --git a/devel/py-pyparsing15/pkg-descr b/devel/py-pyparsing15/pkg-descr
new file mode 100644
index 000000000000..6b3465892bb4
--- /dev/null
+++ b/devel/py-pyparsing15/pkg-descr
@@ -0,0 +1,6 @@
+Pyparsing is a general parsing module for Python. Grammars are
+implemented directly in the client code using parsing objects,
+instead of externally, as with lex/yacc-type tools. Includes simple
+examples for parsing SQL, CORBA IDL, and 4-function math.
+
+WWW: http://pyparsing.wikispaces.com/