aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-04-22 01:51:14 +0800
committerglarkin <glarkin@FreeBSD.org>2009-04-22 01:51:14 +0800
commit5754a75ba55388c35dbbe0183ff25329da850bf4 (patch)
tree4345b5848b91e33ad5ecbc291066164490e9ea42 /devel
parent9271b1cab15dd767d768f7dc46c7276a88d527e2 (diff)
downloadfreebsd-ports-gnome-5754a75ba55388c35dbbe0183ff25329da850bf4.tar.gz
freebsd-ports-gnome-5754a75ba55388c35dbbe0183ff25329da850bf4.tar.zst
freebsd-ports-gnome-5754a75ba55388c35dbbe0183ff25329da850bf4.zip
SVN::Dumpfile represents a Subversion dumpfile. It provides methods
to read existing and write modified or new dumpfiles. It supports dumpfiles with the version number 1 - 3 but was written in a tolerant way to also support newer versions as long no major changes are made. This module is a OO redesign and generalisation of SVN::Dumpfilter v0.21. Newer versions of SVN::Dumpfilter are using it to access the input and output dumpfiles. The ability to create new dumpfiles sets it apart from the similar module SVN::Dump. The submodule SVN::Dumpfile::Node::Properties also allows the processing of Subversion revision property files (i.e. the files lying in the $REPOSITORY/db/revprops/ directory holding the author, date and log entry of every revision). WWW: http://search.cpan.org/dist/SVN-Dumpfile/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-Dumpfile/Makefile35
-rw-r--r--devel/p5-SVN-Dumpfile/distinfo3
-rw-r--r--devel/p5-SVN-Dumpfile/pkg-descr17
-rw-r--r--devel/p5-SVN-Dumpfile/pkg-plist12
5 files changed, 68 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3d0dbed2a348..b142da87463a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1727,6 +1727,7 @@
SUBDIR += p5-SVN-Access
SUBDIR += p5-SVN-Agent
SUBDIR += p5-SVN-Dump
+ SUBDIR += p5-SVN-Dumpfile
SUBDIR += p5-SVN-Hook
SUBDIR += p5-SVN-Hooks
SUBDIR += p5-SVN-Log
diff --git a/devel/p5-SVN-Dumpfile/Makefile b/devel/p5-SVN-Dumpfile/Makefile
new file mode 100644
index 000000000000..21f2ad72550c
--- /dev/null
+++ b/devel/p5-SVN-Dumpfile/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: SVN::Dumpfile
+# Date created: 2009-04-17
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Dumpfile
+PORTVERSION= 0.13.106
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Perl extension to access and manipulate Subversion dumpfiles
+
+BUILD_DEPENDS= p5-Data-GUID>=0:${PORTSDIR}/devel/p5-Data-GUID \
+ p5-Data-Dumper>=2.121:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-TimeDate>=2.27:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-IO>=1.2301:${PORTSDIR}/devel/p5-IO \
+ p5-File-Temp>=0.20:${PORTSDIR}/devel/p5-File-Temp \
+ p5-Readonly>=1.03:${PORTSDIR}/devel/p5-Readonly
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Dumpfile.3 \
+ SVN::Dumpfile::Node.3 \
+ SVN::Dumpfile::Node::Content.3 \
+ SVN::Dumpfile::Node::Headers.3 \
+ SVN::Dumpfile::Node::Properties.3 \
+ SVN::Dumpfile::Tutorial.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Dumpfile/distinfo b/devel/p5-SVN-Dumpfile/distinfo
new file mode 100644
index 000000000000..8fef607b6df5
--- /dev/null
+++ b/devel/p5-SVN-Dumpfile/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Dumpfile-0.13.106.tar.gz) = 22638041674670a48e220d1bd0624509
+SHA256 (SVN-Dumpfile-0.13.106.tar.gz) = d054b85b28bfcbe6c8c242250adc8138327de81e9f6f8b7579d5283401a9e0f4
+SIZE (SVN-Dumpfile-0.13.106.tar.gz) = 28672
diff --git a/devel/p5-SVN-Dumpfile/pkg-descr b/devel/p5-SVN-Dumpfile/pkg-descr
new file mode 100644
index 000000000000..8a77b4e67b56
--- /dev/null
+++ b/devel/p5-SVN-Dumpfile/pkg-descr
@@ -0,0 +1,17 @@
+SVN::Dumpfile represents a Subversion dumpfile. It provides methods
+to read existing and write modified or new dumpfiles. It supports
+dumpfiles with the version number 1 - 3 but was written in a tolerant
+way to also support newer versions as long no major changes are
+made.
+
+This module is a OO redesign and generalisation of SVN::Dumpfilter
+v0.21. Newer versions of SVN::Dumpfilter are using it to access the
+input and output dumpfiles.
+
+The ability to create new dumpfiles sets it apart from the similar
+module SVN::Dump. The submodule SVN::Dumpfile::Node::Properties
+also allows the processing of Subversion revision property files
+(i.e. the files lying in the $REPOSITORY/db/revprops/ directory
+holding the author, date and log entry of every revision).
+
+WWW: http://search.cpan.org/dist/SVN-Dumpfile/
diff --git a/devel/p5-SVN-Dumpfile/pkg-plist b/devel/p5-SVN-Dumpfile/pkg-plist
new file mode 100644
index 000000000000..689bc5ac8b43
--- /dev/null
+++ b/devel/p5-SVN-Dumpfile/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/SVN/Dumpfile/Node/Properties.pm
+%%SITE_PERL%%/SVN/Dumpfile/Node/Headers.pm
+%%SITE_PERL%%/SVN/Dumpfile/Node/Content.pm
+@dirrm %%SITE_PERL%%/SVN/Dumpfile/Node
+%%SITE_PERL%%/SVN/Dumpfile/Tutorial.pm
+%%SITE_PERL%%/SVN/Dumpfile/Node.pm
+@dirrm %%SITE_PERL%%/SVN/Dumpfile
+%%SITE_PERL%%/SVN/Dumpfile.pm
+@dirrmtry %%SITE_PERL%%/SVN
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Dumpfile/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Dumpfile
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN