aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-09-25 20:28:41 +0800
committersobomax <sobomax@FreeBSD.org>2000-09-25 20:28:41 +0800
commit587ebcc393a8aa9592d8756d65638dee12f528f7 (patch)
tree55ca420ea2962afc2a27ec4bdd8460a9f15e86fc /devel
parentfef0b77e118c4e03b2418bb7481200cb569bf39c (diff)
downloadfreebsd-ports-gnome-587ebcc393a8aa9592d8756d65638dee12f528f7.tar.gz
freebsd-ports-gnome-587ebcc393a8aa9592d8756d65638dee12f528f7.tar.zst
freebsd-ports-gnome-587ebcc393a8aa9592d8756d65638dee12f528f7.zip
Add titano - an C/C++ IDE for GNOME desktop.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/titano/Makefile45
-rw-r--r--devel/titano/distinfo1
-rw-r--r--devel/titano/files/patch-aa32
-rw-r--r--devel/titano/files/patch-ab14
-rw-r--r--devel/titano/pkg-comment1
-rw-r--r--devel/titano/pkg-descr13
-rw-r--r--devel/titano/pkg-plist6
8 files changed, 113 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9949b6c814a1..dc5821396956 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -323,6 +323,7 @@
SUBDIR += tclreadline
SUBDIR += tcltls
SUBDIR += templ
+ SUBDIR += titano
SUBDIR += tkcon
SUBDIR += tkcvs
SUBDIR += tkref
diff --git a/devel/titano/Makefile b/devel/titano/Makefile
new file mode 100644
index 000000000000..dc246f15942a
--- /dev/null
+++ b/devel/titano/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: titano
+# Date created: 25 September 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= titano
+PORTVERSION= 0.0.5b
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/b//}
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/gnome/pixmaps/titano
+ ${INSTALL_DATA} ${WRKSRC}/src/xpm/* ${PREFIX}/share/gnome/pixmaps/titano
+
+.include <bsd.port.mk>
diff --git a/devel/titano/distinfo b/devel/titano/distinfo
new file mode 100644
index 000000000000..0e3fdd4c7dfc
--- /dev/null
+++ b/devel/titano/distinfo
@@ -0,0 +1 @@
+MD5 (titano-0.0.5b.tar.gz) = a83aff0532244de14e2c2f223e8b9482
diff --git a/devel/titano/files/patch-aa b/devel/titano/files/patch-aa
new file mode 100644
index 000000000000..bb6ba07bb23e
--- /dev/null
+++ b/devel/titano/files/patch-aa
@@ -0,0 +1,32 @@
+--- src/Makefile.in 2000/09/25 11:33:52 1.1
++++ src/Makefile.in 2000/09/25 11:39:21
+@@ -124,9 +124,9 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-SUBDIRS = gtkeditor tools scanners
++SUBDIRS = #gtkeditor tools scanners
+
+-INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) -I$(top_srcdir)/src/gtkeditor
++INCLUDES = $(GNOME_INCLUDEDIR) -I$(X11BASE)/include
+
+
+ EXTRA_DIST = run-tit xpm/save_all.xpm xpm/compile.xpm xpm/debug.xpm xpm/exec.xpm
+@@ -137,7 +137,7 @@
+ titano_SOURCES = main.cc support.c support.h interface.c interface.h callbacks.cc callbacks.h common.cc common.h highlight.h files.cc files.h projects.cc projects.h dialogs.cc dialogs.h util.cc util.h cproject.cc prefs.cc prefs.h
+
+
+-titano_LDADD = gtkeditor/libgtkeditor.la $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(INTLLIBS)
++titano_LDADD = -lgtkeditor $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(INTLLIBS)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
+@@ -148,7 +148,7 @@
+ LIBS = @LIBS@
+ titano_OBJECTS = main.o support.o interface.o callbacks.o common.o \
+ files.o projects.o dialogs.o util.o cproject.o prefs.o
+-titano_DEPENDENCIES = gtkeditor/libgtkeditor.la
++titano_DEPENDENCIES = # gtkeditor/libgtkeditor.la
+ titano_LDFLAGS =
+ CXXFLAGS = @CXXFLAGS@
+ CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
diff --git a/devel/titano/files/patch-ab b/devel/titano/files/patch-ab
new file mode 100644
index 000000000000..cdc21a408f3e
--- /dev/null
+++ b/devel/titano/files/patch-ab
@@ -0,0 +1,14 @@
+--- src/prefs.cc 2000/09/25 12:01:34 1.1
++++ src/prefs.cc 2000/09/25 12:03:32
+@@ -8,6 +8,11 @@
+
+ Preferences::Preferences(void)
+ {
++ defaultdir=NULL;
++ lastname=NULL;
++ lastdir=NULL;
++ name=NULL;
++ mail=NULL;
+ file = g_strconcat(home,"/.titano/titano",NULL);
+
+ if(Preferences::check())
diff --git a/devel/titano/pkg-comment b/devel/titano/pkg-comment
new file mode 100644
index 000000000000..1d5c212baaeb
--- /dev/null
+++ b/devel/titano/pkg-comment
@@ -0,0 +1 @@
+An IDE for GNOME desktop
diff --git a/devel/titano/pkg-descr b/devel/titano/pkg-descr
new file mode 100644
index 000000000000..3beb5e543f15
--- /dev/null
+++ b/devel/titano/pkg-descr
@@ -0,0 +1,13 @@
+Titano is an IDE built with Glade using GTK+. It uses GtkEditor as a main
+editing widget though you will be able to use your favorite editor as an
+editing component in Titano via Bonobo technology.
+
+Features (some of features are only planned and may appear not very soon):
+ o Project managment with automake/autoconf support.
+ o Support for different languages.
+ o Bonobo editor components.
+ o Integrated debugger.
+ o Code exploring tools.
+ o And many other things you may need for developing.
+
+WWW: http://titano.sourceforge.net/
diff --git a/devel/titano/pkg-plist b/devel/titano/pkg-plist
new file mode 100644
index 000000000000..b8d660199066
--- /dev/null
+++ b/devel/titano/pkg-plist
@@ -0,0 +1,6 @@
+bin/titano
+share/gnome/pixmaps/titano/compile.xpm
+share/gnome/pixmaps/titano/debug.xpm
+share/gnome/pixmaps/titano/exec.xpm
+share/gnome/pixmaps/titano/save_all.xpm
+@dirrm share/gnome/pixmaps/titano
ass='deletions'>-3/+70 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.2miwi2009-04-022-6/+28 * Update KDE to 4.2.1.makc2009-03-092-3/+6 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.0miwi2009-02-092-24/+11 * - Update to 1.2.8gabor2009-02-086-16/+58 * - Update to 1.4gabor2009-02-082-4/+4 * kde@freebsd team is pleased to announce KDE 4.1.4, the last bugfix release in...makc2009-01-143-6/+9 * Turns out, libdata/pkgconfig/ is already part of mtree and needs neithermi2008-09-092-3/+1 * Fix the incorrect location hunspell.pc. No PORTREVISION bump, becausemi2008-09-091-1/+1 * Correct the destination of hunspell.pc file -- according to pav,mi2008-09-082-3/+3 * Add two directories missing from plist...mi2008-09-041-0/+2 * Upgrade from 1.2.2b to 1.2.7.mi2008-09-046-47/+73 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.1miwi2008-09-032-5/+21 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-291-3/+3 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-182-10/+64 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-105-484/+244 * PHP Documentation in these language has been removed from the distribution.edwin2008-08-042-14/+0 * - Update MASTER_SITESgabor2008-07-122-2/+2 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-063-2/+3 * - Update to 1.3gabor2008-04-245-75/+41 * - Fix checking on LaTeX files on amd64gabor2008-04-242-0/+12 * - Update to 1.2.2bgabor2008-04-074-51/+25 * Update to KDE 3.5.8lofi2007-10-304-8/+6 * - Fix UTF-8 buggabor2007-10-073-0/+21 * - Update to 1.2.1gabor2007-09-284-99/+89 * - Update to 1.1.10gabor2007-08-283-5/+31 * - Update to 1.1.9gabor2007-08-014-8/+18 * - Update to 1.1.8gabor2007-07-214-19/+38 * Update to KDE 3.5.7 / KOffice 1.6.3lofi2007-07-048-29/+12 * BROKEN: Still broken on 6.x and abovekris2007-05-251-0/+2 * - Welcome X.org 7.2 \o/.flz2007-05-205-2/+5 * Remove BROKEN: This might be fixedkris2007-04-291-2/+0 * BROKEN: Does not installkris2007-03-251-0/+2 * Update to KDE 3.5.6 / KOffice 1.6.2lofi2007-03-147-11/+12 * Really normalize Aspell dictionaries ports PKGVERSION...thierry2007-02-151-1/+1 * Normalize Aspell dictionaries PKGNAMEs.thierry2007-01-141-0/+1 * Update to KDE 3.5.5 / KOffice 1.6.1lofi2006-12-205-10/+11 * - Update to 1.1.4miwi2006-11-105-71/+27 * KDE 3.5.4 / KOffice 1.5.2lofi2006-09-134-10/+10 * Now installs again.kris2006-08-171-2/+0 * Mark BROKEN: does not installerwin2006-08-041-0/+2 * Update to 1.0itetcu2006-08-013-43/+107 * All dictionaries can be installed separately:thierry2006-07-154-7/+15 * Update to KDE 3.5.3lofi2006-06-064-22/+20