aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2006-04-16 00:29:25 +0800
committerscrappy <scrappy@FreeBSD.org>2006-04-16 00:29:25 +0800
commit5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20 (patch)
tree5d7dc1df3f58d54ca285e535404de2237aab908c /devel
parent0bf7f3b33d0856b0230169fbe63d6bdb650ffbf6 (diff)
downloadfreebsd-ports-gnome-5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20.tar.gz
freebsd-ports-gnome-5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20.tar.zst
freebsd-ports-gnome-5d52b9a45cbf1cc5c7d07335fafb66929c6e6d20.zip
After a recent discussion on freebsd-ports, I have modified the Horde
ports, so that they now do not overwrite existing configuration files. Rather than backing up the old ones and allowing the user to merge the files by hand, config files are left untouched. PR: Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/chora/Makefile9
-rw-r--r--devel/chora/pkg-plist5
-rw-r--r--devel/horde-chora/Makefile9
-rw-r--r--devel/horde-chora/pkg-plist5
4 files changed, 6 insertions, 22 deletions
diff --git a/devel/chora/Makefile b/devel/chora/Makefile
index 2a7614e16284..7c04659a83ab 100644
--- a/devel/chora/Makefile
+++ b/devel/chora/Makefile
@@ -70,7 +70,7 @@ LCHORADIR= ${LHORDEDIR}/chora
PLIST_SUB= CHORADIR=${LCHORADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= CHORADIR=${CHORADIR} CONFDIR=${CONFDIR}
CHORADIR= ${PREFIX}/${LCHORADIR}
@@ -114,11 +114,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${CHORADIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${CHORADIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-chora.conf ${HORDE_INC}
@@ -131,6 +127,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/devel/chora/pkg-plist b/devel/chora/pkg-plist
index b5f16266a49e..b20759e18ae8 100644
--- a/devel/chora/pkg-plist
+++ b/devel/chora/pkg-plist
@@ -12,15 +12,10 @@
%%CHORADIR%%/co.php
%%CHORADIR%%/config/.htaccess
%%CHORADIR%%/config/conf.xml
-%%CHORADIR%%/config/cvsgraph.conf
%%CHORADIR%%/config/cvsgraph.conf.dist
-%%CHORADIR%%/config/longIntro.txt
%%CHORADIR%%/config/longIntro.txt.dist
-%%CHORADIR%%/config/mime_drivers.php
%%CHORADIR%%/config/mime_drivers.php.dist
-%%CHORADIR%%/config/prefs.php
%%CHORADIR%%/config/prefs.php.dist
-%%CHORADIR%%/config/sourceroots.php
%%CHORADIR%%/config/sourceroots.php.dist
%%CHORADIR%%/cvs.php
%%CHORADIR%%/cvsgraph.php
diff --git a/devel/horde-chora/Makefile b/devel/horde-chora/Makefile
index 2a7614e16284..7c04659a83ab 100644
--- a/devel/horde-chora/Makefile
+++ b/devel/horde-chora/Makefile
@@ -70,7 +70,7 @@ LCHORADIR= ${LHORDEDIR}/chora
PLIST_SUB= CHORADIR=${LCHORADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= CHORADIR=${CHORADIR} CONFDIR=${CONFDIR}
CHORADIR= ${PREFIX}/${LCHORADIR}
@@ -114,11 +114,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${CHORADIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${CHORADIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-chora.conf ${HORDE_INC}
@@ -131,6 +127,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/devel/horde-chora/pkg-plist b/devel/horde-chora/pkg-plist
index b5f16266a49e..b20759e18ae8 100644
--- a/devel/horde-chora/pkg-plist
+++ b/devel/horde-chora/pkg-plist
@@ -12,15 +12,10 @@
%%CHORADIR%%/co.php
%%CHORADIR%%/config/.htaccess
%%CHORADIR%%/config/conf.xml
-%%CHORADIR%%/config/cvsgraph.conf
%%CHORADIR%%/config/cvsgraph.conf.dist
-%%CHORADIR%%/config/longIntro.txt
%%CHORADIR%%/config/longIntro.txt.dist
-%%CHORADIR%%/config/mime_drivers.php
%%CHORADIR%%/config/mime_drivers.php.dist
-%%CHORADIR%%/config/prefs.php
%%CHORADIR%%/config/prefs.php.dist
-%%CHORADIR%%/config/sourceroots.php
%%CHORADIR%%/config/sourceroots.php.dist
%%CHORADIR%%/cvs.php
%%CHORADIR%%/cvsgraph.php