aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-01-10 08:01:04 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-01-10 08:01:04 +0800
commit60a8c14fc5be9a19b0d2462b1442c349b52129a2 (patch)
treec784732b7393abfde0e2059390feba05076d5f8d /devel
parent9eee1bf94f3fa0ca124c470328a7b8dbf3063f01 (diff)
downloadfreebsd-ports-gnome-60a8c14fc5be9a19b0d2462b1442c349b52129a2.tar.gz
freebsd-ports-gnome-60a8c14fc5be9a19b0d2462b1442c349b52129a2.tar.zst
freebsd-ports-gnome-60a8c14fc5be9a19b0d2462b1442c349b52129a2.zip
- Apply fix for ViewVC issue 445 <http://viewvc.tigris.org/issues/show_bug.cgi?id=445>
http://viewvc.tigris.org/source/browse/viewvc/branches/1.1.x/lib/config.py?view=patch&r1=2316&r2=2317&pathrev=2317 PR: ports/142460 Submitted by: Rob Farmer <rfarmer@predatorlabs.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/viewvc/Makefile1
-rw-r--r--devel/viewvc/files/patch-lib-config.py31
2 files changed, 32 insertions, 0 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index aa87f4233859..ff8b0b6ccef2 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= viewvc
PORTVERSION= 1.1.3
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://viewvc.tigris.org/files/documents/3330/47194/
diff --git a/devel/viewvc/files/patch-lib-config.py b/devel/viewvc/files/patch-lib-config.py
new file mode 100644
index 000000000000..6f17e200d234
--- /dev/null
+++ b/devel/viewvc/files/patch-lib-config.py
@@ -0,0 +1,31 @@
+--- lib/config.py.orig 2010-01-07 10:44:45.000000000 -0800
++++ lib/config.py 2010-01-07 10:44:50.000000000 -0800
+@@ -274,9 +274,7 @@
+ """Overlay per-root options for ROOTNAME atop the existing option
+ set. This is a destructive change to the configuration."""
+
+- # We can only deal with this happening once!
+- assert(self.root_options_overlayed == 0)
+- self.root_options_overlayed = 1
++ did_overlay = 0
+
+ if not self.conf_path:
+ return
+@@ -285,7 +283,17 @@
+ base_section = self._is_allowed_override(self.parser, 'root',
+ rootname, section)
+ if base_section:
++ # We can currently only deal with root overlays happening
++ # once, so check that we've not yet done any overlaying of
++ # per-root options.
++ assert(self.root_options_overlayed == 0)
+ self._process_section(self.parser, section, base_section)
++ did_overlay = 1
++
++ # If we actually did any overlaying, remember this fact so we
++ # don't do it again later.
++ if did_overlay:
++ self.root_options_overlayed = 1
+
+ def _get_parser_items(self, parser, section):
+ """Basically implement ConfigParser.items() for pre-Python-2.3 versions."""