aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1996-10-18 16:38:18 +0800
committermax <max@FreeBSD.org>1996-10-18 16:38:18 +0800
commit646fc14413772761bd348d7c5ba24ea5da6517d7 (patch)
treee78d0a9d66be1eeb5b8373a5e64fe7202bf805e0 /devel
parent34f033ecbab3403b683ca0e849f34cfbea0b1d74 (diff)
downloadfreebsd-ports-gnome-646fc14413772761bd348d7c5ba24ea5da6517d7.tar.gz
freebsd-ports-gnome-646fc14413772761bd348d7c5ba24ea5da6517d7.tar.zst
freebsd-ports-gnome-646fc14413772761bd348d7c5ba24ea5da6517d7.zip
Honor the setting of NOMANCOMPRESS.
Submitted by: "Philippe Charnier" <charnier@xp11.frmug.org> Use ${INSTALL_PROGRAM} and ${INSTALL_MAN} macros instead of install *.
Diffstat (limited to 'devel')
-rw-r--r--devel/mprof/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/mprof/Makefile b/devel/mprof/Makefile
index 99ee2bb1d5b5..13665225873b 100644
--- a/devel/mprof/Makefile
+++ b/devel/mprof/Makefile
@@ -3,7 +3,7 @@
# Date created: Sat Nov 5 01:16:33 PST 1994
# Whom: hsu
#
-# $Id: Makefile,v 1.5 1995/04/24 11:01:33 asami Exp $
+# $Id: Makefile,v 1.6 1995/11/26 11:29:14 asami Exp $
#
DISTNAME= mprof-3.0
@@ -15,9 +15,11 @@ WRKSRC= ${WRKDIR}
MAKEFILE= Makefile.i386
do-install:
- install -c -s -m 555 ${WRKSRC}/mprof ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mprof ${PREFIX}/bin
install -c -m 555 ${WRKSRC}/libc_mp.a ${PREFIX}/lib
- install -c -m 555 ${WRKSRC}/mprof.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/mprof.1 ${PREFIX}/man/man1
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/mprof.1
+.endif
.include <bsd.port.mk>