aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-02-09 19:43:38 +0800
committerale <ale@FreeBSD.org>2004-02-09 19:43:38 +0800
commit64c967a3b7bc5eff3ae52eb167cf7cae1d817643 (patch)
tree5a5b7919d0c88fe51071c6e66890b4b3fd4e7bf7 /devel
parentb6a56540b211f28c52e6af62d7ac3d5a3e01a34c (diff)
downloadfreebsd-ports-gnome-64c967a3b7bc5eff3ae52eb167cf7cae1d817643.tar.gz
freebsd-ports-gnome-64c967a3b7bc5eff3ae52eb167cf7cae1d817643.tar.zst
freebsd-ports-gnome-64c967a3b7bc5eff3ae52eb167cf7cae1d817643.zip
Remove lang/php4/bsd.php.mk and switch every ports depending on PHP to
use Mk/bsd.php.mk. Approved by: nork (mentor/implicitly)
Diffstat (limited to 'devel')
-rw-r--r--devel/ZendOptimizer/Makefile2
-rw-r--r--devel/pear-apd/Makefile2
-rw-r--r--devel/php-dbg/Makefile7
-rw-r--r--devel/php-dbg2/Makefile7
-rw-r--r--devel/php-xdebug/Makefile6
5 files changed, 10 insertions, 14 deletions
diff --git a/devel/ZendOptimizer/Makefile b/devel/ZendOptimizer/Makefile
index 8c0989976851..4d0585fa7c94 100644
--- a/devel/ZendOptimizer/Makefile
+++ b/devel/ZendOptimizer/Makefile
@@ -15,6 +15,7 @@ COMMENT= An optimizer for PHP code
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
+USE_PHP= yes
BROKEN_WITH_PHP=5
RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
@@ -23,7 +24,6 @@ NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
# Check for FreeBSD version
.if ${OSVERSION} >= 500000
diff --git a/devel/pear-apd/Makefile b/devel/pear-apd/Makefile
index 65a9700ff0fb..1c24940b2359 100644
--- a/devel/pear-apd/Makefile
+++ b/devel/pear-apd/Makefile
@@ -15,12 +15,12 @@ COMMENT= A full-featured engine-level PHP profiler/debugger
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apd
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/php4/bsd.php.mk"
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
diff --git a/devel/php-dbg/Makefile b/devel/php-dbg/Makefile
index ad9d514de42c..04f6fde5f2e1 100644
--- a/devel/php-dbg/Makefile
+++ b/devel/php-dbg/Makefile
@@ -15,13 +15,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= rehsack@liwing.de
COMMENT= Debugger for PHP4
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-dbg=shared --with-dbg-profiler
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-build:
@${SED} "s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -33,4 +31,5 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/devel/php-dbg2/Makefile b/devel/php-dbg2/Makefile
index ad9d514de42c..04f6fde5f2e1 100644
--- a/devel/php-dbg2/Makefile
+++ b/devel/php-dbg2/Makefile
@@ -15,13 +15,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= rehsack@liwing.de
COMMENT= Debugger for PHP4
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-dbg=shared --with-dbg-profiler
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-build:
@${SED} "s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -33,4 +31,5 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/devel/php-xdebug/Makefile b/devel/php-xdebug/Makefile
index 259eb39e5610..27ea39a3fc9a 100644
--- a/devel/php-xdebug/Makefile
+++ b/devel/php-xdebug/Makefile
@@ -15,13 +15,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= rehsack@liwing.de
COMMENT= Xdebug extension for PHP
+USE_PHP= yes
USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-xdebug --with-php-config=${PREFIX}/bin/php-config
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-
post-build:
@${SED} "s|%%PREFIX%%|${PREFIX}|g;s|%%PHP_EXT_DIR%%|${PHP_EXT_DIR}|g" \
< ${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -34,4 +32,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>