aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-11-15 09:23:27 +0800
committeralane <alane@FreeBSD.org>2002-11-15 09:23:27 +0800
commit688f4508b89e33471bb31a530062cbdf40af4cbc (patch)
tree2295a823718fec1309bbe3f6e9f3f1c6fa02f222 /devel
parent73113c775acb6373dbb3b4b98c55363a0e75589c (diff)
downloadfreebsd-ports-gnome-688f4508b89e33471bb31a530062cbdf40af4cbc.tar.gz
freebsd-ports-gnome-688f4508b89e33471bb31a530062cbdf40af4cbc.tar.zst
freebsd-ports-gnome-688f4508b89e33471bb31a530062cbdf40af4cbc.zip
Make port forbidden if perl is above 5.6.0.
PR: 44719 Approved by: maintainer timeout
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-File-Spec/Makefile20
-rw-r--r--devel/p5-PathTools/Makefile20
2 files changed, 38 insertions, 2 deletions
diff --git a/devel/p5-File-Spec/Makefile b/devel/p5-File-Spec/Makefile
index 1c828d9aad7f..c49d3487bee4 100644
--- a/devel/p5-File-Spec/Makefile
+++ b/devel/p5-File-Spec/Makefile
@@ -25,4 +25,22 @@ MAN3= File::Spec.3 \
File::Spec::Win32.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+perl_major=${PERL_VERSION:C|^([1-9]+).*|\1|}
+_perl_minor=00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
+perl_minor=${_perl_minor:C|^.*(...)|\1|}
+.if ${perl_minor} >= 100
+perl_minor=${PERL_VERSION:C|^([1-9]+)\.([0-9][0-9][0-9]).*|\2|}
+perl_patch=${PERL_VERSION:C|^.*(..)|\1|}
+.else # ${perl_minor} < 100
+_perl_patch=0${PERL_VERSION:C|^([1-9]+)\.([0-9]+)\.*|0|}
+perl_patch=${_perl_patch:C|^.*(..)|\1|}
+.endif # ${perl_minor} < 100
+PERL_LEVEL=${perl_major}${perl_minor}${perl_patch}
+
+.if ${PERL_LEVEL} > 500600
+FORBIDDEN= This port is for perl 5.6.0 and under only.
+.endif # ${PERL_LEVEL} > 500600
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-PathTools/Makefile b/devel/p5-PathTools/Makefile
index 1c828d9aad7f..c49d3487bee4 100644
--- a/devel/p5-PathTools/Makefile
+++ b/devel/p5-PathTools/Makefile
@@ -25,4 +25,22 @@ MAN3= File::Spec.3 \
File::Spec::Win32.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+perl_major=${PERL_VERSION:C|^([1-9]+).*|\1|}
+_perl_minor=00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
+perl_minor=${_perl_minor:C|^.*(...)|\1|}
+.if ${perl_minor} >= 100
+perl_minor=${PERL_VERSION:C|^([1-9]+)\.([0-9][0-9][0-9]).*|\2|}
+perl_patch=${PERL_VERSION:C|^.*(..)|\1|}
+.else # ${perl_minor} < 100
+_perl_patch=0${PERL_VERSION:C|^([1-9]+)\.([0-9]+)\.*|0|}
+perl_patch=${_perl_patch:C|^.*(..)|\1|}
+.endif # ${perl_minor} < 100
+PERL_LEVEL=${perl_major}${perl_minor}${perl_patch}
+
+.if ${PERL_LEVEL} > 500600
+FORBIDDEN= This port is for perl 5.6.0 and under only.
+.endif # ${PERL_LEVEL} > 500600
+
+.include <bsd.port.post.mk>