aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2012-06-01 01:01:28 +0800
committernobutaka <nobutaka@FreeBSD.org>2012-06-01 01:01:28 +0800
commit6e07aaa0dff8b875c32bedd99848bfbbab114666 (patch)
tree9ad9796048c2b068ebf5db322894e5d4afce9582 /devel
parentfccc8bf59f2f90d8aaf6dffaee079b61910693d6 (diff)
downloadfreebsd-ports-gnome-6e07aaa0dff8b875c32bedd99848bfbbab114666.tar.gz
freebsd-ports-gnome-6e07aaa0dff8b875c32bedd99848bfbbab114666.tar.zst
freebsd-ports-gnome-6e07aaa0dff8b875c32bedd99848bfbbab114666.zip
Add libewf, a library for support of the Expert Witness Compression Format
(EWF).
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libewf/Makefile39
-rw-r--r--devel/libewf/distinfo2
-rw-r--r--devel/libewf/files/patch-Makefile.in11
-rw-r--r--devel/libewf/pkg-descr6
-rw-r--r--devel/libewf/pkg-plist24
6 files changed, 83 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9b4d1d84d4ae..03451b03e71e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -862,6 +862,7 @@
SUBDIR += libev
SUBDIR += libevent
SUBDIR += libevent2
+ SUBDIR += libewf
SUBDIR += libexecinfo
SUBDIR += libexplain
SUBDIR += libffi
diff --git a/devel/libewf/Makefile b/devel/libewf/Makefile
new file mode 100644
index 000000000000..01ee0e944dd4
--- /dev/null
+++ b/devel/libewf/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libewf
+# Date created: 31 May 2012
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libewf
+PORTVERSION= 20120504
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= nobutaka@FreeBSD.org
+COMMENT= A library for support of the Expert Witness Compression Format (EWF)
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ fuse:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+USE_LIBTOOL= yes
+USE_OPENSSL= yes
+USE_PYTHON= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26
+
+MAN1= ewfacquire.1 ewfacquirestream.1 ewfexport.1 \
+ ewfinfo.1 ewfmount.1 ewfverify.1
+MAN3= libewf.3
+
+.include <bsd.port.mk>
diff --git a/devel/libewf/distinfo b/devel/libewf/distinfo
new file mode 100644
index 000000000000..4ff6a29df483
--- /dev/null
+++ b/devel/libewf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libewf-20120504.tar.gz) = f5d247af4714d6270b8c414f9b1bccfdf28b5073753900cfc00a03ec26757b88
+SIZE (libewf-20120504.tar.gz) = 1556165
diff --git a/devel/libewf/files/patch-Makefile.in b/devel/libewf/files/patch-Makefile.in
new file mode 100644
index 000000000000..67ca6b3037e1
--- /dev/null
+++ b/devel/libewf/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2012-05-03 11:34:09.000000000 +0900
++++ Makefile.in 2012-05-03 11:36:34.000000000 +0900
+@@ -460,7 +460,7 @@
+ MAINTAINERCLEANFILES = \
+ Makefile.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = \
+ libewf.pc
+
diff --git a/devel/libewf/pkg-descr b/devel/libewf/pkg-descr
new file mode 100644
index 000000000000..1ccaadaf4e03
--- /dev/null
+++ b/devel/libewf/pkg-descr
@@ -0,0 +1,6 @@
+Libewf is a library for support of the Expert Witness Compression Format
+ (EWF), it support both the SMART (EWF-S01) and EnCase (EWF-E01) format.
+Libewf allows you to read and write EWF files. Recent versions also
+support the LEV (EWF-L01) format.
+
+WWW: http://sourceforge.net/projects/libewf/
diff --git a/devel/libewf/pkg-plist b/devel/libewf/pkg-plist
new file mode 100644
index 000000000000..5bed5b48092c
--- /dev/null
+++ b/devel/libewf/pkg-plist
@@ -0,0 +1,24 @@
+bin/ewfacquire
+bin/ewfacquirestream
+bin/ewfdebug
+bin/ewfexport
+bin/ewfinfo
+bin/ewfmount
+bin/ewfrecover
+bin/ewfverify
+include/libewf.h
+include/libewf/codepage.h
+include/libewf/definitions.h
+include/libewf/error.h
+include/libewf/extern.h
+include/libewf/features.h
+include/libewf/types.h
+lib/libewf.a
+lib/libewf.la
+lib/libewf.so
+lib/libewf.so.2
+%%PYTHON_SITELIBDIR%%/pyewf.a
+%%PYTHON_SITELIBDIR%%/pyewf.la
+%%PYTHON_SITELIBDIR%%/pyewf.so
+libdata/pkgconfig/libewf.pc
+@dirrm include/libewf