aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-12 23:57:41 +0800
committermiwi <miwi@FreeBSD.org>2007-12-12 23:57:41 +0800
commit70a9fc164425f21f5df7478a84601f5ce2651565 (patch)
treefc92b1bb45ac076c38e11dda63bc6a012d705141 /devel
parent8b1756afa5162f5c3cf621f5f6e627806c5a881a (diff)
downloadfreebsd-ports-gnome-70a9fc164425f21f5df7478a84601f5ce2651565.tar.gz
freebsd-ports-gnome-70a9fc164425f21f5df7478a84601f5ce2651565.tar.zst
freebsd-ports-gnome-70a9fc164425f21f5df7478a84601f5ce2651565.zip
The shape extension wraps libshape and provides the ability to write programs
for manipulating ESRI shapefiles. WWW: http://pecl.php.net/package/shape/ - Ditesh Shashikant Gathani ditesh@gathani.org PR: ports/118064 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-shape/Makefile31
-rw-r--r--devel/pecl-shape/distinfo3
-rw-r--r--devel/pecl-shape/pkg-descr7
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 76541d844344..25ac9bd89050 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1797,6 +1797,7 @@
SUBDIR += pecl-json
SUBDIR += pecl-operator
SUBDIR += pecl-runkit
+ SUBDIR += pecl-shape
SUBDIR += pecl-statgrab
SUBDIR += pecl-svn
SUBDIR += pecl-uploadprogress
diff --git a/devel/pecl-shape/Makefile b/devel/pecl-shape/Makefile
new file mode 100644
index 000000000000..5f9800cc9e07
--- /dev/null
+++ b/devel/pecl-shape/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pecl-shape
+# Date created: 15 Nov 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shape
+PORTVERSION= 0.9.1
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A PECL extension that wraps libshape
+
+LIB_DEPENDS= shp:${PORTSDIR}/devel/shapelib
+
+USE_PHP= yes
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+PHP_MODNAME= shp
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|include/libshp|include|g' ${WRKSRC}/config.m4
+ @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/config.m4
+ @${REINPLACE_CMD} -e 's|include "libshp/|include "|g' ${WRKSRC}/php_shp.h
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-shape/distinfo b/devel/pecl-shape/distinfo
new file mode 100644
index 000000000000..333eee944da7
--- /dev/null
+++ b/devel/pecl-shape/distinfo
@@ -0,0 +1,3 @@
+SHA256 (PECL/shape-0.9.1.tgz) = f40723324e0483a255e960975d7bfe01e1f52ab520754f311cd9809bc82acc22
+MD5 (PECL/shape-0.9.1.tgz) = a1d5143a4ce455131a3d3a6dc3fff2ed
+SIZE (PECL/shape-0.9.1.tgz) = 8514
diff --git a/devel/pecl-shape/pkg-descr b/devel/pecl-shape/pkg-descr
new file mode 100644
index 000000000000..dad5d510095b
--- /dev/null
+++ b/devel/pecl-shape/pkg-descr
@@ -0,0 +1,7 @@
+The shape extension wraps libshape and provides the ability to write programs
+for manipulating ESRI shapefiles.
+
+WWW: http://pecl.php.net/package/shape/
+
+- Ditesh Shashikant Gathani
+ditesh@gathani.org